Xiaomi / Aqara ZigBee device drivers (possibly may no longer be maintained)

That's done the trick @bobbles. Brilliant help, appreciated

1 Like

@andre-berlin yes please I'd still like the drivers please.

Perhaps not the best topic to be chatting on as the drivers that you modified are Markus' drivers, so I'll tag you on the thread there

Xiaomi Smart Home Mijia Honeywell Smoke Detector:

After connecting the device and installing the driver I can access my new device. :+1:

The first “Test” command works, after a while the battery status (100%) is shown, and even my push on the little button of my device raised a smoke=“testing…” event in Hubitat.

Great! But…

I’ve noticed that the log is now flooded with “Parse START” messages; The lastClear state is set 10 to 20 times a minute! I fear that the battery will be fast drained...

Any suggestions?

Thanks very much for this - needed a driver for an Aqara motion sensor and vibration sensor, worked perfectly!

HI there, Thanks for all your help with these drivers! I was looking at this thread but theres a lot here... and I couldn't nail a solution down..

I am trying to figure out how to set the sensitivity of my Aqara vibration sensors.... I can practically knock them over and they don't pick up....

Thank you for any help!

Unfortunately, you can't with these drivers. The smarthings contact sensor is much more sensitive but is no longer available. (It can be done if you're using zigbee2mqtt or deconz platforms but that's another story altogether.)

1 Like

Thanks for the reply....Oh man I just got these.... is there way to set the sensitivity when connected to Mi home and have it "stick" when connected to Hubitat? I was avoiding mi-connector...maybe you can point me the direction of zigbee2mqtt

any other drivers U can suggest I try?

check @chirpy's drivers here. I haven't used them (yet) but may have that.

Otherwise https://www.zigbee2mqtt.io/ with this particular note Set sensitivity of the Aqara Vibration sensor · Issue #3028 · Koenkk/zigbee2mqtt · GitHub.

If you search for deconz you should be able to find similar resources quite easily. Both these solutions will require a middleman (eg raspberry pi) and additional zigbee sticks which may be overkill.

I don't know although it "may" be possible if the sensitivity is set within the device. I guess you can test this with the app.

Otherwise look for a used smartthings contact sensor somewhere or another brand device. Suggest you open a new thread asking for advice on such sensors to get a wider audience.

Thank you for the direction.... I may have to return these... I do have an RPI running Hoobs....have to weigh whether this is worth the effort....

I keep beating on Hubitat and Homekit solutions for washer/dryer notifications...I am using a smartthings plug and an eve plug with power metering but I was hoping a couple vibration sensors would make it easier.....

There are a couple of community apps written to use power plugs for washing machine notification if you haven't already seen them. You might want to check those out.

Thanks I have a couple of Shelly plugs I preordered that should ship soon by recommendation on here but did not know about the apps.... I will check those out thanks for the tip...but I had high hopes for these things for even a mailbox or dishwasher but they aren’t even playing well with rules when they do trigger so I might play with it a bit more till I get my Shellys.... and if I don’t find good use I’ll return them.

There have been also some projects posted for mailbox alerts too!

1 Like

@X-RayVision I use the drivers that were originally written by Marcus. They are no longer maintained but it does allow to set the sensitivity of the Aqara vibration sensor. Note it can be a bit fiddly. You set it in the driver but it may not change until you reset the device.

1 Like

Oh wow....Can you link me? I can’t seem to find the vibration sensor.

@X-RayVision Of course. See post 1 in this chain for the individual links. [Release] Xiaomi / Aqara / Opple Drivers with Presence!

1 Like

I don’t how I could not find it b4. Thanks! Just switching to this already seems more sensitive ... so once set, the sensitivity actually shows in current states? When it says to push the reset button it means the button on the actual sensor I assume tried that a couple times and did a disconnect and sensitivity didn’t seem to show up... I’ll keep fiddling.

Yes it can be a bit of a pain. I think last time I changed it, it had to delete the device and the search for it again. Also found that Aqara devices connect better we really close to the hub.

Hi guys,

I have some Aqara without neutral switch 1 and 2 button and work OK. Now I buy another 1 and look new designs and my V1 button is not working, if I press manually is working but from the application NO.
This is the difference

I suppose need new or change old driver, anybody have some idea how to fix this?

Thk,
N

I too have the same issue where there is no wet/dry status shown in the "Current States" section Hubitat.
4 out of 6 new water leak sensors are not reporting wet/dry status like this.

Driver:

  • Xiaomi Aqara Leak Sensor - model SJCGQ11LM
  • Device Driver for Hubitat Elevation hub
  • Version 0.8

Log:
sys:12021-06-24 06:22:18.528 pm Zigbee Discovery Stopped
dev:212021-06-24 06:21:25.688 pm debugWater Leak sensor6: Creating event [name:battery, value:100, unit:%, descriptionText:Battery level is 100% (3.065 Volts)]
dev:212021-06-24 06:21:25.686 pm infoWater Leak sensor6: Battery level is 100% (3.065 Volts)
dev:212021-06-24 06:21:25.674 pm debugWater Leak sensor6: Battery parse string = 220121F90B0328260421A80105213F0006240100000000082106020A2159D1641000
dev:212021-06-24 06:21:25.672 pm debugWater Leak sensor6: Message payload: 220121F90B0328260421A80105213F0006240100000000082106020A2159D1641000
dev:212021-06-24 06:21:25.664 pm debugWater Leak sensor6: Parsing message: read attr - raw: C26C0100004A01FF42220121F90B0328260421A80105213F0006240100000000082106020A2159D1641000, dni: C26C, endpoint: 01, cluster: 0000, size: 4A, attrId: FF01, encoding: 42, command: 0A, value: 220121F90B0328260421A80105213F0006240100000000082106020A2159D1641000
dev:212021-06-24 06:21:24.845 pm debugWater Leak sensor6: Reset button was short-pressed
dev:212021-06-24 06:21:24.843 pm debugWater Leak sensor6: Message payload: 156C756D692E73656E736F725F776C65616B2E61713101002006
dev:212021-06-24 06:21:24.825 pm debugWater Leak sensor6: Parsing message: read attr - raw: C26C0100003A050042156C756D692E73656E736F725F776C65616B2E61713101002006, dni: C26C, endpoint: 01, cluster: 0000, size: 3A, attrId: 0005, encoding: 42, command: 0A, value: 156C756D692E73656E736F725F776C65616B2E61713101002006
dev:212021-06-24 06:21:24.792 pm errorjava.lang.NullPointerException: Cannot invoke method getAt() on null object on line 80 (parse)
dev:212021-06-24 06:21:24.770 pm debugWater Leak sensor6: Parsing message: catchall: 0000 0013 00 00 0040 00 C26C 00 00 0000 00 00 9F6CC258A5B706008D150080
sys:12021-06-24 06:21:24.558 pm Found Previously Joined Zigbee Device Water Leak sensor6
dev:212021-06-24 06:21:24.542 pm infoWater Leak sensor6: Configuring
sys:12021-06-24 06:21:18.516 pm Zigbee Discovery Running

Current States:
#### Current States

* battery : **100**
* batteryLastReplaced : **Wed Jun 23 19:30:54 EDT 2021**
* lastCheckinEpoch : **1624576340153**
* lastCheckinTime : **Jun 24, 2021 7:12:20 PM**

Hi,

I have the aqara outlet and I would like to know if there is a way of having a power-off memory in the case of an electrical cut-off. Thanks for any help!

Download the Hubitat app