Xiaomi / Aqara ZigBee device drivers (possibly may no longer be maintained)

Yes same as mine. Except when the temperature or humidity changes a certain amount as mentioned above. For temperature measurements where you want to refresh when I need it I use the SmartThings sensors as a refresh of them updates the sensor.. But not for the xiaomi. Although they respond reasonably quickly when a large change in temp or humidity I found.

1 Like

OK. Here's a question for anyone using these devices.
Can I ask what driver you are using?
Are you getting battery, humidity and temperature OK.
Thanks in advance.

Yes it does report battery, humidity and temperature. I'm using Konke Zigbee Temperature humidity sensor driver (that I found in its community page). you just need to set the correct voltage to get the correct battery percentage.
This device also works with Xiaomi temperature/humidity sensor driver

1 Like

Thanks for the response @andrenn23.
I've tried it but didn't get any battery reports.
I'll try it again and leave it overnight and see what happens.
I get too impatient!!!!!!
Thanks again.

Hi @andrenn23. Sorry to be a pain, but could you either look at your logs to see if you are getting any errors or post the driver you are using.
I'm seeing this error so was wondering if you are seeing the same.

Use this and it works perfectly.

I'm liking these devices! Thank you OP for putting all device drivers together!!

I have the Temp/Rh sensor, a few contact sensors (and more on the way!), and a motion sensor on also on the way. I'm replacing iris devices which were always loosing comm

First off, great drivers!

I have purchased the Xiaomi door Window Sensor Intelligent Mini Door Sensor Pocket Size and they work great with the Door/Window driver published on this thread.

I’m using these inside my crank style windows. They are really small! Small enough to fit in the casing which is great!

I installed the first of many before installing the driver. Had to press the button 2-3 times for it to register, but it worked. They were recognized after the first press, and the registration completed after the 2 or 3rd press. I noticed that it didn’t seem to complete (allow me to enter the device name) unless I pressed the button more than once.

Once completed, it registered as a device, but after installing the driver, the switch to the new driver was seamless and worked great!

The other devices were installed using the same process, but since the driver was now present, it picked-it up automatically.

After some time however, they disconnect from the network. I suspect it is because they get relayed through my Zigbee thermostats... I have multiple Zigbee sensors and also some Sinopé thermostats, all on Channel 20. I read in this thread that there could be an issue when the signal got routed through other devices. I’m able to reconnect them, but they all disconnect again, so I will look for another solution...

I have a second hub and will try linking them to that hub instead - it has no other Zigbee devices on it. Just hoping the sensors are not too far! (The hub is in a central location, so fingers crossed!)

I’ll provide an update once I have made progress. Also, input is always appreciated!

Have you tried if my driver keep them on the mesh better?

1 Like

I’ll have to look into that! Do you have a link to it? (I’ll start looking for it as soon as I’m done writing this!)

For some reason it doesn't show easily when searching for Xiaomi / Aqara, but here it is:


Will try it now and let you know how it goes in that thread. Thanks!

Just saw this in my logs. Might it be an unsupported temp/humidity version? :

Unhandled Event PLEASE REPORT TO DEV - description:catchall: 0104 0402 01 01 0040 00 BE77 00 00 0000 01 01 | msgMap:[raw:catchall: 0104 0402 01 01 0040 00 BE77 00 00 0000 01 01 , profileId:0104, clusterId:0402, clusterInt:1026, sourceEndpoint:01, destinationEndpoint:01, options:0040, messageType:00, dni:BE77, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:01, direction:01, data:[]]

This is just a broadcast message that can be ignored, it has been added to the next release. Thank you for reporting, which model is this?

It's a Xiaomi temp/humidity, round with a push button (not recessed).

Ok, I've never seen them send this before. Next release this will be filtered.


I recently moved my 3 buttons from the Mi Home gateway, just to try things out, and all 3 dropped off the zigbee network within 12 hours. They are spread round the house so I'm pretty sure that mesh is not the problem.
Model number is WXKG01LM.
I haven't done any investigations yet but was just wondering if anyone else has seen issues with these devices.

Found this in the past logs for one of the devices.


If you’re still experiencing issues, @gavin_robinson, I would bet my cat (I don’t have one) that it’s the wired Aqara wall switches giving you trouble. On my network things would randomly drop and stop responding. I took @markus advice to try without the wall switches in the network and everything is now working perfectly, including all of my Xiaomi battery devices alongside AlertMe and Tradfri kit.

I’m going to wait for his driver and keep them off this network for now. To stop them trying to reattach, because I can’t turn them off, I had to change Zigbee channel.

The setup is so reliable now I’m tempted to replace some physical switches with Xiaomi Aqara wireless wall switches and wire the ceiling lights on permanently with Tradfri lamps.

What other devices do you have on your Hubitat mesh? I have the WXKG03LM and WXKG11LM, so I don't have a direct comparison, but my recent experience just above has been that other, seemingly compatible, devices have caused issues.

My motion sensors, contact sensors and humidity/temp sensors, Xiaomi and Aqara, are rock solid. It's just these darn buttons. All devices are spread throughout the house which leads me away from the mesh.
This is why I asked specifically about the buttons.
I'll crack it. :+1:
EDIT. One of the buttons is now holding up ok. It's been 18hrs and all is good.
Getting closer. :wink:

EDIT 2. I even have a temp sensor in a freezer in my detached garage that is working brilliantly. I didn't realise they worked at -16.8 C!