Xiaomi & Aqara Devices - Pairing & Keeping them connected

I haven’t messed around with Zigbee channels at all. Still on 26, but devices that were a breeze to pair last week from 20ft away, are now not pairing 1-inch from the stick. Either they don’t get found or they get stuck in initializing for 30 minutes before I give up.

What was a cakewalk is now turning into the walking dead. Me walking “dead” Xiaomi devices to the hub to no avail.

Some further information from a quick search:

SmartThings brand Zigbee devices don't seem to work well on higher channels.

Zigbee channels 11 to 22 occupy the same frequencies as 2.4GHz WiFi channels 1, 6, and 11:

(Information / image credit: ZigBee and WiFi Coexistence, by Joel Crane on MetaGeek Support)

Also from part two of that same article by Joel Crane, the "sideband lobes" of each WiFi channel need to be considered if your WiFi and Zigbee radios are in close proximity. And... if you are using multiple 2.4GHz WiFi access points in your home on different channels, then the Zigbee channel preferably should be outside the channels used by the APs - which is only possible if you're using two neighboring non-overlapping 2.4GHz WiFi channels (1&6 or 6&11).

Based on all of this, I'm going to need to move away from Zigbee channel 26 for my Hubitat, because I'll be moving more non-Xiaomi Zigbee devices over soon. I only have one WiFi router, centrally located in the same room with my ST and Hubitat hubs in my relatively home. So after checking what channels my neighbors seem to be using I will either set my WiFi router's 2.4GHz WiFi radio to permanently use channel 1 and make sure my ST and Hubitat hubs are on a Zigbee channel between 19-24 or set my 2.4GHz WiFi to channel 11 and Zigbee channels between 11-16.

2 Likes

Great info. I have 3 Ubiquiti APs now all running on channel 11 and Hubitat is on 12 so they should be far enough apart that interference shouldn’t be an issue (I hope). I still have the ST HUB on channel 20. Ultimately, I would like to turn off the zigbee radio for the ST HUB too but I can’t for now. Still have my Spruce sprinkler system that I can’t port over to Hubitat yet.

Interesting info. My Xiaomi leak sensor has been staying connected, no problem. I’m using Zigbee channel 13 which was chosen for me when I setup Hubitat. I love the irony that channel 13 is working perfectly. I’m going to go knock on some unfinished wood now!

Oh boy, and it just gets more complicated.

So my WiFi router is a NETGEAR dual-band R6400, but if the 2.4GHz WiFi radio is set for its high speed mode (up to 450Mbps) then it actually needs two 20MHz bands, which requires two channels - primary and secondary. For my NETGEAR router there are preset primary and secondary channel pairs that can’t be changed. So for example, if I set the 2.4GHz WiFi radio channel to 11, then the secondary channel is 7. Luckily I don’t have any additional APs, so after checking the channels used by neighbors, here’s what I am going to try:

  • 2.4GHz WiFi radio set to primary channel 11 (and secondary channel 7) because my nearest neighbors are using channel 6 and more distant neighbors using channel 1.
  • SmartThings Hub Zigbee set to channel 15 (leaving as is because I’m moving all Zigbee off anyhow)
  • Hubitat Zigbee set to channel 13 (which should be totally clear of my 2.4GHz WiFi radio channels 11 & 7, and also neighbors using channel 6, but with no idea whether their secondary channels - if used - were shown in the utility I used)

So it seems I’m going to go with @SmartHomePrimer’s “lucky” channel 13 and will report back next week as to how it goes.

1 Like

no both Hubitat and SmartThings are now on the same channel (20) I believe to get SmartThings to change channel you have to to do a full hard reset (little red push button on hub) but I have not done that.
I believe both hubs simply choose which ever channel they see as having the least noise at the time when you first setup the hub. They do not auto change after.
but that doesn’t mean all different devices will work with that channel from what I am seeing.

on a side note I am having some luck with another repeater (with the Xiaomi) the SYLVANIA plug or north of the wall (Canada) sylvania plug for a much cheaper and easier way to add a repeater. But it has only been 2 days so far with out issues. and no doubt about the UL certificatrion.

I also am noticing some devices will not re-pair to a different repeater or back to the hub if the original repeater it paired through fails or drops the device . Running a test with my SmartThings Arrival zigbee sensor to confirm.
So basically depending on the device just throwing up more repeaters will not extend the range of a device you have to make sure you pair through the repeater at the outer most range that you want to use.
again I do have devices that do re pair like the SmartThings door sensors but Arrival sensors do not appear to (will confirm in a couple of days) nor does Xiaomi .

note: if changing zigbee channels save a back up of your hub first as it can mess up your zigbee option and cause you to do a full zigbee reset and have to re-pair all of your zigbee devices. But instead if it does just fail back over to your saved backup and then you do not have to re-pair all your zigbee device.

I have not tested all the channels to see which work better so far only 20,21,25,26 but maybe 13 is the lucky one it all really depends on what devices you have

1 Like

Ch. 18 works fine with my original round buttons.

:rofl:

Thanks again for all the detailed reports on your continuing tests to find a suitable repeater for all your Zigbee devices.

I looked through the customer reviews on the SYLVANIA plug of Amazon’s (South of Wall) site, and saw this one interesting comment from Jan 8 2018:

There are two models of this device; the 72922 and the 72922-A. If you receive a 72922 , it will readily be recognized as a Sylvania Lightify outlet. If you receive a 72922-A, depending upon how “smart” your hub is; you may receive a pairing error. In my case, I have a Wink 2 Hub. Pairing a model 72922-A as a Lightify outlet resulted in a pairing error, but when I checked the hub’s Home page, it was registered as a “Generic Zigbee Light Bulb.”

Do you know which model you have, and also how easily did it pair?

Indeed, and the only information I’ve found on so far on best or better choices is - as I mentioned above - higher channels don’t work well with SmartThings brand Zigbee devices, and generally channel 26 is not a good choice as some devices just won’t work with it.

Speaking of channel choices, when I got home, 8 hours after changing my Hubitat’s Zigbee channel to 13, I found that none of my Zigbee devices seemed to have changed over to the new channel.

I got tired of waiting, and started with the least invasive method of getting them reconnected. My Sengled Classic smart bulbs just needed me to press the configure command button in the Hubitat device details page for each of them, and then they were working fine.

However, for all my Xiaomi devices, I found that short-pressing their reset button to get them reconnected only worked with about 1/3 of them.

For the others, the LED flash sequence on short-press of the reset button told me that they had lost their connection. I had to put the Hubitat into Discover Devices mode and then long-press the reset button (same as what’s done to pair them). Keeping either the Log or Zigbee Log window open helped for me to know whether they had reconnected.

For most of those devices, they were reconnected on the first long-press of reset button, but there were a few devices that took a number of attempts to get recognized again, the worst ones being my 2-button Aqara Wireless Smart Switches (model WXKG02LM). They weren’t easy to pair in the first place, so no surprise there.

So still disconnecting with all my wifi AP on channel 11 and zigbee on 12. I changed the zigbee channel to 12 this morning and so far the two Xiaomi sensors and three other devices found the HUB. Wonder how long before everyone else join the party.

Try Zigbee channel 13 and let everyone know how it goes.

If you’re not keen on my “lucky” 13 theory :wink:
Here’s a discussion along with some sensible advice from @JDRoberts

so I made the change to channel 13 3 hours ago and still no device is reporting in. How long does it usually take?

It can take up to 24 hours or longer depending on the device. It usually should be less than 60 minutes for most devices depending on their reporting frequency.

I would NOT recommend disabling and re-enabling Zigbee Radio nor rebooting immediately after changing the channel. You need to just give it time to update all the devices that the channel has changed.

2 Likes

Thanks @patrick. I changed the channel back to 12 and a lot of the devices started reporting immediately.

Will update my previous post to reflect your advice.

1 Like

Just received my second Xiaomi Aqara leak sensor today. I can confirm that once again, pairing was absolutely no problem using the following sequence:

  1. Hold pairing button for 10 seconds and release
  2. Wait 3 seconds, then double short-press pairing button
  • Sensor shows up with “Initializing”
  1. Wait 3 more seconds and double short-press paring button again
  • Sensor successfully paired and also automatically selected the Xiaomi driver (already installed).
  1. Saved and tested. Wet detected immediately.

I’m going to test this one in the basement to see if it drops off. It’s actually not far from the hub, maybe 25 linear feet.

2 Likes

As Xiaomi devices are designed to work with a Xiaomi hub, I wouldn’t be surprised that they don’t reconnect to the Hubitat after a change of Zigbee channel. Some manual “prodding” may be necessary (as I found I needed to do in my circumstances).

That article on MetaGeek Support by Joel Crane that I linked to a few posts up makes it clear that for best performance of 2.4GHz WiFi and Zigbee Mesh networks in the same space, some planning and testing of an optimal choice of channels may be necessary.

I figure that if I can determine which channel works in keeping all of my Zigbee devices connected all the time, it will be worth the effort.

1 Like

I have the 72922
The hubs (SmartThings and Hubitat) see the device very easily but pairing correctly was a bit hit and miss. You have to make sure the plug functions and reponds to commands correctly. If it does not pair correctly it initially appears correct but does not respond to commands or sometimes only partial commands (ex. on but not off).
To pair it you put the hub in discovery mode, hold the button and then plug it into the wall and keep holding the button until you hear a click. The hub should see it right away. (it may take 3-4 attempts to pair correctly)
I would still like to let this run 3-4 more days to confirm nothing falls off. Usually unplugging and replugging the device back it is fine but once it did fall asleep when I put back in. Similar to the Xiaomi to wake it up I had to put the hub in discover mode and with the plug still plugged in just push and hold the plug button until it clicked and the plug woke up. I had to the same to the Xiaomi devices I had running through it at the time, With out having to re-pair them. They may have come back by themselves but I want to run a week long test with out touching them to see if everything stays connected.
I wonder what range of channels the Xiaomi hub uses.

I have also noticed 99.9% of the time devices when pairing will always go to the repeater device versus the hub. The key is making sure they go to the repeater you want.

DH for the SYLVANIA plug


replace physicalgraph with hubitat
the generic zigbee plug or switch DH would work but always leaves the plug status as unknown and it would not log any events (maybe due to not pairing correctly).

1 Like

I’m not sure if this has been mentioned yet, but Xiaomi devices can be added by monitoring the Zigbee logs and manually entering the DNI using the Add Virtual Device option.

I have used this in cases where the device fails to initialize.

1 Like

Just to update on the progress. My hubitat is back to running on channel 12 and all 3 Ubiquiti APs are running on channel 11. Both Xiaomi sensors have been performing great with hourly updates. It’s been a week and things seems a lot more stable. fingers crossed :slight_smile:

1 Like