Wrong status for garage door opener

I have an Iris Z-wave garage door opener that I used successfully with smartthings. I excluded it from smartthings and added it to hubitat, but it is showing the opposite status. When my garage door is closed is shows the status being open and when it is open the status shows closed. If I command it to close when the status says closed I have confirmed that it is not opening the door, but I need to figure out how to get the status correct. Any ideas?

You might try re-pairing the tilt sensor to the unit. As far as I know that is not configurable. When sensor is horizontal it should be open and closed when vertical.

Sensor pair procedure is:
1 unplug unit for at least 10 seconds

2 plug in and then hold the reset button on side for 10 seconds.

3 manually raise and lower door two times.


Thanks. I actually had tried that but no luck. I tried pushing the pairing button on the iris opener and holding for 30 seconds or so until it continuously beeped every second and it seems to have flipped the status. The only problem is the first 2 times I included the iris opener I had to wait overnight to see it working in any real way. I guess I'll wait until tomorrow and see what happens.

...and we're back to open. The status is showing as open regardless if it is open or closed. I put a new battery in so it's not that. Here are some details...
-garage door is closed (tilt sensor vertical), status shows open, I click refresh, it still shows open
-garage door is closed (tilt sensor vertical), status shows open, I click open, it shows "opening" then status stays open
-garage door is closed (tilt sensor vertical), status shows open, I click close, it shows "closing" while garage door opens, then status stays open (tilt sensor now horizontal)
-garage door is open (tilt sensor horizontal), status shows open, I click close, it shows "closing" while the garage door closes, then status stays open (tilt sensor now vertical).

Everything is working except the proper status.

I'll try anything if anyone has ideas.

It sounds like the sensor isn't pairing correctly.

Why would you have to wait? This should be able to be tested immediately after pairing. If it doesn't work right after joining it to the hub, something is wrong.

Which model tilt sensor is this?

1 Like

about not pairing correctly...that was my thought but i've tried re-pairing, changing the battery, etc. to no avail.

waiting until tomorrow...i agree with you, but each time i try including it i'm not able to get any status until a longer period of time passes. I didn't have to wait overnight this time, but the status was not available right away.

the model of my Iris Zwave opener is GD00Z-1.

Might I suggest that before you try pairing it again next time, you power down your hub, pull the plug from the wall for a few minutes and then plug it back in. (Pulling the cable from the back of the hub has been reported to sometimes cause a problem with the connection, so pulling from the wall is better…)

This will reset the Z-Wave radio, so if there is an issue with it, it might help.

I definitely appreciate all the feedback...I have tried this too.

1 Like

just noticed the update to your message...didn't think of that, i will try it and report back.

1 Like

Thinking about it, the connection with the hub seems ok. It is taking commands from the hub. My only problem is the status.

Here is what I mean about no status right away.

This time I didn't exclude and re-include...just unplugged the iris opener as suggested by Sebastian.

1 Like

Yea, but that is just the opener if I understand that device correctly. Isn't there an additional tilt sensor on the door somewhere?

correct, there is a tilt sensor that came with it. Here is what i have for the tilt sensor...

Wait, I wonder if this is Zwave, and not Zwave Plus.

If this is old Zwave (and I think it is from what I can find) you may have to poll this to get status. Older Zwave didn't report instant status due to a patent issue.

Smartthings polls things in the background, so you probably didn't even notice this before. But on Hubitat, you need to go to Apps, add a built-in app, and choose Zwave Polling.


Feels like you might be onto something. I did try adding it to dashboard, but that was previous to excluding and reincluding...that said, I removed the dashboard.
I went to the "Z-Wave Poller" but there was no way to choose any device, and I don't see where to enable it in the device details.

Hmm, I guess I never tried polling a garage door.

If you hit the "Refresh" button on the device page (second screenshot above), does the status update?

If THAT works, you might be able to do a periodic refresh using a rule.

no matter how many times i click it...no change.

i recall seeing polling somewhere when i was including devices, but i don't know which devices. I'm not finding polling anywhere in any devices now.

I found this in the list of compatible devices and performed a factory reset as indicated.

it didn't seem to work. Here is what i see now...

FWIW, based on the inClusters from your screen shot above, you don't have the newer z-wave plus version (model GD-00Z-1). So @neonturbo was spot on.


That makes sense to me, however the model number on my Iris opener is exactly that (GD00Z-1). So if that is the answer, I'm struggling to find how to set it up to be polled.