[WITHDRAWN - Use the new Broadlink integration by @tomw] NATIVE Broadlink RM/RM Pro/RM Mini/SP driver

Just installed 0.51 (driver and app) to use with my RM3 Minis. When I go to Apps > Devices, under Available Devices, it says 'No unconfigured Broadlink devices found'. There is nothing under Configured Devices.

In the app, if I click the gear, in the Application State table > broadlinkDevices row, I do see my broadlink devices:
{={devType=24374, cloudLocked=false, IP=, devTypeName=RM Mini 3 (V4), MAC=, Name=[UNNAMED], supported=true}, ={devType=24374, cloudLocked=false, IP=, devTypeName=RM Mini 3 (V4), MAC=, Name=[UNNAMED], supported=true}}

So why don't they appear under the App's Broadlink Device Manager?

I added the RM3 Minis with ihc android app. Do I need to do anything on the android app side? I even tried deleting one of the Minis from ihc to see if that does anything.

From the Android ihc app, Device Info on one of the Minis show:
Access to the cloud: Load failed
Firmware: 44057
Connection status: local online
Data Cloud: load failed
sdk: load failed

The log just has hundreds of:
'app 38 has pending hub commands'

Hubitat is version 2.3.2.123.

1 Like

Not sure if this will help anyone. After not being able to easily and cost-effectively find a RM Pro, I bought an RM4 Pro, which is not compatible with this unsupported driver.

I run Home Assistant too, but their setup made me crazy with how complicated it was. So I turned to my other smarthome savior, Homebridge. This allowed me to very easily add my RF controlled DC motor ceiling fan to HomeKit, and control it from Hubitat and my picos by sharing virtual switches with Homebridge.

https://broadlink.kiwicam.nz/#homebridge-broadlink-rm

I next tried the standalone instructions, which just needs the ip address of my units, and now they work just fine. I guess the discovery portion is broken (or never worked), despite the logs showing some indication that my units were discovered.

I'm on code version 0.51.

Do you think this would work using a Nest Hub or Echo?

In principle, it should work (at least with the Echo) using the same approach that @SmartHomePrimer outlined using Homebridge. The difference is that using Homebridge, he presumably does it all within his LAN (i.e. locally).

2 Likes

Correct. All local.

@user1510 I believe the Broadlink RM4 Pro supports both Google Home and Alexa, so you shouldn't need the virtual switches I used. You could just use the Broadlink Alexa Skill or add Broadlink to Google Assistant.

2 Likes

Wanted to add some commands and went into the app for the first time in a very long time. It's throwing all sorts of errors, although the actual devices seem to be working and issuing existing commands.

Before I dig into the code I'm wondering if anyone else is seeing this, or has coded a solution.

Update: looking at the error log it appears to not be finding the New Ip or perhaps not finding the device then the new iP. The stored IP addresses match the router's reserved IP addresses.

I can't speak for this app/driver, but I am making my own integration for Broadlink remotes based on some other references. Mine works for IR currently, and I will attempt to add RF support once my RM Pro arrives later this week.

I'm happy to share privately if anyone wants to alpha test or give feedback. It should be able to co-exist with the integration in this thread.

2 Likes

I reinstalled the Broadlink app and for reasons I cannot explain, it's working again :man_shrugging: I'm really grateful because the Broadlink app's code is extremely dense and way beyond my current Java/Groovy skill level.

Please keep us apprised with your progress. It's good to know there is an alternative out there. If it was not for the many hours I have invested getting my Broadlink devices and codes setup, working, and integrated into my HE system, I would take you up on your offer.

I understand that for sure. I can probably offer a migration path (like an import option for saved codes or something). But I probably can't fix your automations that use commands on the existing integration. :wink:

2 Likes

Hi @tomw!

Firstly, thanks for your kindly offer. Could you share your integration with me too? I have five Broadlinks R3 Mini that I use to control AC mini splits and would be great if we had a new option. I may give feedback or also make some tests!

1 Like

I'm very interested as well. Watching..

Thanks for your interest, @marcusvrsilva and @cwwilson08.

I have testing across IR and RF underway, with help from a few users that have a mixture of RM3 Mini, RM Pro, and RM4 Pro. All seem to be working well.

I could use some help with testing from anyone that has an RM4 Mini. Let me know if anyone can help with that.

Otherwise, I will post this openly to share with everyone soon.

13 Likes

FYI: Broadlink IR/RF remotes integration (RM3 Mini, RM Pro, RM4 Mini, RM4 Pro, etc)

@marcusvrsilva

5 Likes

Great work. I've been a long time user of this integration however one thing that held me off changing over was carrying all the codes over... However it seems you have integrated importing so nice work and can't see any excuse why we don't all transition over :wink:.. I assume the two will work in unison.

I'll have a look over it in the next week or so. My current integration isn't broken which is why I didn't offer to so any beta testing , however it's good to see a maintained alternative.

2 Likes

Sounds great. Join the discussion in the other thread! (If you haven't already)

1 Like

Yes, both can reside together on the same hub. I am temporarily setup that way, until I remove this Withdrawn Broadlink Device Manager (Beta) and its linked devices within a week or so.

1 Like

Thanks a lot, @tomw !

I'll install and test it. Is there some specific feedback you need, some condition you want I try?

No, just jump into the other thread I started if you have any questions or issues (link in my post above).

I was seeing it just now! Thanks again, my friend!

1 Like

Download the Hubitat app