[WITHDRAWN - Use the new Broadlink integration by @tomw] NATIVE Broadlink RM/RM Pro/RM Mini/SP driver

I am not seeing this on my system... I'm testing with a RM2 Pro Plus2...

The learnIR() function already uses a 30 second timeout, and the learnRF() function uses a 30 second timeout per step.

If the learnIR() function is giving you trouble, please post the log of the function being executed so I can figure out whats going wrong.

Very cool! Is this all local, or does it have to go out to a broad link cloud service?

Terrific! Many thanks for contributing this.

Yes.

2 Likes

I've got amazon.com open in another browser window...before I buy more Broadlink devices, do you have specs on which hardware is supported by the driver?

For example, I found that the Broadlink Mini Bean has a different device fingerprint from the Broadlink Mini 3 (as used by [broadlinkgo](broadlinkgo/knowndevices.go at master 路 rob121/broadlinkgo 路 GitHub and [homebridge-broadlink-rm(Broadlink RM mini 3 - unknown device 5f36 路 Issue #515 路 lprhodes/homebridge-broadlink-rm 路 GitHub)).

I updated to support that recently:

But I don't have the device so if somone test it let me know, either way @cybrmage feel free to crib from my code, if this works better, I'll be happy to stop using my own, less dependency is best!

rob121Owner

5m

I updated to support that recently:

(Where "that" is the Broadlink RM Mini Bean.)

Yes, absolutely...I didn't mean to suggest that you don't support it now, just to point out the difference between hardware models (and a source for device fingerprints).

In the RM line of products, there are basically just 3 devices: RM, RM Pro and RM Mini.

They all support the same communications methods and protocol, regardless of branding. The different device IDs differentiate between various different brandings and hardware revisions, BUT the protocol hides them, and the protocol is all the same... If you get a device with an ID that is not in the list... not to worry... A single line of code will resolve that...

1 Like

I am confused by the device naming, but I have a device that I have used with both broadlinkgo and cybrmage's BETA driver.

I bought it from Amazon from this page: https://www.amazon.com/Broadlink-RM-Mini3-Universal-Controller-Compatible/dp/B01FK2SDOC

I don't recall it being named "Black Bean" at the time, but that is definitely the model I bought from Amazon in July, 2019. Maybe they have transitioned to new variants or changed the product ID in the meantime, so YMMV.

It shows up as ID 10039 (0x2737) in cybrmage's driver. broadlinkgo doesn't list the ID, but my devices work there (and worked prior to Rob's recent update).

Is this thread crashing chrome on Android for anyone else? It does for me.

2 Likes

It's very slow to select and copy the code it seems. @cybrmage would it be better to host it on GitHub?

1 Like

I have posted a new version, v0.20, that

  1. should fix an issue where the learnIR function did not work as expected on some RM Mini units.
  2. removed extraneous code
  3. fixed device name had unprintable characters if the device did not have a name set for it when it was configured by eControl/IHC

It is available in the first post.

No.

Same here...

1 Like

That is an issue that you should report to the forum admins, or maybe @mike.maxwell or @chuck.schwer or @bravenel (tagged them so they are aware of the issue)

I have posted a new version, v0.22, that:

  1. has a verified fix for an issue where the learnIR function did not work as expected on some RM Mini units.
  2. Adds support for sending stored codes from the Dashboard "Button" templace

It is available in the first post.

1 Like

Does anyone know of a solution for 330 MHz rf (for an electric gate I have)? It seems the Broadlink doesn't cover that frequency. I did find this which looks interesting...

Universal WIFI remote control converter 330 433 868MHz Android IOS RF WIFI remote control Wi-Fi to Remote RF Converter 240~930MH
https://a.aliexpress.com/qScp0jeC

Another option would be an arduino solution.

Would prefer something out-of-the-box if it exists!

To add to this on my personal and work laptop It's not crashing chrome but is very slow and I am unable to copy any text if I have scrolled and there are a few replies showing.

Hi @cybrmage, thank you very much for sharing this driver, it works very well, I tried it with the RM mini and RM Pro +. I found a small problem with RM3 Pro +, basically a ";" it is missing on line 333 after "isPro=true". I have added ";" and it works properly.

In the Log you can see:

dev: 2002020-01-11 08: 28: 53.005 errorgroovy.lang.MissingMethodException: No signature of method: java.lang.Boolean.call () is applicable for argument types: (java.lang.Boolean) values: [false]
Possible solutions: and (java.lang.Boolean), wait (), any (), wait (long), each (groovy.lang.Closure), any (groovy.lang.Closure) on line 333 (parseDiscoveryPacket)

Thanks for this driver! For me it was perfectly timed as I just started looking at the RM Pro yesterday. I have now ordered an RM mini 3 as well as the RM Pro just because of the existence of this driver. Once I get the devices I鈥檒l put your driver to the test :slight_smile: