[WITHDRAWN] NATIVE Broadlink RM/RM Pro/RM Mini/SP driver & RC HVAC Manager

That was a quick fix. Great response time

1 Like

Works great. Thanks!

RM Mini3 mess

Received first RM Mini3 yesterday. Inadvertently used Broadlink app, not IHC, to set it up. Then tried adding it to this app, said device was locked. OOPS! Deleted device, cleared my account, reset device with reset on device, but it can not be found by IHC. Contacted Broadlink support, still waiting for response on that issue.

Second RM Mini3 arrived today, successfully added to IHC, added 4 sub devices, successfully added device to this app. So far this device is good.

Any idea how to get the first arrived recalcitrant RM Mini3 to connect to IHC? I'm going to return it if I can't get it working.

Update May 27, 2020: I gave up attempting to get device initialized and returned it. Don't use the Broadlink app even with an RM Mini3 if you want local access to the device!

DAM, the HE staff are nothing short of freaking amazing.
Thank You @bravenel

In the process of moving from WINK to HUBITAT this past week or so, I have successfully set up HUBITAT (currently running version 2.2.0.128) and made the transition of our set of five ALEXA-compliant and coordinated smart light bulbs to the new hub without much trouble. However, I have had no real success in moving our current Living Room Speaker device combination to HUBITAT so that I can use ALEXA voice commands (a prior workable combination I had worked out between the BROADLINK device and ALEXA directly). The devices involved are a PHILIPPS soundbar triggered by a BROADLINK RM PRO PLUS2. The BROADLINK device is currently connected appropriately to HUBITAT (using beta versions of the device code) as is the AMAZON ECHO SKILL app; the necessary IR codes are set, tested, work correctly (in the associated app) and are stored on the device. The Living Room Speaker (the Zone Label) is listed in the AMAZON ECHO SKILL app as a Selected Device (using BROADLINK).

When “discovered”, however, although ALEXA suggests commands will work, the ECHO then states “Sorry, Living Room Speaker is not responding” and the LRS appears in the device list but with a “There was a problem” indicated. I can control the BROADLINK device directly from my iPhone (using the IHC app) and, as mentioned above, using “test” on the HUBITAT app. I currently have three LRS listings on the ALEXA devices list (“why”, I don’t understand), one of which uses HUBITAT (POWER off) ;the others two, versions of BROADLINK. I have cleared all three at various times, together and separately, and reinstalled them to no avail. I currently have IHC and e-Control apps on my iPhone and both the ALEXA and HUBITAT apps on iPhone, iPad and laptop.

Suggestions? I am fairly computer literate but completely stumped as to how best to solve this dilemma.

LEE MAKELA

1 Like

I'm not sure if this is a high priority @cybrmage but if your apps/drivers were included in the Hubitat Package Manager then that would make updating much easier. I have only just found that app when I installed a new branch of Xiaomi drivers but it seems to be a good way to update 3rd party drivers/apps.

Is anyone else having trouble downloading either of these?

I get this for both links;

use google drive links in this thread, afew posts above.
The developer is off the grid and took his code with him. Hope he's okay, as no one knows where cybrmage is

Thanks @Rxich

So once I put the hvac devices created by this app/driver into the maker api I can turn the ac units on via google assistant voice commands. Thought great this is looking good. However if I say turn the heat up to 20 degrees (or similar as that is the beuty of the natural speech rather than using routines) the temperature is't sent. It seems to send the last temperature I had used through my hubitat dashboard.

The google home app shows the thermosat temp and the room temp, just if I change the temp it doesn't get sent. Changing from heat to off works however.

Is anyone else able to control the temperature via google assistant/home or through the google home app?

Anyone have a working HVAC version they can suggest, or perhaps post and share?

I decided to try the HVAC app because ON learn mode on the remote for my Fujistu mini split always produces On with Heat, and the Mode button never learns, always times out.

Update1: Got a "mode Cool IR code" learned. Using the Fujitsu's remote, first press on "Mode" button does nothing, second press sets IR Code.
How to: Using remote set unit ON, set mode to "auto", then turn on Broadlink's IR learn function, press Mode twice, setting and learning "Cool". Now with RM AC comes on in Heat mode, but I added the AC_Cool code immediately after the ON with a 3 second delay. Perhaps this will help someone, it's been a big learning experience for me.

Using HVAC V0.26 with a Fujitsu unit and ecobee thermostat, I'm unable to get beyond initialization due to a Java error.

dev:1506 2020-05-27 13:41:40.923 error java.lang.NullPointerException: Cannot get property 'value' on null object on line 294 (installed)

None of the values exist

Line 294
log.debug("LAST STATE: cooltemp [${device.currentState("coolingSetpoint").value}] heattemp [${device.currentState("heatingSetpoint").value}] thermostatSetpoint [${device.currentState("thermostatSetpoint").value}] thermostatMode [${device.currentState("thermostatMode").value}] thermostatFanMode [${device.currentState("thermostatFanMode").value}]")

Device Current States

  • supportedThermostatFanModes : [auto, high, medium, low, quiet]
  • supportedThermostatModes : [off, auto, cool, heat, fan, dry]
  • temperatureDisplayScale : F
  • temperatureScale : C

Got it to initialize by commenting out line 294, added a ? to the fields on line 295. My question now: How do I turn ON the AC device with this app, OFF works!

Update1: Unfortunately OFF is the only command working on the Fujitsu.

Line 295 fix
if ( (device.currentState("coolingSetpoint")?.value == null) && (device.currentState("heatingSetpoint")?.value == null) && (device.currentState("thermostatSetpoint")?.value == null) && (device.currentState("thermostatMode")?.value == null) && (device.currentState("thermostatFanMode")?.value == null)) {

My Mitsubishi unit turned off with every command on one of the codes library and the other it didn't respond. So cybrmage made a new library and it worked. He was very helpful and responsive to add the 3rd library code for Mitsubishi so hopefully he comes back fit and keen like before

I posted the version I use several posts above. Have no issues. I heat, cool, use fan, change the temp, etc...

I rarely change anything manually now as I have a couple super complexe rules that I use to control what it should do when depending on the outside temperature and temperatures on inside sonsors.

I do the same. Well mine aren't complex, mine just say if under a certain temp outside put on heat, if between something put auto and if over a certain temp put cool mode. This way my multiple split units don't work against each other or use the cooling function when it's cold outside because another unit has helped to heat the other space above its target temp. Also good when I lower the temperature when going to sleep so the unit stays on heat and just lowers its energy rather than with auto it would have used the cool function to get the temp down quickly which wouldn't be ideal.

I'm curious what complex rules you use in case it's worth me incorporating into my rules. I may look into using a more complex rule for zones outside the multiple split systems I have... May... As that is complex.

I just have one mini-split to worry about... But I also have a fan in the equation - I will explain later...

I’m sure some of the developers out there will see my code and cringe... and rightfully so! Input is always welcome! That said, even though I feel like the code is a bit of a mess, it seems to work wonderfully well!

And a side note, some of this is in there because I have a south facing solarium. I added a fan in the wall to exhaust the hot air and use it to heat the house on nice sunny days. My initial code did just that, but I wrote it in the winter and now I am making adjustments to avoid it heating the house too much when the house is already pretty hot. (Yea, not doing much architecting...). Oh, and I haven’t had to cool yet... I suspect I will be adjusting that temperature point... :slight_smile:

I have 2 main RM rules.. This first one controls the heating/cooling.

This next RM is the more complexe one. It controls when the fans should turn on and off during the day depending on temperature. It is a bit of a doozer... So I had to split the screenshot into to images...

I really like this app the way it s fully integrated in to Hubitat. I have been trying for some time to automate my blinds and this fits the bill nicely. Thank you cybrmage.

I have some questions that I hope someone can help me with. I have a RM2 Pro Plus3 and stored my Broadlink codes under the devices section and I can see them listed in the State Variables area.

  1. When I upgrade the version of Broadlink package does that mean that my Broadlink device is replaced or I need to delete and recreate it? If so am I correct in thinking that my my learnt codes would also be gone and I would have to re-relearn these.
  2. Where is this State Variable data stored? By that I mean in the app, driver or is there a separate area?
  3. I'm running version 0.41 and I can't see anywhere to import or export the learnt code data or import it if that is what I need to do when upgrading..
  4. When I go to the Apps and click on remote codes I can see some codes that I learnt when I was setting them up but choosing delete won't delete them.
  5. Is there a way to modify the name I gave to a stored code. I had a typo and it is bugging me.

Thanks

Wow. Now I see what you mean by complex. Quite a few conditions in there. Hope it works well for you.

I really want to look into temperatures in each of my split systems and modify each system to make certain sensors equal a set temperature.. However that too is quite complex a thing once there are more than just two systems..

Hi,

I have been having trouble with this and other implementations with learning the RF codes so I suspect it is the Broadlink device. But I now have it working.
Now I'm not sure if the timing of pressing the button, the speed of pressing it or just the amount of tries as I have had to try learning a single code up to 30 times, while at one point I learnt a few in a couple of minutes. It just worked first go.

The way I've been doing this is learning the codes through the devices method by holding the button down when it says to under RF_Status : SWEEP: LED = ON : Press AND Hold button on RF Remote.. When it finds the frequency the message then changes to something like LED = OFF but stays there only for less than a second. Now while it still says LED=OFF and before it changes to RF_Status :FIND : LED = ON : Press and Release RF Remote button repeatedly.. Press the button repeatedly as quick as you can. Like a jackhammer.

When it doesn't work I get a learnt code of
26001D00160D160D170C0B180B18170D160D160D0B180B18170D05000726000D050000000000000000000000
always starts with 26.
When it works the same button has a code
B200F401150D170C0B190B18160D160D160D0C180B18160D160D0B18170C0B180B19160D0B180B19160C170D160D0A190B190A19160D160D0B180B180B180B19160D0B180B18170C170D160D160D0B180B0001189832160C170D160D0B180B18160D160D170D0B180B18160D170C0B18170C0B180B19170C0B180B19160D160D160D0B180B190A19160D160D0B180B180B180B19160D0B180B18170D160D160D160D0B180B00011E9931170C170D160C0B190A19160D160D170D0B180B18160D170C0B19160D0A190A19170C0B190A18170D160D160D0B180B190A19170C160D0B180B180B180B19160D0B180B18170D160D160D160D0B180B0001229931160D160D160D0B180B18170C170C170D0B180B18170C170C0B19160D0B180B19160D0B180B18160D160D170C0B180B190B18170D160C0B190A190B180B18160E0A190B18160D160D0B180B19150D170001129931160D170C170C0B180B19160D160D160D0B190A19160D160D0B18160D0B180B19160D0B180B18160E160D160D0A190B180B18170D160D0A190A190B180B18160E0B180B18160D170C0B180B18170C170001079931170C170D160D0A190A19160D160D160E0A190B18160D160D0B18170C0B180B19160D0B180B19160D160D160D0B180B190A19160D160D0B180B180B180B19160D0B180B19160D160D0A190B18160D160005DC00000000
Always longer and always starting with B2.

I hope this helps you.

This helps me, the RF codes I also have trouble with and I compared all the codes and they all started with 26 and were short. It also took a huge number of tries to get it working. After sweeping, it would error a lot.

Download the Hubitat app