Why isn't Mode Lighting with sunset/sunrise working?

Hi there! One week in with my C7 and having fun! I set up Mode Manager which seems to be working. Unfortunately, Mode Lighting is not. I can switch to RM if needed, but Mode Lighting seems so much easier. Below are some screenshots of both. Any ideas?

Here's my "Garage plug" device, which is a SmartThings Zigbee Plug using the default-selected driver. on/off on the device page works fine. Weirdly, it doesn't work on my Dashboard -- shows up with a question mark.

Dashboard:

In case anyone is reading... should I have posted this in the Support forum rather than RM? Still new here...

Post your System Logs (left side menu). Those show mode changes and sunrise/sunset events.

Nevermind that. You are using the wrong app. Mode Lighting is for something else.

Use Simple Automation Rules instead.

1 Like

So I did that and it looks right but it still isn't working it seems. anti-Turn On is listed in Events, but it never actually turns off.



Is there something else that's weird about this plug? Again, clicking "off" manually on the device page works fine. I turned on "Enable power reporting" at 60W and now I see this in the event log for the device:

Which looks reasonable, although I guess these two halogen bulbs are costing me a TON! Something else to fix... outside of Hubitat.

If those are the Events logs for the device, it is not showing on or off events. What I need to see are the logs for the device, and its events. The former from the Logs page, and the latter from the device page Events button. Need to line up the times with the app logs, to see what the device is doing relative to the app.

Also, if the app turns on the plug at sunset, it should be 'on' now. Is that the state shown on the device page?

Last screenshot above was the events page of the device. Here's the past logs of the device:
image

And here's the device page itself:

Anyone have any further ideas?

are you at update 147? That solved my sunset/sunrise issues with simple automation.

1 Like

Yep, that is the first thing to do/check.

1 Like

Few weeks late response but still having the issue.

I'm on 2.2.4.158 now and upgraded to 147 I believe shortly after the above. Unfortunately, no luck. The lights automatically turn on at sunset but they don't turn off at sunset. Is something wrong with the plug itself? Whenever selecting "off" on the plug device page, it immediately turns off, so that makes me think it's something about the automation set up.

Also, weirdly, clicking the plug on my dashboard results in the widget not updating for a while. That seems to be the case for a few items on my dashboard. Should probably create a dedicated thread for that, but figured I'd mention it here.

We had the problem that you device logs didn't really show on or off, thus making it really hard to tell what's going on. Open the device page and hit Save Preferences, to re-kickstart logging. Then turn the device on and off from the device page, and show those logs.

Here are the debug logs for off/on/off/on:

Without debug logging enabled on the device page, no logs at all were showing up when turning on/off.

Also interesting to note: turning the plug off/on doesn't update the "Current States" consistently. I have to press Refresh in order to get the switch/power data to update. I don't know if that's expected, particularly for what I believe is called a "mains" powered device which hopefully is repeating Zigbee signal. Here's a screen capture video of what I mean: Hubitat smart plug not refreshing - Album on Imgur

It sounds as though this device is not working. Perhaps you should do a factory reset on the device and then run Zigbee discovery again. It should rejoin the hub. See if it works any better after doing that.