Why is my Google Mini's sound level changing?

After a number of months of my Google Mini keeping the same volume setting, in the past several days, the TTS sound level is diminished. I went into the device settings and saw that it was at 45%. I changed it to 100%, and it seemed to take, at least for the time I looked at it. Then the next time the mode changed, it was quiet again. When I went back in, the sound level was again back at 45%

What is causing this to change? I have not made any changes in the apps which use it for TTS announcements. How can I set the sound level and have it stick?

I am having the EXACT same problem, right down to the same specific 45 volume level as well. I hope we get an answer! Really would like to get my alarm system sounding loud and fully operational again haha

So far I have:

  1. Rebooted my hub, Google homes, Wi-Fi router, and modem
  2. Entirely uninstalled/reinstalled/added my google home devices, Chromecast integration apps/google home apps both within hubitat and Google itself as if starting brand new
  3. Checked to see if any "night mode" or auto-volume decreasing setting accidentally got ticked on, which they have not. I've always left my google homes on 100 volume with mic off and solely using them for TTS speakers for hubitat
  4. Set the volume back to 100 multiple times within hubitat, google home's app, and on the physical device itself only to have it bounce to 45 when a TTS command kicks in. I've confirmed in Google's app and hubitat the speakers would be on 100, send a TTS, and then the log would state all my playing Google home speakers set to 45 first then play the message.

This has only started within the past week/week and a half. I'm noticing it happens during night hours primarily and sometimes never during the day. Triggers possibly when the internal hub time recognizes its past "sunset" hours in the hub settings, but that's just a hypothesis.

I'm pretty tech savvy, but this has me stumped since it randomly started happening without making changes to my google/hubitat accounts.

Any help for StephenH and I would be greatly appreciated.

1 Like

@bravenel I also rebooted the Mini. I have not gone as far as rebooting everything else. Is it something in the latest update which is causing this?

When I get time I'm gonna try reverting to a previous update, if thats possible, never tried that.

:smiley: And I thought I was the only one...

I have a JBL Link 10 - something changes it's volume to 28 every day.
Used to be at 03:00 every day, lately it's at 22:00 every day.
I have searched through Hubitat but I couldn't find anything. I do not think that it's Hubitat's fault, I think it's got something to do with a wellness bug on Google's side. (I do not use any wellness settings in Google)

I made this rule to fix it:

I have actually forgotten about this problem, until you mentioned it now :smiley:

Anyone have any progress on this issue? I can't figure it out.

I've tried reverting Hubitat's firmware to and still had the same issue. I also tried reverting to and still had the same issue. Never had this issue on those firmwares previously.

As a test, within the Google Home app I've also casted my phone's audio playing YouTube and used the 'broadcast' feature to my Google Home and Mini without it lowering the volume from 100. However, right after doing so I sent a speak command via Hubitat's device page on both my Home and Mini and they lowered to 45 volume. I'm stumped.

Again, the issue is only roughly between the night time hours of 8pm and 8am. Once I have the Google speakers speak via Hubitat and the volume lowers to 45, I'll correct it to 100 and it will stay 100 until its inactive for some time, maybe 30mins to an hour, before the 45 volume issue appears upon receiving another TTS command. I don't know if it has something to do with forgetting the "mediasource" or whatnot, but ive run out of ideas.....

Sorry for the word wall lol trying to give all my input into my attempts to solve this hahaha

It is frustrating. I tried the rule posted above, but it does not stop the change from happening. Tonight, it happened at mode change which was at 23:00. I modified the rule to just have the condition that the sound is not equal to 80%. If it isn't, it is supposed to tell the time and set the volume to 80%. We'll see what happens.

I tried setting night mode in the Google Home app with Google's night mode setting the volume to 100, but hubitat tts events appear to override it and still set volume to 45. I might message hubitat support directly and reference this thread. Tried searching Google's forums and didn't see this issue. I'm leaning more and more towards this being a hubitat issue.

I gotta assume there's more than 2 people with this issue right?.....lol

I did a variant of the rule shown above with the trigger event being,
"Hallway speaker reports volume (80) !=80.0"

"Speak on Hallway speaker: '%now%'"
"Set volume on Hallway speaker to 80"

Last night, at mode change from day to night at 23:00, the starting chime for the Mini was loud and the mode change announcement was soft. This was immediately followed by the rule activating and adjusting the volume back to 80. So, this helps track down where the unwanted adjustment in volume is happening.

Why is the volume being adjusted at the mode change? Why is there no setting for specifying a desired volume for the mode? If night mode is going to change the volume to 45%, why is not the Day mode then restoring it to what it was previously? Is this the unintended consequence of some other change that was made? Right now, it looks like the only place to specify the volume of the Google Home Mini is in the device settings. Is there a way to incorporate a volume setting in the Mode Manager? Some people may want the volume to be lower during certain modes.

I have been having a similar problem on my C4 with platform - so the problem isn't with any recent platform updates.

Just thought of something. I just recently installed Chromecast Helper on my C7 hub to eliminate the annoying log entries on my C4 hub. The C7 has platform I'm thinking it is a C7/platform issue. In my case the Google minis have been dropping to 40% on their own.

It is not a C7 issue. I have it on a C4.

I have the microphone disabled. I am not sure whether the mini goes outside my local network to operate. I think I may see if I can block the IP address of the mini from Internet access in my router and see what happens.

I have a C5 and have the same issue. I'm 95% sure this is a Hubitat issue. Casting directly to the Google Home speakers during overnight hours from my phone, no volume change. Casting from Hubitat to the Google Home speakers during overnight hours, loud connection noise with 45% volume playback. Ive tried it via TTS as well as using it as an 'actuator' in Rule Machine to play mp3 files stored on my Hubitat with similar 45% volume results when playing. Something must have internally updated and changed recently behind the scenes cause even my downgrades to previous firmware didn't correct the issue. My mics stay off as well.

During the nighttime hours, I notice after 30mins or so of idle time the Google Speakers will not respond to manual Hubitat commands from the device menu or register a line in the Log of them (volume up/down, mute, refresh, initialize, etc) until a Speak TTS command is sent. Once a TTS is sent, it acts as if it reconnected and I'm able to send those commands as normal, until another period of idle time in which it repeats the same issue. That would not happen prior to this issue appearing. As a note, I do not have messages stuck in queue waiting. Everything appears as it should, minus the issue.

Unsure what that could mean, but at this point I'm just documenting my troubleshooting and journaling what I'm noticing until a solution is found.... lol

It turns out that I could not find an option in my router to make sure the mini stays on the home network only. I will have to look more since I may have missed something.

@StephenH, have you tried changing the mode change to 22:45 or 23:15 (for example)?
Then it would be clear if it has anything to do with the mode change.

My volume changes at 22:00 and I have no mode changes around that time...

Okay, so I thought I will go through the settings in my Google Home App again, just to be sure I do not use any wellness settings....

I went into the settings of the JBL speaker and I found a setting called "Night Mode" (translated from Dutch, so it could be called something else) and yeah, it was activated!!!

My problem is solved now :smiley:

I don't use the Google Home app and never have. It looks like I will have to install it so I can check.

I didn't know that that was possible :slight_smile:
Don't you use Google voice commands?

Ive checked that, no modes or night modes set in both hubitat or google apps. Still have the 45% volume issue at night

Absolutely not! The last thing I want is for Google to be listening to everything. I have the microphone turned off. I've debated going into it and making sure it is disabled. It was a "free" item for being a Google Fi subscriber for cell service. I wanted it for the speaker.

I did install Google Home long enough to go in and make sure any settings that could cause this were turned off. Then I uninstalled the app. Tonight, the same thing happened. At 23:00, the volume changed to 45%. My rule changed it back to the 80% that I want it at.