Why is my c7 hub so inconsistent?

I've gotten this to about 90% satisfaction, by purchasing a second hub and using mesh. This issue used to be much worse. Tonight I have a good example with logs and I'm hoping someone can see something to help understand why the hub fails to respond.

Starting with 1, I'm trying to activate a scene that turns on a lamp and under cabinet lighting. I try 3 times with 15 second intervals and give up.

2, I walk downstairs and trigger my basement office motion which should turn on the lights. The motion is detected in logs but the lights don't come on.

  1. I give up and turn the lights on the old fashion way, lol.

Is this to be expected from time to time? If not how do I go about pinning down the issue?

Sounds like it's missing commands caused by a weak mesh, or maybe something like a zooz 4-1, or power reporting device is saturating the mesh.

1 Like

I run my home off two hubs. It works perfectly all the time.

Really need to provide the community with what devices you are using and how many repeaters for Zigbee and/or Z-Wave you have.

What custom apps and drivers? Have you be tried disabling any custom apps?

Are you triggering any WiFi devices?

1 Like

On the hub in question I'm using a Siren 6, about 8 Inovelli lzw31's, 2 inovelli color bulbs, and a few motion sensors. The only custom app on this hub is "switch dashboard" to control the inovelli LED's. All the oddball stuff like garage door openers, locks, key fobs, ecobee, is on the other hub.
No wifi or zigbee on this hub as well. I was really hoping by pulling just the dimmers and motions to the new hub it would run smoothly.

I'm fairly certain its not a range issue, devices are within tens of feet of each other and the hub not far off.

Are those inovelli red dimmers on at least firmware 1.48?

Yes, and the few that were on much older (1.3x) were upgraded to 1.52. So a mix of 1.52 and 1.48.

These devices support S0 but not S2 and will pair securely (i.e., with S0) by default unless the controller/hub requests otherwise. The C-7 is not capable of doing so due to requirements imposed by Silicon Labs (the "owner" of Z-Wave--or, more to the point, also responsible for certification, and the C-7 is Z-Wave certified). You will see that Hubitat does not officially consider these compatible with the C-7, likely due to problems some people have with S0 devices (they're pretty chatty in general, up to 3 times the traffic of no security or S2) but possibly something to do with these devices specifically. They aren't the only such devices; you'll also see the Zooz 4-in-1, mentioned above, as being subject to a similar problem. I believe Inovelli are trying to figure out workarounds (maybe a separate paring method for non-secure inclusion); not sure about Zooz, but I imagine they are aware of the issues too.

One workaround is to pair the device with a secondary controller (a popular option is Z-Wave PC Controller running on Windows, using a Z-Wave stick plugged into that computer as a secondary controller--not super-easy to figure out on your own unless you're familiar with Z-Wave, but possible if you're able to follow instructions, which I believe someone has written up somewhere here). Some people still believe there are issues with the C-7 and these devices even without S0, but I'm not sure what staff's "official" stance is. Still, it can't hurt. I'd also make sure your LZW31 devices are paired with either S2 or no security--or really that anything isn't using S0 that doesn't need to be (e.g., if it's an older door lock or garage door opener that needs to be securely paired but predates S2).

Not saying this is your problem, but it could be a problem.


Interesting. I made sure to pair all my other devices with no security, but yes the two bulbs show as S0 in my zwave details.
In this particular situation, the two bulbs were "offline", ie, they're being powered by a dimmer and being used as traditional bulbs, and that dimmer was OFF. I know it doesn't make much sense to do this but that's how they're running at the moment.
You seem to understand zwave very well. Does my running these bulbs improperly pose a potential problem? Like the hub is trying to talk to them but they're unavailable or something like that?

One potential issue is the manual recommends not turning off power to the bulbs! (see Page 3)


I was going to say it might disrupt the mesh but I don't know if the bulbs repeat or not. I have a couple - 2 are in sconces that are controlled by picos and always have power.

1 Like

Ive been meaning to do this so I'll make it a priority and see if it helps. I would think devices would simply find a new route but yes maybe this is causing the random delays, fingers crossed, thank you

1 Like

Use smart bulb option disable local load control.


Also have you updated the firmware to the beta firmware?

Improvements in reliability and speed...


I am not up to date on the bulb FW, I'll do that as well.

1 Like

Not that quickly. I would do what @lewis.heidrick recommended.


It was not clear to me that @wogfun was using smart dimmers with the smart bulbs. If so then yeah I agree setting local load control on the dimmer is the way to go. Would still update the bulbs to the beta firmware though it makes a difference in speed and may actually be part of the issue.


It sounds like you're recommending dimming the smart bulbs traditionally with the load output of the dimmer?
I had it that way until last night - I managed to use a button controller to set a single click up/down adjust 10 +/- percent and 2x click up/down is 100% on/off. I got the dimmer LED to display the dim % by grouping it with the two bulbs, then wiring the bulbs directly to line, essentially removing the bulbs from the dimmers load output.
It all works but feels like there should be a much better way to accomplish.
F/W on both bulbs was changed to 2.3.

No sorry wasn't clear - "disabling" the load control on the dimmer. I know you can do this with newer Zooz models but not sure about Inovelli.

This is feature is what I was thinking:

The other thing you can do is decouple the load from the dimmer and use rules to control. I've done this with switches but dimmers seem a bit more challenging.

1 Like

ok yes understood now. Last night I switched the bulbs to virtual control, I wish there was a better way to do this. Right now its kind of clunky. I'll see if this helps with the original zwave issue.

1 Like

Also the firmware - can't stress this enough.


yes FW updated last night. So far it helped with the bulbs performance (both bulbs dimming at the same time)

1 Like