Why did my Mode not change?

I just tried to create a simple new mode to "early morning" time. The intent is to use that in lighting app for "non blinding lights" when the kids just wake up for school. For some reason, the system did no switch to 'early morning" mode, and instead went into "day" mode. Any thoughts on what I did wrong?

Did you hit Done in Mode Manager after setting that?

Look at the App Status page (cog icon) for Mode Manager, at the bottom of the page -- Scheduled Jobs. It would be listed there.

I have now clicked on 'done'. I am not sure if previously I clicked it or not. Will test if this works tomorrow morning.

I think, even if it works now, then for future enhancement, this might be an issue which a lot of users unknowingly fall into. It would be nice if the Hubitat application somehow helps here. Probably, if a change was done, then somehow show a prominent icon that there are unsaved changed?

We are going to do something like this. Whenever you change an app, hit Done.

It's actually a bit more subtle than meets the eye. Many changes just happen when you make them in the app -- not so much for Mode Manager as for something like RM. But anything that involves an Event Subscription or a Scheduled Job requires that Done be the final step to update those. We will move to Save and Cancel buttons instead of Done, and not even save small changes until Save is hit. That's coming in a release or two down the road.


As always, respect to the Hubitat team! (sniff tears of happiness with the hyper-engaged team!!)