Why are rules controlling lights attached to smart plugs so slow?

I bought a pair of Neo Coolcam Power Plug Z-Wave Plus plugs (green dot, not blue, so I know they are the Z-Wave Plus ones) to turn on/off 2 old fashioned filament lights in a hutch I have. I am using the Neo Coolcam Power Plug driver for them.

I also bought a New One Z-Wave Plus plug to turn on/off my Quntis desk lamp. I found I had to use a Generic Z-Wave Plus Dimmer to get it to work (I tried a Z-Wave Plus Outlet, but that didn't work).

I am using either an Inovelli Red Dimmer or a Fibaro Key Fob to trigger rules to turn them on or off.

If I'm inside either device and use the on/off buttons there is a delay, but I'd say a second or less.

I created rules to turn them on or off using an Inovelli Red Dimmer or a Fibaro Key Fob. Using either of those it takes about 5 seconds from the time I push the button on the Fibaro Key Fob or double click the "up" button of the Red Dimmer to get their respective light to turn on or off.

Here are some screen shots:
I pushed my Fibaro Key Fob button 5 (the minus sign) at 1:14:24

But the command to turn off the light didn't happen until 1:1436. 12 seconds later!

This time, which is much more typical, took about 4 1/2 seconds. But that is at least 4 seconds too long.

The Fibaro 5 pushed Rule Machine 5.1 rule is doing a simple toggle rule to turn that light on or off. (If it is On turn it Off Else (so must be off) turn it On

Here I did a double tap on my Inovelli Red Dimmer (Stuart's Den Hutch Switch) which turns on the Quantis light via the New One plug and my ceiling fan light. Again, it took about 5 seconds from the time I did the double tap until the on() command was sent:

It is using a very simple Button Controller rule to turn these lights on:

I'm not including screen shots of the hutch lights, which I also control via the Fibaro Key Fob or that same Inovelli Red Dimmer, but the rules and times are similar - about 5 seconds each.

Any idea why turning these on like this is so slow and any suggestions on what I can do to spead them up?

The best way to assess where the problem is, you will need to enable the apps logging as well, then check duration between A. the trigger and app firing the command and B. app firing the command and device actually turning on/off. If the bulk of the latency is on A, then it's likely the app, if the bulk of the delay is on B then it's likely the device. Identifying the root cause is the first step in decreasing the latency.

1 Like

In addition to @bobbyD's advice, if you get a delay when manipulating the device from a rule or app but not from the device tab, it's probably not a device issue. However, if you do get the same delay while manipulating the devices manually from the devices tab, I'd check zwave details. If you post a screen shot of your zwave details page we can take a look.


I was able to do a test today and I notice that while the button push on my Fibaro KeyFob showed up almost instantly in the logs, the "On" command didn't appear for almost 7 seconds.

I'm thinking about rebooting my Hub to see if that will help. I did a reboot of the hub and then went into Rule Machine and ran the rule that is connected to the Fibaro KeyFob 5 (minus sign) button. It worked virtually instantly.

I then tried the Fibaro KeyFob button again and it worked virtually instantly! Woo hoo! So it seems that the hub "just" needed a reboot.

I've seen that some people set the hub to reboot automatically every so often. Is this recommended, and if so, how often?