When adding new devices, why are Device Names assigned to their Device Type and not the LABEL?

New user here. Still migrating from Vera. Just reloaded all of my devices on a fresh c7 over the weekend and with every device, its initial "Device Name" gets assigned to its Device Type, and NOT the "Label" I provided when adding it. Why is that?

Makes no sense to me so the first thing I do is change the name to match the label. Another problem is, it also makes the "Past Logs" screen completely useless because all I see is bunch of device types and not device names. Eventually those "old device names in the logs" will go away but, this is not good.


Am I missing something? Please help or explain. This does not work for me. The label I provide should become the name, too.

The label is what its displayed for the device as it's "name" in all contexts except for the one you happen to show -- logs. What happens with logs is that the name shown is the name that existed at the time that log page was opened last or refreshed (which essentially opens it from scratch). The name in the header of the logs page is never updated, even when the device name is superseded by the device label.

To see the logs with the new "names" (i.e., what label you created) just refresh the page.


That is the way we all wish it worked... but it does not. It hangs into the old name for a long time, until the logs fill up and it starts purging old stuff out.


Thanks! No worries, thats what I figured. Maybe I'll do a soft reset with clear the logs, or maybe not. Sometimes its best to leave sleeping dogs... sleep.

Weird, just worked for me.

FWIW, on recent firmware, you can use the Settings > Reboot option with "clear logs" selected. The catch is that some users report this doesn't always work, hopefully to be fixed. :smiley: But if it does, no soft reset needed.

Personally, I'd just wait for the old entries to purge their way out, but if you don't want to, a soft reset is also a safe operation as long as that's all you do (a soft reset only, no radio resets) and restore a backup (which the hub keeps but I'd download just to be sure).

This works for me in Live Logs, but Past Logs have used the oldest (rather than current/newest) name for as long as I remember, and I was able to replicate this with both device name and label in a test I did just now with a virtual device.

Enough people seemed to be confused, or at least perhaps just want the other behavior, that I actually added a note to the Logs documentation on this a while back.

What is strange is that it just updated for me once, but won't again. I'm going to push to get this fixed, because I know it's annoying the way it is.


I believe something is amiss because my "new names" aren't showing up in past logs AT ALL. When I open the log from the device page, it highlights the device type for that specific device. Nowhere do I see its name or label which is "L Kitchen"


But my Live Logs look great! Not much in there yet but this what I like to see...


I just noticed that my Past Logs time is 2 hours off from Live Logs, and actual local time.

Thanks (on behalf of all the people heavily disturbed by this), it has always been just waved off in the past. A few people have very aggressively brought this up before. Logically it would make more sense to use the "newest" name at the top, but it uses the "oldest" name currently (whatever name it sees first going from bottom to top.

This is one of the big reasons people have also pushed for the purge logs on reboot, which has yet to work on my C8, only my C7.

@TomS you can try doing a reboot and check the purge logs option, but it is hit or miss right now, not working on all hubs for unknown reasons.

Someone else brought this up in Beta I think, it had something to do with remote admin or VPN from another time zone if I recall correctly. One page was using the hub time for the logs entries and the other was using local (browser) time.

Both are the same for me but my hub time is the same as my local time.


Great, reboot with clear the logs did the trick for me. Didn't think to try that, but I'm still confused as to why "Names" of new devices get set to their device type in the first place. Don't quite understand the correlation between the two, or the need?

If the type is a model specific driver you get the model in there. Sometimes inclusion happens where you do not even have the chance to type in a custom label (Smart Start).

The reason it goes into the logs is because things are already being logged during onboarding and configuration before you get the prompt to add the label, so the displayname for the device is temporarily the "default" name which is the driver/type name. It is better than just having it populate with "Device #D2" or something even more generic.