What should I do if I can't connect to C7 hub and the hub is not processing rules?

Hi All,

Recent issues with my C7 Hub. 2 weeks ago my hub stopped running rules. When I tried to log in to see what was going on, I was not able to connect to the hub. At first, the hub was recognized, but just wouldn't connect. Now it's not even recognized. A few items I tried:

  1. Rebooted/Power Cycle. Hub turns on and has a green light.
  2. Checked ethernet cables.
  3. Attempted to access diagnostic tool/8081 port, but am unable.
  4. Tried advanced discovery by MAC and by IP, but was not found.
  5. Reached out to hubitat support and haven't heard back.

Thoughts?

Thanks

Through the support portal (support.hubitat.com) or by email?

Also tagging @support_team

2 Likes

I emailed them about 2 weeks ago.

The fact that the hub stopped running rules might be indicative of a database issue, however the Diagnostic Tool would be available. Unfortunately, without access to Diagnostic Tool, there isn't much that can be done. Opening a warranty case to get a replacement is likely the only solution:

Might want to try a reboot of the router; sometimes that wakes everything back up.

1 Like

Thanks for the quick response. I'm definitely not in the 90 day window for a warranty claim. This hub is about 2 years old.

Has the hub's IP address changed lately? If the LED is green, it means the platform has loaded.

2 Likes

In rare cases it could happen that a hub dies. We strongly recommend adding Hub Protect plan. Not only does extend the warranty of your hub for the life of the plan, should the hub fail, but also you will have a cloud backup that allows you to load onto a new hub, so you don't have to rebuild your Z-Wave network, as well as automations. You can read more about Hub Protect by visiting the following page:

Hub Protect | Hubitat Elevation®

1 Like

No change to IP since I first hooked it up.

Also, are you using jumbo frames on your network?

Is the IP assigned statically on the Hubitat, or is it via a DHCP reservation?

Either way - can you try resetting the IP using the button on the underside of the hub?

The process is described here:

https://docs.hubitat.com/index.php?title=Network_Setup

5 Likes

I think resetting the IP address may have done the trick! Good call. Once I reset it, it still wasn't being discovered, but I was able to log into my router and find the new IP. I logged directly into the IP from a browser (bypassing the Hubitat interface/discovery page) and was welcomed to a corrupt database error. From there, I followed the soft reset procedure and reloaded a backup. All seems to be working now.

3 Likes

This topic has been marked solved by the community and subsequently closed. For further discussion on this topic, feel free to create a new thread under a different category to continue the conversation.

If you are logged in, click [HERE] to get started.

Download the Hubitat app