What am I missing here?

I have a zigbee light on my dresser that has the level controlled by mode lighting. For the past few months the initial turn on after a mode change is at the correct level and then it changes to 100%. A simple off and on will get it back to the correct level but why does it go to 100 to begin with? Even my mode lighting does not set 100%. This is a C7. Here are some details:

Doesn't matter what app triggers the light for this to occur and again it only happens the first time it's turned on after a mode change has occurred. Yes I can control it with Alexa but the option there for hunches is turned off.

From the device events, it looks like the bulb driver is automatically setting it to 100% - is there a setting that could be doing this?

1 Like

:point_up: Agreed - this is most likely the culprit.

@tivomaniac Please share a screenshot of the device details page for this light, including all of its user settings.

1 Like

Doubtful. I have a bunch of these and it's the only one doing it.

Have you tried it with the "Enable level pre-staging" off?

1 Like

It was that way I turned it on to see if it would make a difference. It worked fine for years but a few months ago started doing this. Tossed a band aid rule in earlier today to just turn the light on for a couple seconds and then off when modes change to hopefully flush the one cycle out. Will see if that works today. Not ideal but...

Also realized the bottom part of the device page wasn't there...

I could try a different driver but it's the same driver on all my Sengled bulbs.

Changed it to use the legacy driver. Will see if that makes a difference.


Other driver made no difference. Dunno. Very odd.

1 Like