Webcore - Philips Hue Zigbee Plug needs Refresh

This plug works perfectly with an Alexa command to turn OFF. But it will not turn ON with an Alexa command if I don't add the REFRESH. I'm currently using the Generic Zigbee Switch driver. Thoughts?

There are likely two problems/issues working together to create this outcome:

  1. Your device is not reporting back to the hub correctly. Running a "Configure" command on the device may fix this. (Otherwise, the typical Zigbee troubleshooting will apply.)

  2. Your piston is not sending the command because it thinks it's in the wrong state, and command optimization is enabled. See:

This is a (likely) guess based on your symptoms. If you still have problems, or don't want to change the setting above, enable logging to see what's really going on, and then you'll have more clues to work with.

You are correct. But Configure did not fix this.

Again, you are correct. Turning off command optimization worked to be able to remove the Refresh command. But the state of the device is still not being reported correctly to the hub. However, when I use the Refresh command in webcore, the correct state of the device is reported.

You could try re-pairing (don't delete from Hubitat first--it will slide back into place, so it's easy). No guarantees, but sometimes it helps with this kind of thing.

To be clear, I didn't mean to imply that the webCoRE setting would help with the device itself, just be a likely workaround for this problem. :smiley: If you don't rely on the state on the hub being accurate for other reasons, I suppose you could deal without this. Otherwise, maybe the above would help -- or you could be dealing with something else like mesh range, odd Zigbee devices messing things up (any smart bulbs on this network?), etc.

The first thing that I did was re-pair the device. I even played with different drivers. No dice. The device connects directly to the hub and I feel that I have a healthy mesh. No smart bulbs in use. All good suggestions to troubleshoot. I could just leave command optimization off and not worry about the device state. Or, I could just continue to use the Refresh command. Either works perfectly. Currently, I am using this plug for Christmas lights. So not a bid deal for accurate device state for this use. But I will want the correct device state in future uses. So the troubleshooting continues.... Thanks for all of the great insight.