webCoRE for Hubitat Updates

I'm getting a problem - the piston never runs (I've added logging in very first line but it never executes) and instead I'm seeing an infinite stream of events like - only pausing the piston will stop them.

According to git blame this may be caused by a recent change

Any ideas what is going on and how to fix it?

Can you show us the piston?

We resolved this issue. It seems to be on import from ST, it thought there was still a deviceSubIndex (even though there is not one). recreating the if statement resolved this issue.

There is a new release out today, as there seems to be some compiler/runtimes changes that happened in HE that displayed a bug.

Thanks for spending time on this!
I tried but couldn't find the donation page - do you have one for this project?

1 Like

I don't have one. If the webcore folks have one, you can do it there for them.

I'm paying it forward for myself.

1 Like

Another problem shown up - at some point newly added devices are not showing up in a Webcore.
I have 79 devices and at some point new devices stopped appearing in a webcore. I'm just adding more switches and bulbs - same as I have in there already, devices are listed as "In Use By: Webcore Hubitat" but I can't find it either in Physical Device dropdown or at Devices on the right. Any ideas what may be causing it? I have a suspicion that it may be related to adding a Child Notification device for Innovelli switch - it started happening after I've added the first one of those.

I would need to see some logs from the webCoRE main app, and settings from that app.

Are you using the public webcore servers, or your own?

You may want to move to a private message to avoid releasing too much information in public.

Nothing to share really - I've updated the devices but logs are totally empty.
Default settings, public server.

I can confirm there is something going on.

  • I created a simple piston "Test Piston" with one device.
  • I then go to Hubitat Hud's APP tab and select that "Test Piston" and under devices it doesn't list the device as it use to do in the past.
  • Finally I display the device itself and it doesn't show it being associated with "Test Piston"

It does not effect the execution operation but not having this information properly displayed can make for a nightmare in keeping track of what devices are in use by what piston.

The logs show nothing out of the ordinary so I have not listed here but have screen shots showing the problem. Should be easy to duplicate on your end. BTW, I am on one release behind as far as Hubitat but the latest release has the same problem.

I would need to see higher up in the webCoRE dashboard under "Quick Facts" when you have the piston open in the webcore dashboard.

The example you show does not have any subscriptions (no lighting bolt). so This is what HE uses to display in use typically (it also uses that that a setting is set for the piston for the device). In webcore this gets updated once the piston is run when there is no subscription.

Can you execute (hit the test button) in the webcore dashboard when you have the piston open

Also be sure you have the current version of webcore running.

The piston I created was intended to be a simple as possible. It has no triggers.
Two tests were tried. The first test involved creating the piston and saving it (without out running) The results shows just as I showed before.
Next I ran the piston using "Test" which executed and did what it was supposed to do.
The results of the missing device as shown above remains.

Here is a screen capture of the piston and the info from Quick Facts. The data remained exactly as shown both before and after the "Test" execution.

The best I can tell I am on the latest release from Dec 17th and should be reproducible using any device on the latest version of WebCoRE

Here is another piston that has two devices, one being the trigger.
Results are the same, both before and after execution. Neither of the two devices are listed.

Hmm

I just ran a test and it works...

  • I opened one screen to HE console -> device in question
    • it does not show being in use by my test piston, but it does show in use by webcore
  • I created a piston, that uses the device without subscription
    • saved the piston
    • hit refresh in the other window, still only shows webcore main for the device in HE console
  • Hit test in the webcore dashboard for my new piston (executed it so it reads or uses the device)
    • logs show the piston loading the device from the parent
    • hit refresh in the he console window, and the device shows it is in use by both webcore and the piston.

I'm using the webcore release from a few days ago.

Don't know what to say. The screen shot shows I am on the Dec 17th release.
I have also tried logging out of the WebCoRE dashboard, did a hard reset, and register the browser again. I have relied on the the app names showing on devices and first noticed this problem on Dec 21st when I had a problem with a device and had to remove and reinstall it.

When I get a chance I will re-install the previous WebCoRE version to see it the issue resolves. I will let you know the results when I find out.

1 Like

put the latest groovy file for the piston on your system and let me know

1 Like

OK,

webCoRE Now;

  • Last Updated December 17, 2019 for Hubitat
    public String version() { return "v0.3.110.20191009" }
    public String HEversion() { return "v0.3.110.20191217_HE" }

webCoRE Piston Now;

  • Last update December 20, 2019 for Hubitat
    public static String version() { return 'v0.3.110.20191009' }
    public static String HEversion() { return 'v0.3.110.20191217_HE' }

Deleted the original "Test Piston" and create a new one using the same parameters. Tested to make sure it was functioning as expected. The app name still does not show as being in use on the devices and in the webCoRE app the devices are not showing in the devices field. Same issue as originally reported.

1 Like

So send me in a PM your piston code/green snapshots, I'll run your piston.

Hi everyone,

I am trying to run WebCoRE on a Raspberry Pi. I did all the major stuff, and I can see the WebCore page when using my Raspberry Pi IP address. So I guess I am good. But my WebCoRE Dashboard does not load my pistons and does not seem to connect to my Hubitat. The IP adresses of both my Hubitat and my Raspberry are set as Custom endpoints. To be noted that when I try to use the WebCoRE Dashboards from the cloud, it works perfectly. Do you know what I am missing ?

EDIT : Ok, I unistalled the webcore app and reinstalled it with no luck, nothing changed. I uninstalled it again and reinstalled it, and now it works like a charm. I have absolutely no idea on what went wrong or well in either case...

I have a new version and I'm looking for some beta testers. Once again - much faster, less state usage, some bug fixes.

If you are interested, send a Private message. Would be good to get some additional testing before releasing.

Beta will require cut and paste of code into the HE console -> apps Code.

New release posted today. Many new optimizations and improvements.

Be sure to

  • restart your HE hub prior to installing (HE console -> Settings -> Reboot hub)
    • Allow the hub to settle after restarting for 5 minutes or more
  • Take a backup of hub and store off the hub (HE console -> Settings -> backup and Restore -> Download)
  • Update the files webcore-piston.groovy and then webcore.groovy in:
    • (HE console -> Apps Code -> webCoRE Piston)
    • (HE console -> Apps Code -> webCoRE)

Database accesses are a source of overhead, so the comments in first note on reducing logging is good for performance once you are done debugging.

4 Likes

Download the Hubitat app