webCoRE for Hubitat Updates

You can see a subscription to the global variable if it is used as a trigger. (subscription to the variable).

You are correct original webcore is pretty inefficient here.

Okay....that was always one of the major headaches when I first moved to HE and migrated my pistons. The few that I kept at the time had to be jammed together into very large pistons because you couldn't use global variables. Every time a global variable got updated I would see 10-12 piston executions and my hub would be brought to it's knees. Good to know that has been changed now. :+1:

BTW, did we ever find out what was going on with the registerInance issues? I still have it commented out as it continues to post 408 errors.

HE folks are aware of a server issue (registerInstance) and cloud fuel streams.

I thought this latest release should not call that if you are running a local instance of the webcore servers....if you are and seeing this, then I have a bug...

It appears to be working normally again. I watched it cycle several times and its acting as it should. Thank you very much for all the time and effort and especially your quick responses

I'll admit, I didn't give it a chance, I commented it out when I loaded it. :blush: I'll import again and see if the 408's are gone.

Another small bug fix today to webcore-piston.groovy

please upload this fix

1 Like

Overall better responsiveness. Noticeable improvement in handling database updates when new versions are released. Use to be a little clunky having to load a small piston and having to exit and go back in to get things working. This time around loaded a small piston and database updated right away. webCoRE just keeps getting better,

Since updating to the latest release I have experienced a problem with at least one piston.
It is my morning wake up piston that fires after pressing a button. It no longer fires. It is a piston that has been in operation for many months with no problem.

Things I have tried to get it working again. Edit/Save. Edit/Modify/Save. Pause/Resume. Import it into a new piston. Reboot hub. None of these work. (below is a copy of that piston and the error log) There is no log generated in dashboard.webcore.co because the piston never fires to generate one.

What did work was creating a brand new piston duplicating the same thing that is in the piston that fails, The new piston works as it should.

I found another piston that no longer works. Appears to be the same situation as the previous one I posted. Again the solution was to re-enter the same command into a new piston.

So far only two out of eighty-eight. There may be others but so far haven't found any. Perhaps these errors will point to something.

updates posted that should resolve both of these.

thx for reporting.

1 Like

Hi, has anyone had issue getting devices to load?

I have added all my devices to webcore, but when I open the dashboard, my devices will not load. I tried removing some to see if any were causing an issue, but it doesn't seem to be working.

I get the "There was an issue loading your devices...the data may be outdated..." message.

Are you up to date with the latest version (see note 1 in this thread)

the webcore servers have been changed and you should ensure you are running the latest groovy code for HE.

Updated to Oct code and a few pistons stopped working with this error, please help...
image

for the time being is there a way to rollback to Aug version?

For others, we looked at this and the issue is not happening. If it comes up again we will debug the issue.

@nh.schottfam I updated on Friday and received the same error in the log for my kitchen lighting piston

This resulted in no action from my kitchen lights and a -10 from the wife. I tried recreating the piston but this did the same thing.

interestingly when I duplicated the tab in chrome to recreate the piston this happened

here's the versions i'm running, I also run a local webcore on my Rpi I've tried a "git pull" on that and it says its already up to date.

Well, first, the last screenshot doesn't show anything at all except the app names. There's no way to tell from that what the version of each is.

Are all the devices you have in this piston still linked to webCoRE? I can tell you, I will not be surprised if you have trouble with this piston. It seems awfully long and complicated for a single piston in conjunction with Hubitat.

D'Oh I could have sworn there were version numbers on there! serves me right for posting early in the morning.

the piston has been running perfectly since July and never missed a beat. It fires my kitchen lights so it gets some use.

For everyone, we found the bug, will post an update today.

1 Like

Does anyone have any thoughts on this?
I've noticed this as well and have been doing copy and paste for my RPi files to keep them updated.
Tagging @nh.schottfam in case you have any ideas. Thanks.