webCoRE Activity Not in Hubitat Logs

Over the past few months, my automation (all webCoRE pistons) have become so intermittent in behavior I'm about to throw the whole thing away.

In this instance, you can see webCoRE believes it told the office light to turn off. But if I go to my office light in Hubitat, there's no command received.

Has anyone else seen this? Or better yet, know of a way to correct it? I've already added a "verify lights/locks/garage doors are in the state webCoRE last sent" step to most of my pistons, but even that is proving inadequate to get consistent performance.

I'd say on average my pistons that shut off 3 or more lights are working 60-80% of the time over a given week.

Appreciate any help here!

webCore logs (abbreviated)

7/8/2024, 12:00:44 AM +349ms
+2ms â•”Received event [Chandelier].pushed/physical = 3 with a delay of 19ms, canQueue: true, calledMyself: false
+25ms â•‘RunTime initialize > 24 LockT > 0ms > r9T > 1ms > pistonT > 0ms (first state access 20 m:23 2 22)
+27ms â•‘Runtime (11897 bytes) initialized in 1ms (v0.3.114.20240115_HE)
+28ms â•‘â•”Execution stage started
+34ms â•‘â•‘Comparison (integer) 3 gets (integer) 3 = true (1ms)
+34ms â•‘â•‘Condition #2 evaluated true (4ms)
+35ms â•‘â•‘Condition group #1 evaluated true (condition did not change) (5ms)
+48ms â•‘â•‘Executed device command [Upstairs Hallway].setLevel(2) (9ms)
+61ms â•‘â•‘Executed device command [Master Bath Lights].setLevel(100) (10ms)
+72ms â•‘â•‘Executed device command [Master Closet].setLevel(100) (9ms)
+86ms â•‘â•‘Executed device command [Master Fan].setLevel(100) (11ms)
+97ms â•‘â•‘Executed device command [Master Lights].setLevel(100) (10ms)
+102ms â•‘â•‘Command optimization: Skipped execution of device command [Back Flood Lights].off() because it would make no change to the device. (0ms)
+111ms â•‘â•‘Executed device command [Basement Bar].off() (8ms)
+124ms â•‘â•‘Executed device command [Basement Family].off() (12ms)
+134ms â•‘â•‘Executed device command [Basement Family 1].off() (8ms)
+145ms â•‘â•‘Executed device command [Basement Hallway].off() (10ms)
+162ms â•‘â•‘Executed device command [Basement Porch].off() (15ms)
+172ms â•‘â•‘Executed device command [Basement Stairs].off() (8ms)
...
+274ms â•‘â•‘Executed device command [Office].off() (8ms)
+276ms â•‘â•‘Command optimization: Skipped execution of device command [Playroom Main].off() because it would make no change to the device. (1ms)
+286ms â•‘â•‘Executed device command [Pool Table Lights].off() (8ms)
+288ms â•‘â•‘Command optimization: Skipped execution of device command [Screened Porch Light].off() because it would make no change to the device. (0ms)
+291ms â•‘â•‘Command optimization: Skipped execution of device command [Garage Bikes].close() ...

vs Hubitat

How many devices are you trying to turn off in one hit.
I have a piston that turns everything off when pressed. About 15 devices.
It was always failing to turn them all off.
Just to much for the ZigBee network I suppose.
I put a small delay in between each device command and now it's 100%.
Might be something to try.

I'll give that a shot for the larger ones, thank you! On my pistons that have 2 and 3 devices I'm seeing the same issue so I think there's something else at play, too.

I should also clarify, I only used office as an example in the piston and Hubitat logs above, but every device that webCoRE shows log activity for had no activity in the Hubitat logs and remained on.

Can you show us one of your pistons?

Here's a simple one. I had to add a second off attempt after it started failing regularly.