Wait for event - RM bug or hub issue?

I have a rule that has a wait for event with a 2 second delay at the beginning of a rule. I do this as a way to halt double triggers. This is a rule to set a presence device showing activity in the house. A switch turned on, motion in an area that would only be triggered by a human, etc...

Most of the time it works but since I have moved it to a different hub it has occasionally stopped on the wait and never times out. The rule sits there until another trigger occurs. You can see in the screenshot below the area circled and labeled "didn't work". It set a 2 second wait at 9:12:41 and did not start again until 10:00:20 about 45 minutes later when another trigger occurred. Earlier in the rule circled and labeled worked, you can see it wait and continue on as it should.

Maybe it's something with the rule. Its a new C7 hub that I just brought online. The rule originally was running on one of my C5s, and I never saw this. Since I moved the rule from a C5 to a C7 I rewrote the rule from scratch as it originally was a legacy rule. So this is a fairly old rule that has been working for some time. I did re-write however so maybe there is an issue, but that part is pretty straight forward. It's the very first line of the rule, wait 2 seconds to make sure there is not another trigger.

So it's on a new hub, and a new RM. Has anyone else seen anything like this?

Could we see the rule? I’ve got a similar rule where events happen almost together, and the first line wait has worked 100% correctly to not do the rule until all events have occurred.

In addition to the above, turning on event or trigger logging would be helpful. Right now, it's hard to know what is in the logs for what reason.

Also, just curious (it may be helpful for staff if there is in fact a problem, but it won't be much use for an individual to fix on their own): when the timeout never completes, is there anything under "Scheduled Jobs" on the "App Status" (gear icon) page? There should be at least one during the 2-second wait, so if you can see the page during and after, that might be useful.

So right after posting this I decided to start using the Private Boolean method of halting triggers. Using it as a required expression. This seems to be working pretty well.

Apparently this issue is not a widespread problem and I use the same technique in other rules, and I haven't noticed an issue with those. So I will chalk it up to something got corrupted, and if I see this in something else I will persue further.

1 Like

Download the Hubitat app