Virtual Switch in Google Home Not Responding

I've setup a virtual switch for controlling my garage door. The virtual switch works fine in HE, but when linked to Google Home I'm getting a Not Responding/Offline from GH. None of my other switches have this status, and everything else is operational.

I didn't see anything in the HE logs, any ideas?

I was having this issue in the last few days. Can't quite remember how I solved it. The only things I could suggest are:

  1. Tell Google to "resync my devices"
  2. Take the switches out of the list in the Google app in HE and put them back in the list. Perhaps try a resync after taking them out and after putting them back in.

I also had some issues with my router around the same time, so maybe try restarting your router and/or HE hub.

All pretty much wild stabs in the dark... Probably good if you can post how you fix it, would be good thing to capture for anyone else who has the same problem.


I had the same issue with one of my lights a couple of days ago and ended up having to remove it from the GH app, sync then add it again.

1 Like

Here's everything I tried that didn't work for me:

  • reconnected Hubitat to GH (multiple times)
  • deleted the virtual switch from GH integration, reconnected, added virtual switch back, reconnected again
  • deleted the virtual switch and started over
  • rebooted the hub and router

Here's what worked:

  • changed the driver from Virtual Switch to Generic Z-Wave Switch, and reconnected account, then I changed it back to a virtual switch without reconnecting.

This was just a random guess, I had no evidence to point me in that direction other than some of my other physical switches use that driver.

1 Like

Glad to hear you got it working