Very laggy devices

I did find that a daisy chained zwave bulb behind a zwave outlet was turned off almost all the time. it's right next to the hub so might be used in many of the routes. with the bulb powered off the mesh, my suspicion is that it was causing issues with routing. i now keep the outlet on at all times to make sure the bulb remains on the mesh. either i got lucky, or this helped. the performance and reliability is up. any thoughts on this reasoning?

i have the mouser usb stick coming today so i'll remove those ghosts. hopefully all will be resolved then.

1 Like

If the bulb routes then I'd toss it in the trash. There are particular brands that don't route. I'd replace it with one of those if you need a smart bulb in that location.

1 Like

I don't know how bad Z-Wave bulb routing is vs Zigbee Bulb routing.. BUT at least with the Inovelli Ilumin bulbs it is clearly stated in the manual that you MUST keep them powered at all times.

Honestly except for the ghosts things look fine. Those ghosts will crush your mesh though. You may not need the z-wave stick to remove them. Either way though, once you're done, shut down the hub, unplug at wall (not hub) for 5 mins. This will clear your radio. Boot back up. Go to settings, backup. Make a backup of your current database. Do a soft reset, then re apply the database you saved to your pc. This will ensure you have no database corruption.

1 Like

ghosts are gone. i ended up with the mouser stick and followed Dropbox - Hubitat UZB Stick How-To.pdf - Simplify your life. the one thing I had trouble with is getting PC Controller installed using Simplicity Studio v5. With v4, it worked as stated in the How To.

will report back if an issues persist.

2 Likes

Download your latest backup, Do a soft reset and reapply what you backed up. This will insure your database is not corrupted. After all is said and done, shut down the hub, unplug at the wall for 5 mins, power back up. Run z-wave repair

1 Like

I might hold off on running a full Z-Wave repair for a bit to see how things stabilize.

1 Like

I'm only a day in but the system does seem to perform better. Also, it does look like the power meter is spamming the mesh. i didn't see this before. sample log below:

the only thing I can see to do is enable a power reporting threshold. i'll try that to see if it reduces the frequency and still provides the functionality i'm looking for:

1 Like

The power meter is running less than 300ms every 120 seconds. Something like 1/4 of 1% of the total time. That is not so bad. I have the same meter and I run it every two minutes as well.Power and nothing else but still I don’t think it’s so bad

Looks like you get 5 messages in about 260ms, every 2 minutes.
That's like a cyclic spurt of messages.

I am not sure how other Power Meters work but that is spamming when you consider that this device is not the only other on the network and should at least delay messages in between to allow for other network traffic.

Basically this device assumed that for that small window, nothing else on the network matters.

You do not want all those power reports on, pick just one or maybe two things and turn the rest off. You are probably going to only want Power Reporting (watts) and not intervals, percentages, voltages, or anything else. And when you do set the watts, be realistic about the load. A wash machine might be just fine at 100 or more watts change threshold. The lower the threshold, the more reports and the more needless reports you are going to get.

Do this for all power reporting devices, they are pretty bad for the mesh if set incorrectly.

Any idea why these show null and yours don't?

Btw, I upgraded to the newest release of Hubitat, and now in my ZWave Details screen I no longer see the in/out clusters. How am I to find a ghost in the future?

They are still available on the device screen .. They weren't providing any useful information here.. If you click on the device on the right it you will see it on the bottom of that screen.

There won't be a device listed it will show a "discover" button.. And likely a true ghost won't even have device class information, but an included device that didn't make it through discovery, just won't have device assigned.. But you can use the Device Type and Manufacturer to better figure out what device is holding a node id..

On the data devices you created from the child app. Click on devices and then click on the data device and then scroll down to preferences and put whatever you want the identifier to be.

image

image

1 Like

Download the Hubitat app