Variable for Chime number

:+1: Thank you sir!

Hi @bravenel, I got this setup and I am getting a Groovy Cast exception trying to cast a string to a short...

I double checked that my hub variable is configured as a number. The rule correctly shows the value of the variable just like your example above. Do I have something mis-configured? Or is there an issue? Thanks!

I will look into it. Should not be throwing an error.

What build are you on, and can you post a screenshot of the rule? At the bottom of the rule there is a version number, what is that?

Fix for this bug coming in next release. Sorry about that, missed it in testing because my chime worked.

No worries, thanks for confirming.

Thanks, it's updating now, we'll see what happens.

Hi @bravenel, sadly that made it worse, I cannot even open the rule now. I get the same error when I run it and now when I open the rule I get this...

Both log errors are here...

Please remove that rule and recreate it.

I'll give it a shot.

No luck... literally, as soon as I typed the variable into the chime field I got this screen...

Here's the rule.

Here's the build...
Screenshot from 2021-11-24 18-48-53

To be clear, I tried to use the set chime action and as soon as I enter in the variable the error appears, Now, in this rule above, obviously you can't see that chime action but if I try to select actions to run I get the error again.

OK, sorry about this. I can reproduce it. Will get it sorted out.

1 Like

Thanks! No rush, enjoy Thanksgiving with your family!

1 Like

Found this problem and fixed it (again). Don't get too invested in this approach. What I should do is make the variable selection explicit instead of using %var-name%.

1 Like

Ok, I gotcha. Have a great Thanksgiving.

1 Like

Hi @bravenel, hope you had a great holiday; just wanted to give a quick update. I'll give the latest FW (113) a try later and report back. I had to revert back to 2.2.9 and restore and old backup. After I upgraded to I followed the procedure to open RM and hit 'done' to update the rules that use a variable trigger. That and everything else seemed to work fine but when I upgraded to .112 I ran into a couple odd issues. I didn't open RM and hit 'done' again, since I was on a 2.3.0 version, and it did wipe out my variable triggers, a button rule that was working fine suddenly wouldn't open with an unknown error and I had to re-write it, and obviously the chime variable issue still didn't work.

Hi @bravenel, I went to the latest update today (116) and it works like a champ, thanks!