V2 iris keypad requiring hub reboot

This was the second time which the iris v2 keypad doesn't beep a countdown when HSM armed OR turned off but worse is it doesn't turn off or on the alarm. The dashboard functions with no issues turning the alarm off or on. All other devices and rules/notifications work fine. If I reboot the hub the keypad works fine for another few weeks. I do have my router and modem reboot every morning at 3am and wondering if this is causing issues or if anyone else has an idea of of the keypad issue. Also I had put in new battery in the keypad last time this occurred. Thanks for any comments or suggestions

I imagine you have your modem and router reboot due to issues occasionally with internet access otherwise? I had issues about monthly with my old Netgear router but since I went to an ASUS router a few years ago I've only had to reboot it once when the internet didn't work.

I haven't had problems with my Iris V2 keypads although I don't use them real often as most of our arming disarming are done via our phones as presence sensors or based on schedule to arm night or switch back to disarm. Have you tried removing the batteries in the keypad waiting a few minutes then putting them back in to "reboot" the keypad instead of the Hubitat hub, does that fix the issue for a while too?

Unless your ISP is really bad, there should be no need to reboot the router and modem daily. If anything, you are causing yourself more issues as you are wiping out the ARP tables daily and those are required for maintaining a good home network. Professionally speaking, I would suggest that you reboot only your modem once a month or even once every two months. If your ISP is just that craptastic, then you may want to look at getting better equipment and/or a better ISP.

Most modern routers don't need to be rebooted more than once a month.

Which leads me to your keypad issues. It seems like your Zigbee mesh isn't strong enough for the keypad to stay connected reliably. This could be an issue with the channel your 2.4 ghz WiFi network is on. If you are rebooting nightly and don't have your WiFi channel set manually, then your router is going to automatically pick which ever channel it thinks is the least congested. If it's picking a channel that is close to your Zigbee channel, you are going to have issues with devices staying connected to your HE due to interference.

First I want to thank you for responding, I was losing hope Lolo. It may have been my imagination about slowing down of my Internet and the reason why I have the modem and router reboot at 3am. I read somewhere that hubitat does maintence at that time and the reason why I mentioned me rebooting of my modem and router. As to the question of removing the battery and inserting it back to see if that helps , I did ( the first time this occurred a few months ago) and yes the keypad started to function correctly again. The battery showed 50% at that initial time so I replaced it. This past time it still shows 100% and I probably should have removed and inserted the battery again but opted to reboot the hub which corrected the beeping of the keypad when leaving and entering and full function of the keypad again. First I'm go to stop the auto reboots of the modem an router. Do you think removing the battery is the better way to resolve the problem if it continues rather than reboot Hubitat? Thanks so much for your input

Thanks coreroottedxb! Definitely going to stop rebooting the modem and router. Once in a great while my wife would have an issue with our internet connection and thats my initial reason for rebooting. I have a good TpLink router and believe the issue is with my ISP. Really appreciate your views!

1 Like

Absolutely! I get it about the wife. When I tell my wife that I'm rebooting my modem (AT&T Fiber), she always looks at me and asks if she'll lose the internet... on her phone... I love her, so I just smile and go about rebooting the modem.

With my wife ( and I'll cover my butt too ) who I also love dearly Lolo, it's NEVER a good time to reboot and the reason I let timers do it each evening. Guess I'm back to asking my wife if it's a good time to reboot haha. Again thanks for your input.

1 Like

I had two Iris v2 contact sensors and 1 Iris v2 water sensor that dropped frequently while none of the others (21 contacts and 5 water) did, I replaced the three devices and tried the water about 6 feet below the hub in the same room and it made it a week the first time then about 3 weeks the second. I'm planning to retire that one soon. Hopefully your keypad isn't like those.

Gonna try not rebooting the modem and router an keep my fingers crossed the iris keypad isn't having connection problems like your sensors had. Thanks for info!

1 Like

You might also want to look at your WiFi and Zigbee channels. On your router, try setting your WiFi channel to something low like channels 1-6 and on your HE hub, if your Zigbee channel is anything lower than 20, you might want to consider setting it to 20 or above. The reason for this is that Zigbee and 2.4ghz overlap and can cause interference with each other. So, a strong Zigbee mesh can cause WiFi interference for your 2.4ghz devices and vice-versa.

This article is a good explanation of what I'm talking about: ZigBee and WiFi Coexistence — MetaGeek

Now, I say might because this is not an easy fix. You'll most likely have to re-pair your Zigbee devices. They might auto-heal and reconnect automatically, but that isn't always the case and varies from device to device, in which case, you'll have to run around and re-pair your Zigbee devices.

It's not fun, but the pain usually equals a much better experience going forward. So, take this with a word of caution that there WILL be pain in doing something like this.

Great info. Will definitely take a look at the router and zigbee settings.