Updating C7 with 2.2.9 Fails 2 for two

Twice I have ran into this issue updating C7 on the 2.2.9 code has failed. Moving from 2.2.8 to 2.2.9 and now 2.2.9 build 128 to 129. C5 updates without issue and it is quick. C7 never completes. First time major build update. It failed I had to pull the power after 15 minutes of "updating". Revert to old Platform, soft reset, (corrupted DB) restore from cloud back up and then apply update again, this worked.

Updating from 2.2.9 build 128 to 129.

C7 and C5 was up for less than 24 hours. C5 No issue updating
C7 Fails on update again. Second attempt, rebooted through diagnostics. Hub console still didn't' come up. Connected through the diagnostics again. Reverted Platform build 128. Didn't see any issue this time with the DB. Proceed with update again. This time it applied correctly.

I'm noticing the last few Platform builds that memory consumption has gone up and degrades faster over time. I don’t know what areas of the memory are being affected (kernel, system, device, etc). C5 and in the C7 and the update process seems to be affecting C7 and not the C5. Note most of my devices and services are on c5 and all the S2 devices are C7.

Coming to my conclusion is I wonder if reboot c7 prior to the update. Would I have seen this issue? Is there a memory leaking issue that affects c7 and updating it?

As far as I can tell this is pretty consistent problem with the updating issue.

1 Like

This may be a UI issue we just found. Give it a few minutes, and see if the hub comes up at its IP address. The UI problem causes the update progression updates to stop showing, giving the impression of failed update, when in fact it continues to progress.

What is the specific evidence of failure?

Hub info shows the correct IP. I don't see any change. If I attempt to connect to the web console, I receive a broken page. I have left in that state for unusually long time well over 15 minutes +. No response. Diagnostic page showed it was update. However, I was unable to communicate with the hub other than Diagnostic.
It even showed up in the remote admin. Couldn't connect to console.
The first time I even saw the LED light go from blue and green and still no response.
Second time it was like the web page time out and got a broke webpage again IP was correct and Diags showed updated.

What happens if you reboot the hub?

Also, see this thread:

Both C5 and C7 report running Most likely a new IP address, that happens on updates.

1 Like

I couldn't get to the web interface. Page cannot be displayed. It didn't jump it was pingable and reserved in DHCP. Yes, I did try find my hub and it found it on the correct IP Address.
The web console was completely unresponsive.
Diagnostic wouldn't have come up on the device if the IP address had changed. You are access via IP on 8081 and the diagnostic page had the correct IP in it too.

IF that was the case applying the update again should do it again. c5 is setup the same exact way does not have an issue.

OK, not sure what's going on with this. Using :8081, roll back to 2.2.8.xxx. Then try the update again after that.

When 2.2.8 > 2.2.9 yes reverted back to the last platform (2.2.8). it stated DB corrupted. Soft Reset and restored DB from a few hours ago. Rebooted 2.2.8 applied 2.2.9 right after that. no issue.

Second on from build 128 >129. I revert back to 2.2.9 128 after the unresponsiveness. Everything came back OK. (no DB Change). Applied 2.2.9 129 again. All working.
Only thing I see is the rebooting before applying is the ONLY change I can see.

You know, there's no telling what might have happened. There is not a general problem, because there are thousands of hubs updated to 2.2.9 without issue.

I'm just glad it all came up for you. And, sorry for the hassle factor.


I assuming that there isn't any logging of this process to understand what may have happened. There should be some sort diagnostic logging of updating. Even if it is a small text to download and review from the Diag page.

I appreciate your help and input. I'm just trying to make sense of this too.

"there are thousands of hubs updated to 2.2.9"

how many "thousand" ? :grinning:


Again, another example of this happened. Now this isn't from an update.

Diags Page


However, I have hub mesh enabled and I still can access the devices and they work.

Note C5 is OK.

Hmm, something is going on with that hub. I'll take a closer look.

Rebooted everything came back and I'm updating 130 just see if that goes smoothly after the reboot as I'm expecting. Let me a little bit of time.

C5 has been running for the same amount of time without issue and updated without issue too.

If you run into the same thing (nothing comes up on port 80), could you please try accessing port 8080 instead? That will help with troubleshooting...

@gopher.ny Sure thing. FYI.. after the reboot of the hub, this was the first time the C7 was able to be updated too without issue. So, I think there is something OS/System related. I will let you too.

1 Like

Update from 130 > 131 was successful on both hubs today :slight_smile: :+1:
Now I have let them run for three or four days to see if that other issue comes back.


C5 has been running for 5 1/2 days and now it crawling. Once it does come up

Very slow.. Memory is down round 21.4MB (DB only at 62MB) cannot get in Logs.. Will be attempting to reboot. Port 8080 same thing.
Don't know why this is happening.
Any advice?