[UPDATED] Weewx Weather Driver With External Forecasting

community_driver

#183

I dropped the daily.json.tmpl file into /var/www/html/weewx/ which should be the root for a debian install and still no luck. I'm sure I'm missing something simple but I can't figure it out.

The weewx install all went smoothly solid updates to WU and the weewx default html report works fine.


#184

In your weewx.conf is StandardReport enabled or is SeasonsReport enabled? I think they changed the latest versions to use Seasons in which case you have to put your tmpl file in the skins/Seasons folder and modify that skin.conf.


#185

Jackpot!!

Seasons was true so I created the daily.json.tmpl and put in in /etc/weewx/skins/Seasons
Then I modified the skin.conf to reference

[[[json]]]
template = daily.json.tmpl

Then hit up the Pi @

192.168.1.20/weewx/daily.json

and this was the result

{
"title":"Current Values",
"location":"Fox Point North Barrington IL",
"time":"03/21/2019 01:39:00 PM",
"lat":"42° 09.84' N",
"lon":"088° 07.32' W",
"alt":"830 feet",
"hardware":"Vantage",
"uptime":"0 days, 0 hours, 0 minutes",
"serverUptime":"0 days, 17 hours, 48 minutes",
"weewxVersion":"3.9.1",
"stats": {
"current": {
"outTemp":"42.9°F",
"windchill":"42.9°F",
"heatIndex":"42.9°F",
"dewpoint":"39.0°F",
"humidity":"86%",
"insideHumidity":"32%",
"barometer":"30.027 inHg",
"barometerTrendDelta":"3 hours",
"barometerTrendData":"-0.015 inHg",
"windSpeed":"1 mph",
"windDir":"248°",
"windDirText":"WSW",
"windGust":"3 mph",
"windGustDir":"248°",
"rainRate":"0.00 in/hr",
"insideTemp":"69.1°F"

},

"sinceMidnight": {
"rainSum":"0.00 in",
"maxtemptoday":"42.9°F",
"mintemptoday":"37.3°F",
"maxinsidetemptoday":"69.9°F",
"mininsidetemptoday":"64.3°F"
}
},

"almanac":{
"sun":{
"sunrise":"06:52:44 AM",
"sunset":"07:06:13 PM",
},
"moon":{
"phase":"Full",
"fullness":"99%"
}
}
}


#186

You could have just installed my weeWX extension.


#187

I tried that's part of my linux ignorance, I couldn't get the installer to work.


#188

wee_extension --install filename

then restart weewx and wait for the template generation


#189

I just started seeing the double F F now. Where did you put your fix at ?


#190

Search for “fcode” and anywhere that is, add another line. I.e

dewpointRaw1 = dewpointRaw1.replace(fcode, "")
dewpointRaw1 = dewpointRaw1.replace("\u00B0F", "")

Even if you do this, things still won’t look right; see the weather tile:


#191

Yup things are still messed up.

image

image

@cobra Needs to work on this more. Has anyone figured out how to strip all the F and C out of the weewx template ?


#192

Guys.
if you are using this driver on a dashboard
TURN OFF ‘display data units’
Most dashboards use logic to put the units back on again.

I’m sure I’ve mentioned this before a few times.

Andy


#193

It is OFF !!!

image


#194

I’ve been using this ever sice I wrote it without any problems
I’ve been so busy that I haven’t really been following this thread.

Are you saying that the driver is not removing the units when they are sent from weewx?

Andy


#195

It's ADDING. I removed all the units in the template so there is no F but the code is still adding them twice.

No matter what I try it wont go away.

slot3Data : Temp: 72.7°F°F (Feels Like: 52.3°F°F) Hum:34%

And to top it off that is the INSIDE temp not the outside. Outside is 52 not 72

image


#196

Are you trying to use my super tile beta?


#197

If I use individual tiles everything is ok including the units. It's the attributes "weather" and "weatherdisplay" that's messed up.


#198

???


#199

Sorry, I didn’t realise what you,were doing.
I’ll be releasing a much better tile creator next week some time (subject to the final beta going well)

Ok...
As this is using WU then I will be removing the ‘tile’ attribute from the app when I re write it.
Weather Underground has changed the api so drastically that it is a complete rewrite of the driver.
I’m working on the ‘custom wu driver’ atm then I’ll move on to this one.
I’m currently using this driver but it will stop working after next week so I’m hoping to get it all done before then.

This is an example of what you will be able to do...

image

Andy


#200

Im using Apiux not WU


#201

The above picture uses apixu actually

But whatever, I was never happy with the way the driver presents the tile.
Also, there is now a restriction on the number of characters sent to a display tile which this exceeds a lot of the time..

Time for a complete rewrite.

Andy


#202

I'm just going to remove the driver. It's not even pulling the outside temp correctly and insists on displaying the inside temp.

If I use the attrib temperature it shows inside_temperature.

image