Updated firmware on ZEN20 but still shows 2.0

Updated my firmware on a ZEN20 from 2.0 to 2.02 but it still shows 2.0 in the devices page. I have pulled the power and plugged it back in but still showing 2.0. No errors that I saw during the firmware update using the Hubitat utility. The ZEN20 is setup with no security.

how did you get the firmware file? their site has been "down" for a few days

Worked for me a couple days ago.

There is no standard for how firmware versions are updated or even displayed at all on the device detail page. Often, a "refresh" or "configure" command or even a "Save Device" will do it, but this varies by driver.

There are authoritative ways to see: if you're on a C-7, the Device Firmware Updater app will fetch the current version and show it in the list with the firmware targets (pretend you're going to update, but don't--you just have to go this far...but also, go back and select another device if this is how you updated in the first place and it's still selected, otherwise it seems to use a cached value). On any model hub, the "Get Version Report" in the (unofficial) Basic Z-Wave Tool driver will also spit the information out to Logs. The "community" firmware updater driver also has a similar command. Any should help verify if the concern is just whether it really updated.

ah OK thanks - I was just looking ... trying to remember what I did last time I did any FW updates I think I had hit configure > save preferences > save device then refresh before the new version showed up

Tried that. I'll just assume it took. :man_shrugging:

Try unpairing it and the repairing it.

It's not there to unpair. I did that and the device responded correctly but the hub failed over to the force option. So there is nothing to pair. I guess I could try to click on DISCOVER from the Zwave devices page since that shows. Maybe if I can pair it back then it will remove properly. I just don't want to make it worse. @bobbyD what do you think?

So you didn't do an exclude, but a forced removal? That means you have created a ghost.

From the Zwave page click on discover and then try remove once that option shows up. Make sure the device doesn't have power while doing this. This may take a few attempts. A reboot of the hub may help it be more successful as well. If that doesn't work you may need to take more drastic steps to remove the Ghost.

Always try to do a proper exclude if at all possible.


If you didn't reset the device, you should be able to start the exclusion and exclude the device properly. If you reset the device, then you'll need to wait until the radio realizes that node is dead. Including the device with a new node, will make the removal so much harder.

The device flashed like it had been removed. Yet still shows in the Zwave Details page but REMOVE doesn't do it. So I guess give it a few days first?

Was the device working, after you switched back to its driver following the update? You may have bicked it...

New ZEN20. The old is in a drawer now. I paired the new one and moved all apps to it and then removed the old.... well tried to remove it.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.