[Updated] - Cobra Apps Container

community_app

#83

Is this only on one child app?


#84

I think it's because between versions I renamed the presenceHandler method and when you previously updated it did not remove the call to the method.
If this is only on one child can you please delete the child and try to recreate it again?


#85

seems to be, at least the only one I have noticed

The mode child or the presence central child?


#86

the Modes Plus child


#87

have you moved things around? I'm just checking the rest and thought there was a switch option? For my holiday mode?

there is now a enable disable at the top?


#88

Can you please confirm the child version you are using (Modes Plus)


#89

1.7.1 ?


#90

At version 1.7.0 the enable/disable switch was moved to the 'Restrictions' (2nd) page

This will change again slightly when the new version comes out

You may need to check all your child apps, which is why I always advised a check and a save after every update

Andy


#91

yeah I have just worked this out and moved it all around, it does make more sense being there.


#92

Hi Andy, when I click "Add a New Open Contact message" I got error page

Error 500

A Server error has occurred

If you are seeing this screen repeatedly, please contact Support. For assistance, email support@hubitat.com or go to community.hubitat.com.


#93

500 is usually because you didn’t copy the parent or child code to your hub..
Cobra Apps is looking for something that doesn’t exist.

Andy


#94

Just installed using the instructions on your new website with the import options for the container app and then parent and child of several apps.

Weird issue that happens in both Message Central and Avg all. If I walk through and create a new automation, when I get to restrictions and press done it works as expected and I get back to screen shot below. But when I press done on this page it takes me back into the restrictions page of the automation instead to a higher level. IT does in both avg all and message central.


#95

I have the same it only does it on some of the apps it takes you back to the last child page rather than back to parent page.


#96

@drew @BorrisTheCat

Guys
I have seen this happen too.
It only started after the UI update to 2.0
It does not effect operation.
Just click the link at the top of the page to return to the apps page.

I think it may be a platform issue but maybe not,
It might have something to do with the update checking as I added quite a lot of code around the same time as the UI update.
I’ll talk to @bobbyD, @patrick amd @bravenel about trying to find the cause.

Andy


#97

Yeah its not been a problem I have been doing just as you said. It's not affecting the app at all everything is running well :smile:


#98

Great!
I hope you like the apps and they work well for you.
Currently there is about 150 of my app installations people are using and I've only had a couple of issues.
So all seems reasonably well (apart from this issue)

:slight_smile:

Andy


#99

This is most likely an issue in the UI navigation. It is harmless, as you've seen. We will track it down.


#100

Good to know. I was worried that I had screwed up the install.


#101

(as of 2.5.0) ... is the Update URL pointing to the correct place?

I was able to install the container OK using the 2.4.0 url mentioned on the Cobra website instructions, but it then of course immediately saw 2.5.0 as available. When I pasted that URL into the import field, nothing happened.

On a whim, I tried the URL in a browser and got the github web page for the file, as opposed to the actual file. So back in Hubitat apps code I tried importing the same folder path, but using the domain raw.githubusercontent.com ... and that worked a treat.


#102

Thanks @martybird I’ll take a look. Apologies for any issue :+1: