Update failed

Hi guys,

My update seems to be stuck at the splash screen. Time to power cycle?

Update:. Power cycled and now still stuck on the splash screen.

Update2: Tried to go back to previous version but now stuck on splash screen also. What's the hang up?


Where did you see the "go back to previous version" screen? I don't have anything overly critical on my Hubitat Hub yet, so after seeing your post I gave the update a try too and mine seems to be stuck on the loading screen as well. (It's only been 3-5 minutes, so I'll give it a few more before trying anything else)


Did you select 678 and hit Submit?

Yes sir.. still stuck

Bruce. I haven’t power cycled my hub yet… should I go ahead and do that and then navigate to :8081 and select 678 (if it doesn’t come back up after a power cycle)? Wasn’t sure if you guys might want any diagnostics off it before I power cycled.

Go ahead. Not sure why it’s hung up. Sorry about this!

I’m hoping we are isolated cases only.

You are. We all tested this today. We will get it sorted.

1 Like

Just for documentation's sake....

After power cycling the hub, I was still getting the loading screen, so I navigated to :8081 and I was presented with the following screen.

I selected 670 and hit submit and it said it would redirect me in 20 seconds. I was redirected and back at the loading screen then after waiting for a bit the main Hubitat Elevation screen loaded as expected.

I'm about to go back to :8081 and try switching back to 678 now. :slight_smile:

Edit: And it worked this time. I'm back up and running with the new firmware.


I’ve been doing the same as you but no dice so far. Letting it sit longer to see if that’ll help.

1 Like

FYI, I updated mine to 678 and it completed quickly and uneventfully.


Same here. My update went through without a hitch.


My upgrade was smooth as well.


So during the upgrade, probably the extraction part, I did the page refresh which took me back to the download button again so I restarted the ugprade process. I am wondering if that screwed it up.

Could be. I did that to myself once as well. It takes longer to extract than you’d expect. So, next time, wait for it. Give it a couple of minutes…

Maybe some on screen instructions to wait will prevent guys like me being stupid and impatient.

When I check for updates it says No updates available. I’m still on 670

Yayyyy back up and running again. Thanks @chuck.schwer Love the ability to restore the db.


Shall we try again? Was it user error ?

1 Like