Unusably slow load/never load web interface

Good afternoon,

I've searched. I've tested. I've disabled. But here I am: it's gotten to the point where I can't reliably load my devices or apps on my hub. Every once in a while, it will load right away (very rare), but most of the time, it will take 3-4 minutes. I don't always have the patience, because it's not like it's workable to have to wait that long every time you go from inside an app back to the list, etc. I think it has taken longer than 4 minutes sometimes when I've walked away. Not sure if it's ever completely failed (with an error).

The main page and settings page are a little more reliable to load, but still not nearly as fast as they used to be.

I've tried disabling custom apps
I've tried Safe Mode (which disables all custom apps, drivers, etc., right?) --It had zero effect
I've even done a soft reset and restore. No difference. This thing just isn't having it.

Notably, I don't notice any slowdown in the actual operation of the hub. All my switches, automations, etc., and my outside connections work just fine, as fast as always. It's just the actual interaction with the hub through the web interface that has become unusable.

I've reached out to support 2 days ago, but I know it's a holiday weekend. Just hoping someone can suggest something I haven't tried, and/or confirm for me that Safe Mode should have been expected to have an effect if it were a custom driver or app.

This feels like it has been a somewhat gradual but steady decline, and I can't pin it on any one change I've made recently, as I haven't really added any new devices or drivers in a while.

Any help would be greatly appreciated. I'm dead in the water with my plans at this point.

Are you talking about the dashboard on a mobile device?
If so, did you only select the devices you want to be on that dashboard or did you select ,All Devices'.
If you selected all it will get the current state of all devices even though you may only have a handfull on that dashboard. Doing this is known to slow down the dashboard on a mobile.

I'm actually not talking about dashboards at all. --Just the web interface for the hub, accessing it from my laptop at its IP address.

I rarely use Hubitat dashboards.

I clicked "Apps" a few minutes ago after posting this thread, and here's my progress so far:

It's probably been over 5 minutes at this point.

1 Like

Ah OK. Wasn't sure.
Must admit that is strange and I've never come across that issue I'm afraid so I'm not sure what to advise.
There has been issues with certain types of routers slowing things down I believe.


What router or switch is the Hubitat connected to? Netgear or ASUS by any chance?

I've seen mention of that, yes.

On that note, I have Google Wifi, but I have been using it for several months/a year or so, and this issue is new.

I should also note that downloads of updates and such seem perfectly fast. --It's just the interaction with my devices and apps lists, primarily. My apps page is still loading. My last post was 7 minutes ago, and haven't touched it. It has made progress, so I know it hasn't given up. But obviously something is badly amiss.

EDIT: It did eventually load. My estimate is it took 15 minutes this time.

Google Wifi

Same as me - but I have my HEs connected to the router (or mesh point) via TP-Link switches. But in event, the issue arises only if there is a Netgear or ASUS switch in the middle.

My HE is wired directly into my Google Wifi access point 2. I have a small switch in the closet, but I don't remember which brand (possibly a netgear? but I think it's a Belkin), but I don't think it's involved in the path here. Is that worth checking out? It's definitely not between the Google Wifi and HE.

No, I don't think it plays any role here.

Have you got the same delays when accessing the device/app list from your phone?

1 Like

Along the lines that @markus raised - which browser are you using on your Desktop? Can you test if the problem exists while using a Chrome incognito/private browsing window?

1 Like

I do that next to never, so I hadn't even checked...and as it turns out...NO. ??

Very fast load on my phone. Whaaaa? :astonished:

I have no issues connecting with anything else on this laptop (and there's a lot there). What might this be?

1 Like

I'm using Chrome, and I have tried incognito. No difference.

Browser caching, arp cache issues and some other possible problems. Try another browser next.

1 Like

Oh, my goodnes...

So, weird:

Edge: No love.
IE: No love.
Incognito Mode: no love.

Disconnect my computer Wifi and reconnect: ALL WORKS FAST.
Now, the really crazy thing about this is that nothing else was slow. Just my connected to HE!

All websites, connection/interaction with my QNAP, my node-REDs, etc., were all working fine before I did this.

Obviously, this no longer sounds like an issue with my HE...but what in the world would cause my computer to not want to play nice with just Hubitat?

some add-on probably. Check your chrome extensions. They can be a bear sometimes.

ARP table corruption? If this happens again we could look at finding the actual problem, with it gone, that would be hard.


Oof. Stuff like this makes my head spin. Because it was such a simple and unintuitive fix....I mean, I have wifi connectivity and perfectly fine speeds to every resource I try to reach. --Why would I try disconnecting the WiFi! --But the suggestion to check from my phone put me in a whole different frame of mind, so I appreciate that. The different perspective is exactly why these forums are so great.

Next time I run into this issue, I'll try the Wifi thing again. But I'm gonna keep the ARP corruption and the extensions thing on my radar for sure. Something's fishy.

Thank you all. Will update if there's any more issues.

I just did think of one thing, you said your HE is connected to your 2nd Google WiFi? And your connection between your Google WiFis is the wireless mesh one? Are all other services on you lan, like node red, on the other one?