Unknown Zigbee Device, persist after rebuild

I just found a very odd thing in my Zigbee network that I don't understand.

Below is the Zigbee routing table from /hub/zigbee/getChildAndRouteInfo

You can see there is an unknown device 1C03 in my Neighbor Table Entry. But I scan through my entire list of devices and could not find out this device actually is. What's odd is there are actually several devices that seems to be take a route via this device so I'm not sure what might be going on here.

I have a few Echo and Eero devices at home as well, could it be somehow related to those?

I'm not sure if I should even be worried about this at all. So any suggestion would be a great help here.

Child Data:

[swLounge, 5B6C, type:EMBER_SLEEPY_END_DEVICE]

Neighbor Table Entry

[msDining, 00C6], LQI:255, age:9, inCost:1, outCost:0
[Unknown, 1C03], LQI:155, age:4, inCost:1, outCost:5
[msHallwayB, 45CA], LQI:97, age:9, inCost:1, outCost:0
[msKitchen, 5E94], LQI:168, age:9, inCost:1, outCost:0
[msLounge, 65AC], LQI:149, age:9, inCost:1, outCost:0
[msHallwayF, 6D99], LQI:167, age:9, inCost:1, outCost:0
[msStairU, 8E1A], LQI:52, age:9, inCost:5, outCost:0
[msStairL, A1CE], LQI:167, age:9, inCost:1, outCost:0

Route Table Entry

status:Active, age:0, routeRecordState:0, concentratorType:None, [tempSensor1, A883] via [Unknown, 1C03]
status:Active, age:64, routeRecordState:0, concentratorType:None, [swHallway, E9A4] via [Unknown, 1C03]
status:Active, age:64, routeRecordState:0, concentratorType:None, [msStairU, 8E1A] via [Unknown, 1C03]

Just a way out thought.
I had a 3 ZB devices that refused to join; always worked in the past (C7).
I went into Settings and ran the mesh ZB graph. Found a random 4 digit hex identifier dot that wasn't on my ZB list of devices - unknown.
Created a ZB device, used a generic driver and keyed in the 4 digit hex as the identifier and voila, device showed up in the Devices list.
At that point you could delete it if it wasn't real, maybe? :wink:

How's your Zigbee mesh performing? From the looks of the neighbor table, the only repeater with link status good enough to be used as a repeater is the one designated Unknown 1C03. those numbers following the LQI are measures of reception and transmission on each neighbor link to the hub.

All the other repeater neighbors (reporting outCost:0) are indicating that even though the hub may 'hear' them, they aren't receiving a good signal from the hub. They should be exchanging status with the hub 4 times a minute; the age figure is the number of 15 sec. intervals that has elapsed without the hub receiving these status reports. InCost is a measure of hub's reception on that link (how well it can hear the neighbor , that figure comes from the LQI); outCost indicates how well the remote neighbor is hearing the hub (based on the LQI that the neighbor is seeing on the link; it transmits the outCost figure during the link status report so the hub can tell how well it is being heard-- lower cost numbers are usually better but outCost:0 is a special case and means that no status was received from the neighbor at all).

It common to have several intervals elapse without receiving status from a neighbor (actually the age counter gets reset to '2' every time a link status report is received and increments from there) but once the age counter increases beyond 4, the link is considered 'stale' and they hub starts looking for another in-range repeater to replace it in the neighbor table if one exists; evidently in your mesh there isn't another suitable repeater in range. So age:9 and outCost:0 means those neighbor repeaters aren't checking in with the hub any longer; maybe there's heavy interference or something (more than a few walls) attenuating their signals?

Even the 1C03 device is reporting that though it is hearing the hub, the signal it's receiving isn't very strong (via the outCost:5; the cost scale runs from 1 to 7 where lower non-zero numbers indicate stronger signals ).

It's not unusual to see 'Unknown' in place of a device name for a while when a device has disconnected from and then rejoined the mesh (the hub will correlate its MAC address and replace the Unknown with the name given when it had originally joined). If you see this regularly (on non C-8 hubs the 4 digit short ID will also change) it's another sign that the mesh isn't stable.

This is one of the strange reasons that prompted me to check... Everything in my neighbour table entry are Sonoff battery motion sensors. Note the ms-Prefix for their names.

The only other ZigBee devices I have are Aqara temperature sensors (temp-Prefix) and Sonoff ZBMINIL2 relays. (sw-Prefix). None of them as far as I know, are even capable of being a repeater.

A majority of my devices are wifi devices (WLED, Shelly, Tuya) so they shouldn't affect my ZigBee network here.

And most of the Zigbee devices are in fact responding perfectly fine. The only one that has issues are tempSensor1 which will randomly stop reporting and it is one of the devices shown as connected to this phantom repeater 1C03.

I checked via the ZigBee graph, and there are 20 devices on it. But I can only ever count 19 devices in total in my ZB mesh. At this stage I'm completely lost on what could even be a problem here.

Ah... I assumed they were all repeaters. Those devices shouldn't appear in the neighbor table at all.

How many repeaters in your Zigbee mesh? Evidently none of their device roles are being reported correctly by getChildandRouteInfo (save 'Unknown', which seems to be working OK in spite of missing its device label).

What's equally strange (and broken, from a reporting standpoint) is that Zigbee sensors don't report link status and cost figures; only routers do. I doubt the Zigbee Graph would be any more credible since it uses getChildandRouteInfo as well.

Not sure what to make of this; is this a C-8 hub? If so I'd say forget about troubleshooting the 'Unknown' device and chalk it up to the typical C-8 Zigbee issues that are regularly being reported here (end device dropoffs and unreliable getChildandRouteInfo). If you only have a single sensor causing issues (and you have a C-8) your hub is probably (and unfortunately) working about as well as anyone else's...

Yeah, the issue I have is probably unrelated to the hub anyway. I discovered some oddities with the devices which disappeared after I moved them off into using Generic Zigbee Drivers. I also tried moving one of my ZB buttons to use the unknown device's PAN ID and now it's disappeared from the network.

There are actually no repeaters at all in my network so I guess all the apparent issues are down to bugs with the C8. It's not a show stopper for me but I do wish we have some understanding of what might be causing these things to show such wrong info.