Unknown device won't go away

My mesh crashed so I had to do a lot of repairs and re-adds, however, now that everything seems to be in good order, I have this one device that won't go away.

I don't even know what it is, the only possible device is already excluded. How do I make it go away?


Since you've just done a bunch of stuff w/your hub I'd start w/this so you're ion a fresh state:

  1. Shut down your hub, at red LED pull power, wait 30s, restore power.
  2. Check and see if the device has returned to normal.

You might boot up to find the device looking normal again.

If it doesn't clear up and all of your devices are working normally and controllable from their device pages, then:

  1. Press the Refresh button and see if a Remove button appears
  2. If Remove appears, click on Remove and the device should go away

In some cases the Refresh/Remove process may need to be repeated. Don't do a flurry of button presses...take it slowly.

If it doesn't clear up but you have one device that isn't controllable, then try the Discover button.

The device will be a dimmer.

I turned off the hub for 12 hours, no dice. I also tried to refresh, then remove, also no success.

Have you tried the Discover button?

Do all of your other devices function normally from their Device pages?

Everything else works normally, but the Discover button doesn't seem to do anything. This device can only be one dimmer and I already excluded it during my previous troubleshooting...

It has neighbors listed. The SDK will refuse to remove it with a bogus error saying it is not in the failed list anymore.

If you had properly excluded the device that was attached to that exact node, it would have been deleted as part of the exclude. You possibly had this node from a failed pairing of that device and when you excluded it, it would only take the good node out.

See this guide:

So you excluded and re-included the device represented by the ghost, and it's functioning normally.

You should have better results if you kill power to that device and re-try the Refresh/Remove. If it has an air gap, pull it, or kill a breaker. Then do the Refresh/Remove...

That is consistent with what I see, I'll figure out what the neighbors are and try to remove it this way.

You can use the red/blue topology map to see the neighbors. Or use the custom app Z-Wave Mesh Tool.

I power-cycled all the neighbors, then turned the hub off for several minutes but I still can't remove the device. I have a feeling I'll need that USB stick :roll_eyes:

1 Like

Just be clear, you have to kill power to the neighbors when you try the refresh remove... That's what you meant by power cycled, correct?

Yes, sorry, I tried killing power to all the neighbors but refresh-remove still didn't work.

1 Like

I got a UZB stick from Digikey and nuked the offender. And I don't like Z-Wave anymore.

1 Like

The ghost issue can be a b_tch...yeah.

However, I haven't had a ghost in forever (like years) and once you have one you learn a lot about how they are created and you get really good at not making more. :slight_smile:

I LOVE Z-Wave on the C8/C8-Pro.


Like @danabw I have not had a ghost in forever. Z-Wave on the C-8 has been great for me. The external antenna and the 800 series Z-Wave make all the difference in the world. 99% of my devices join directly to the C-8 hub.