Unifi users, how fast does your smartphones attach to your WiFi?

I know there are a few Unifi users here so I'd like to see if I can solve my issue with my cell phone taking its sweet time connecting to my WiFi. Sometimes the phone takes up for 30-45 seconds when I arrive before it connects to the AP. My previous Asus APs connect as soon as I pull in the driveway.

I've tried some of the suggestions from the UI forum but my Unifi presence driver bounces from away/present a few times when I'm home.

How fast do your phones connect to your Unifi APs?

I get connection when I am in range. Usually just when I pull in my carport. Around 3 seconds maybe?

Mine was very slow. Unifi LR AP's x 2 in about 2000 sqft. I really hated it. Put up with it and tweaked and researched for 2 years. Recently had multiple high latency warnings. Got fed up and removed the ap's and replaced with Orbi RBR50 & 2 RBS50 satellites, connected as AP's only to my PFsense box.
Now my cells connect instantly, in my driveway, as with unifi, but much faster and roaming is much faster from AP to AP. Samsung Note 20.

I recall when I first got Unifi, I was much happier, I'm thinking their firmware updates screwed up something. I'll never use them again. They are better than a single router, but can't touch Orbi. Maybe other unifi AP models are better? But I read the LR are ideal for cellphones due to higher receive sensitivity, for weaker cell transmitters in cellphones.

i wish i could figure out how to connect two or more august connects to my unifi APs. :wink:

Pretty fast. My issue is that the kids turn WiFi off all the time as the internet at school sucks. So I can't use it as presence detection - to spotty whether it is on/off on their phones.

Create a rule so their lights refuse to turn on of they are not present, or their front door unlock code doesn't work, or they have to hit a local end point......

I could. I just don't care that much. Life360 works 100% of the time for us, so there isn't a real problem to solve.

I agree that there would be ways to coerce them into turning it back on, though!

1 Like

I have an AP Lite and an AP LR. The AP Lite is behind the wall next to the driveway so you'd think the moment I pull in the cell would attach to it. Nope! I have tested both my DSL modem and two different routers handing out IP addresses but no change in connect time.

I forgot to mention same behavior for home and at my work.

Fwiw, I have 3APs, 2 AC Pros, and 1 AC HD, and I've never noted any delay connecting at all. Having said that, my Wife's iPad occasionally loses its mind and she's not able to connect until she reboots. But that's an Apple issue IMO.

However, I have hugely overlapping coverage, so it's possible one or 2 APs could have an issue, and the other(s) don't.

Makes me want to experiment!

S

not sure the sq ft you're covering but I read where you have overlapping you should turn down transmit power on all AP's so the device connects to the nearest one, and not an AP it can hear but can't transmit to.

2 Likes

The area is less than 1500 sq ft.

Possible it has something to do with randomization MAC address on apple? Just guessing.

1 Like

Interesting idea.

My house is roughly 3K square feet arranged as 3 floors, 2 plus a basement. The 3 APs are installed, 1 above the other in roughly the "center" of each floor, and arrange RF wise to be on differing WiFi channels in both the 2.4 and 5GHz bands. Nope -- they are all on ch-6 (2.4) and ch-159 (5 Ghz) and set to auto.

Power is set to default on all three, but the AC HD must have a much more powerful amplifiers, as they are reporting an EiRP of 28dBm on the 2.4 GHz channels vs 18dBm on the AC Pros, similarly in the 5GHz band there is a 4dB delta between the HD and the 2 Pros.

This results in my tablet, which I use on the main floor, where the HD is, never dropping the HD, even when carried to the other floors. Yet the bulk of the WiFi devices that are permanently on each floor tend to be linked to the AP on their floor.

Interestingly, as the crow might fly, the two 2nd floor and main floor hot spots are probably very close to equidistant from the tablet at night when it goes upstairs, so there's probably no significant degradation in the signal as far as the tablet is concerned. Certainly not enough to make it "roam".

I can't see, with my configuration, any benefit to adjusting the power of the APs. Perhaps if I was trying to share a channel, between two of them...but realistically, I doubt it would help much, might be worth futzing with in the 2.4GHz band though. Just to see if anything moves around.

S

There is a (relatively) simple test you can do:

  • Install a Wifi Scanner on your phone
  • Turn off one AP and stand close to it (on the same floor)
  • With the scanner measure the other APs signal

If the RSSI of the other APs is higher than -70 dBm, then the APs are talking over each other and you need to lower the radio power. Do the above for both 2.4GHz and 5GHz bands.

The objective is to have, at any given location in your house, only one AP with signal > -70 dBm.

I have 3x nano-HD around my (single story) house, and I had to set 2.4GHz power to low and 5GHz power to medium for our mobiles to roam correctly.

3 Likes

I have 3 ap's. Two of the wifi 6 lite and one ac lr.
I notice no discernable time to connect, I use the enhanced wifi presence app on my Android and it works great. My phone and my tablet connects to the closest ap.
If I reboot an ap I notice that my Amazon echo connects to one of the surviving ap's. I noticed it takes a couple of hours for them to connect back to a stronger ap.

My emporia energy vue2 are awful. They seem to want to connect to the ap with the lowest channel number no matter what the strength of the signal. I ended up adding an ssid per ap and locking my iot devices that doesn't move to that ap. My phone's, computers and tablets seem to work well with multiple ap's and hand over as expected.

Let me know if you want me to check something on my config.

Good test.

Perhaps I'll mess with it this weekend, but as I don't have any problems with the way my WiFi is operating, my motivation is low. :slight_smile:

S.

The annoying thing with my setup is the performance is great, just that connection delay irks me :face_with_symbols_over_mouth:

I've been on an off trying to figure it out. I posted this thread during one of those figuring it out days.

mine connects pretty fast. i don't usually pay attention to it though as i'm using autoroid to turn my wifi on/off based on my geo location. if i turn off my wifi or switch ssids though, it connects pretty quickly (within a few seconds)

I am using a u6 pro and it connects to my phone as soon as i pull up to my drive way.

From what you state here, this issue has nothing to do with Unifi and most likely more to do with the smartphone itself, maybe check your phone settings and make sure the WiFi at home, and at work if important, is a trusted one (so that it won't spoof the MAC address of the phone), not sure if this will delay the connection time or not but can't hurt to try.