Unexpected Error with scenes

Getting Unexpected Error with Scene-1.2

Have you tried looking in the logs?

And are you able to provide any more details on exactly you are trying to do when you see this error, is it when opening a scene under the apps page? If so, is the error only appearing for one scene or all?

1 Like

Looks like a missing device used to produce a different error, and was also fixed in the first cut of 2.2.8... Still worth checking though, you never know.

1 Like

Does this error happen when you open the Scene-1.2 app? What build is your hub on? (Settings / Hub Details)

This did happen after I removed a device. Not all scenes are broken, some have this error. I've updated the scenes with this deleted device. How do I fix it now?

I'm running and Scenes-1.2.

Please show a screenshot of the Logs when this error is thrown.

java.lang.StringIndexOutOfBoundsException: String index out of range: -2 on line 626 (method mainPage)

Can you post a screenshot of the Scene, or does it throw this error when you open it?

Please see my original post. It has the screenshot. Whenever I open the scene, the errors show in logs. I checked the details of the scene, it seems it's still referencing the deleted device.

Given that you can't open the Scene, you will have to remove it, and create it again. There was a fix introduced to deal with deleted devices more gracefully, but perhaps this particular Scene was already broken.

I'm getting this error when trying to view/edit existing scenes as well as when trying to add a new scene. Here is the log when attempting to add the new scene:

Same error when attempting to edit an older scene:

I think this broke with 2.2.9 (I'm running, but it's hard to say for sure because I don't go into these scenes very often.

The scenes push virtual (phantom) buttons on my Ra2 Main Repeater, which has been setup as a "Keypad."

I need more information. What is app 1581? You can see its name in the logs, and you can see that number when you open the app in the URL.

1581 was the new scene that I was trying to create. 191 was the old scene I was trying to edit. Similarly, when I try to create it again, it is 1582 (Shades Closed)...