Unable to add Aqara Cube after C8 upgrade


Since upgrading to C8 I can no longer add Aqara Cube.
Cube is found but does not progress to setup.
Legacy mode produces same result.
I have one cube which added without issue using C7.
Found it so useful I bought 2 more before upgrade to C8 but as previously mentioned unable to add.

Could Hubitat team please look into why this would be so.

Thank you, Richard.

What driver are you using that works for your original Cube? There is a new version of the Cube (T1 Pro) that I bought when I was experimenting with Zigbee2MQTT and it works differently than the original Cube. Is it possible that the one you have that works is the original Cube and you bought two of the T1 Pro models? I paired my T1 Pro to HE after Z2M experiment failed with no functionally on HE.

I Google'd but can't find documentation of differences between original and T1 Pro.

1 Like

Hi Stephen,

Thank you for your interest in my problem.

Not sure about Cube type however I found if I start add Zigbee device it finds the device but doesn't go to setup screen but if you press find Zigbee device again after timing out it will find the Cube again and allow access to setup screen if you don't press reset on the Cube????

So the long and short of it is I've found a work around. I stayed up to the small hours to discover this glitch.

Thank you again for your message of help.

Regards, Richard.

Aqara devices never have been guaranteed to work with Hubitat. I did have a couple of Aqara sensors that I got to work with the C7 hub using a community driver. Since migrating to C8, those devices ceased to function. I replaced them with compatible devices. One day, they might work again, but there are no guarantees since Aqara only claims to function with its own hub. I understand some others have had similar issues with Aqara on the C8.

The new Aqara cube that is supposed to work with Zigbee 3.0 hubs is more likely to work with Hubitat.

You might be able to use your C7 hub in conjunction with the C8 using hub mesh. Just make sure the two Zigbee radios are on different channels.

1 Like

Hi rwclements,

Thank you for the info. It's true I guess we want everything we purchase to work with Hubitat which is a tall order for any product like Hubitat.

The info you provided was helpful and meshing my C7 is a good idea.

Regards, Richard.

1 Like

See this: NYCE devices are incompatable with C8 and any other Zigbee 3.0 coordinator - #2 by bobbyD


I suggest to abandon current zigbee aqara devices, and either wait for Matter/Thread ones (edited: or that some announced zigbee 3.0 versions), which in theory could not produce such massive problems with compatibility, or look for other devices from other companies (if you need sensors just now). You can't predict their behavior. Any update of any version of hub could render them useless. Yes, Aqara devices look great, they are small, but they (zigbee ones, at the moment) are producing a massive headache. I got so irritated, that I sold all my Aqara/Zigbee hardware recently.

To be fair, Xiaomi/Aqara specifically states that their legacy devices are designed to work with their own hub. They never indicated they would work in any other Zigbee environment. Those of us that tried using them with Hubitat did so at our own risk.

There may be some hope in that they are stating that some of their new devices will work with Zigbee 3.0 hubs. Hopefully, these newer devices can be made to work with Hubitat as the form factor of some devices is rather nice.

1 Like

Hello bobbyD,

Thank you for the info and making an effort to understand the problem.

Regards, Richard.

Hi rwclements,

Sounds like you’ve made a big effort to use Aqara. I understand as they are very pleasing to the eye compared to alternatives as you mentioned.

I found motion sensor and door contacts would work fine reporting motion and doors opening and closing until you attached an automation to them. Once an automation was attached to a device they would stop reporting motion/door opening etc.

I tried creating automations through HomeBridge not Hubitat and they worked fine although I have had some stop working occasionally and had to delete and reinstall them.

Problem solving is one of the aspects of home automation I enjoy to a point and as you describe it maybe time to resign Aqara to the back of the cupboard until they improve.

I’ve enjoyed sharing this experience so I don’t feel I’m the only one having problems. It’s easy to jump to the conclusion it’s Hubitat short comings but clearly getting all the different third parties devices to work correctly with Hubitat is not a realistic proposition. I’ve played with most of the major home automation platforms and Hubitat is my favourite.

Regards, Richard.

1 Like

If you are interested, you can personalize your forum username to something other than @user1103. Simply send a request to @support_team or @bobbyD.

The Hubitat staff have not made a lot of effort to get the Aqara devices to work with Hubitat. Xiaomi/Aqara does not claim that their devices meet Zigbee standards, at least not until recently. Most of the work done to get them to work has been done by the community, especially the community developers. Hopefully, the work done by the staff to get previously compatible devices like NYCE to work with the C8 will bear fruit for other devices like Aqara.

Exactly, so why should we spend any time on this?


Apparently you’re not a member of the MFC?

Dear all.

Did anyone mention time being spent on anything. I’m confused.

Thank you, Richard.

What about recent ones devices, described as Zigbee 3.0?
for example:

SSM-U01 / SSM-U02 (switch module T1)

GZCGQ11LM (light sensor T1)

Aqara H1 dimmer

They are advertised, as Zigbee 3.0 Certified. Will they be officially supported?

1 Like

Aqara is coming out with some newer devices which are supposed to work with Matter. If they are fully compatible with the Zigbee 3.0 standards, they should work with Hubitat. Only when these newer devices get into the hands of Hubitat staff and community members will we know if they are truly compatible.

Third Reality recently released at Gen 2 power monitoring smart plug that they claim meets the Zigbee 3.0 standard. However, some people who have attempted to use these plugs have encountered problems with the plugs flooding the Zigbee network with data because the devices do not allow the driver to set the power monitoring reporting frequency as provided in the standard. Thus, it appears the device might be in partial compliance but not necessarily in full compliance with the standard.

Just seems they have no interest in correcting anything or trying to maintain some kind of proprietary entanglement ala Packard Bell...

"Ooops, they did it again"?

I hope, that at least sensors (light sensor T1 and new temp. and humidity sensor) will behave in good way. We will again need to wait. DAMN.

Well there's another issue, at least from us getting our hands on these devices, I won't purchase anything from aliexpress.

1 Like

Download the Hubitat app