Unable to add Aqara Cube after C8 upgrade

Well there's another issue, at least from us getting our hands on these devices, I won't purchase anything from aliexpress.

1 Like

What if someone will buy it for you, and send in one package directly?

of course, that works.
But these have to be the zigbee 3.0 devices, i already have a pile of their "lesser" cousins...

1 Like

If you agree, I could do attempt to get that true zigbee 3.0 devices. So far I had luck during shopping on aliexpress, and got almost everything was fine, I mean I got, what I ordered.

if they're being advertised as zigbee 3.0, then that's as good as they will get.
I doubt there's multiple versions of the same product advertising zigbee 3.0

But happens, that seller is sending different device, than advertised

I identified reliable source of ZCW1 humidity/temp sensor. If you want, I may try to start thinking how to send it to you, or I could be "testing mouse", and provide logs if needed. And according to comments, they are working with many other systems, zha, domoticz, etc.

Aqara T1 luminance sensor, there is at the moment only one russian review, suggesting that it works with other system, same situation, I could analyse how to send, or be "testing mouse".

no reviews so far on door/windows sensors P1 and E1 (both zigbee 3.0, but different shape/look)

By reviews, I mean information provided by buyers, in comments in sellers' offers.

Logs wont work, i run zigbee packet captures for new devices, its the only way to see everything that's going on.

Ok. So I will PM you.

1 Like

Hello All.

I think personally in the interest of providing a home automation platform that allows Hubitat uses a large selection of third party devices solutions or alternatives should be explored as a core value. The number of automation enthusiast that find themselves frustrated by device issues is considerable in my opinion. To put Hubitat head and shoulders above automation alternatives means providing the most extensive library of third party support of any other platform. I moved from Home Assistant to Hubitat because every time there was an update something stopped working and instead of focusing on getting the fundamentals right first they would continuously bring in new features etc that made the whole platform in a state of chaos (in my opinion). The platform that provides the most features and support for third party products will be the most successful. The “hub” is only as good as what is hanging off it. People will shop everywhere for all sorts of devices for all sorts of reasons (price, esthetics, features, product knowledge, unaware of alternatives that are better, migrating from another platform, the list goes on).
What’s important is that clear decisive decisions are made about what’s in and what’s out. Im not sure if this forum is controlled by Hubitat or a group of enthusiasts but it seems the attitude of some is negative. Not everyone has the technical ability of some but we all try to contribute at a level we are able, or so I would hope.

Anyway thank you to those that help with my enquiry about Aqara Cube but it’s gone off topic a bit now. I managed to get it working in the end with perseverance finding that add device would find the cube but not allow moving on to setup page, after timing out press add device again without pressing reset on cube and immediately it would allow me to move onto setup page. If your Aqara sensor devices (mostly motion sensors) continuously drop off I found adding Home Bridge and setting up automations for those devices there stopped drop outs (it seemed everything was fine with the sensor until it was attached to an automation) and also allows interactions between other platforms like ewelink. A bit of a clunky way around but it works for me considering I moved platforms and had lots of wifi devices.

Anyway I’m stepping off my soap box.

Regards, Richard.

1 Like

The forum is controlled and moderated by Hubitat Inc. That said, there will always be some negativity but overall we all try to help eachother. That said they can't make everything work and when it comes to zigbee, @mike.maxwell certainly tries as do other devs here in the forums but trying to get stuff working that doesn't adhere to standards ends up being a lost cost and no reason to go forward with trying to get it to work,, Aqara and Xiomi are 2 of the biggest problem children in that regard.

1 Like

The ZCW1 humidity/temp sensor is made by Tuya, not Aqara. The Tuya Zigbee devices work just fine. The question is related to Aqara devices.

Thanks for pointing that. Interesting, because saw it marketed as Aqara at least one place. So we had at least one problem less. I will try to focus on providing other Aqara Zigbee 3.0 devices for Mike.

1 Like

Hello rlithgow1,

Thank you for the response and I take it on board that Aqara don’t want to play so they will lose what ever market share they have to alternatives that do play. I was probably hasty with my negative comment as it seems communication between group members is direct so I apologise for my comment.

Interesting you focused on the “negative” comment that you decided to respond to.

I’m happy with my Hubitat and generally find a work around when a problem arises but I’m not hardcore in regards to the point where my toilet seat lifts up when I walk in the bathroom and that seems to be where Home Assistant automators live. I would imagine most enthusiasts just want a robust easy experience and that should continue to be Hubitat focus in my opinion.

I’ll bow out of this one now and contribute in the future if something else arises that I need to understand of offer.

Thank you, Richard.

I dunno, auto lifting toilet seat seems pretty cool... :rofl: Yeah Ikea seems to do the same thing a bit with how they adhere to the zigbee protocol. Though in that case I think ikea is starting to put out some 3.0 stuff (someone will correct me if I'm wrong). The best thing I can tell people when they go looking for a particular type of product is to first consult the official compatibility list and then search the forums for what general consensus is or if you have a particular product in mind, just post and lots of people will answer.

1 Like

@mike.maxwell, I did find that their latest generation of cube that is said to be Zigbee 3.0 is available on Amazon:

Aqara Cube T1 Pro, Requires AQARA ZIGBEE 3.0 HUB, 6 Sides to Control Different Scenes and Diverse Actions to Control Smart Home Devices, Supports Homekit, Alexa and IFTTT https://a.co/d/3VUzXeF

I am not aware of a community driver that works with it. I tried the one that had been created for the previous generation, but it doesn’t work for me on the C-8.

1 Like

Aqara T1 Pro Cube is different than Aqara T1 Cube.

No driver is known to exist for the Pro model in Hubitat (yet).

1 Like

That is unfortunate…. I was using the T1 (non-pro) to set a fan to either auto or a specific speed depending on he side of the cube facing up. It unfortunately no longer works :disappointed:). I would love to replace it with the Pro version.

I would be happy to help test a driver if one were to get developed!

1 Like

Most of the earlier Aqara devices state that they only work with the Aqara hub. The newer devices state that they are Zigbee 3.0 and require a Zigbee 3.0 hub,but not necessarily an Aqara hub. So presumably they can be made to work with the Hubitat C8 once suitable drivers are developed. Only time will tell if Aqara has fully inplemented all aspects of the Zigbee 3.0 protical.

The Zigbee 3.0 protocol is supposed to be backwards compatible with earlier Zigbee standards, but there was a recent post by staff indicating that NYCE Zigbee 1.2 devices won't work with any Zigbee 3.0 hub. Fortunately, the staff were able to modify the C8 firmware to allow it to recognize the legacy NYCE devices.

This just indicates that not every manufacturer implements the Zigbee standards perfectly. If they did, all Zigbee devices would work with all hubs.

1 Like

A custom driver for the new Aqara Cube T1 Pro. is now available for testing.


Download the Hubitat app