Trigger Lag


#1

I've got a few fairly straight forward event triggered rules for HA that up until recently, worked beautifully. Now the problem is that there is a bit of a lag between the event and the execution of the actions.
For example, I have a rule set to disarm HSM, change my thermostat setting, and unlock the door when I enter the geofence set up in the mobile app. Then whenever the door opens, the lights in the living room come on and Alexa stops playing the radio I leave on for my dog. (I'll post a screenshot of the rule when I get home).
Originally, whenever I opened the door everything would happen near instantaneously but there seems to be a 4-5 second delay now and I can't figure out the cause. I'm also experiencing a similar issue with a couple of other rules so I wondered if maybe there was too much happening on the hub which was causing the delay so I removed some apps/drivers/devices I wasn't using but that doesn't seem to help.
I'm happy to post screenshots of whatever you all think would be useful to diagnose the issue but I'm still really new to all of this so other than the rules themselves, I'm not sure what would be helpful.


#2

It's possibly a custom app or drivers that you are using, rather than one you are not using. You can just disable them to test. You don't need to uninstall.

https://docs.hubitat.com/index.php?title=Apps

https://docs.hubitat.com/index.php?title=Devices


#3

Could you have some device referenced in those rules that is offline? For example, a powered-off Z-Wave device? It's unlikely to be from too much happening, and more likely to be from something that is not responsive. Another possible culprit would be the Alexa portion -- how are you doing that?


#4

Actually, I forgot to mention that my Ecobee went offline last week and that's probably about when it started. But, everything is back online now and the state change on the Ecobee seems to be working just fine. As for the Alexa integration, I'm using the Echo Speaks app from @tonesto7. Also, the lag seems to happen even with a very simple rule using a single contact sensor and a hue bulb.


#5

Try disabling Echo Speaks and see if this makes any difference in your performance. On the Apps page, upper right hand corner, click on the gray X. That will reveal a column of check boxes to disable the app. Also, do the same on the Devices page for the Echo Speaks drivers.

If that makes a noticeable difference, you'd have the answer. If not, you can re-enable those. We have seen slow hubs because of Echo Speaks.


#6

I'll give it a shot and report back. Thanks!


#7

Just wanted to pitch in here and say that I was having the exact same issue. Turns out that Echo Speaks was the culprit - it really affects automation response times and even WebUI load times after a while. Make sure you disable both the devices and the app for now. I believe the creator of the app is looking for beta testers to fix the issue on the original thread.


#8

@nitinphilip I'm sorry to hear you are having issues... I'm currently testing v3.0 of Echo Speaks in my slack channel. I'm hearing that this new version has drastically lower effect on Hubitat hubs.

You can find the link to the slack in the Echo Speaks topic