Thought problems with 2.3.3 devices not working, pages not loading, seems resolved - consider solved

I upgraded to 2.3.3.124 and found that several pages weren't loading from Safari, such as logs, devices and apps. I had tried to go into them as I was having a problem with an Inovelli Red Dimmer that is connected to just a line, neutral and ground that is supposed to control the ceiling fan light via the Binding app for an Inovelli Fan + Light. I finally got in and saw the logs showed the button was pushed, but nothing else was happening. I also have a Fibaro Key Fob that I set a button to toggle the light on and off. Trying that didn't work either. Again, the logs showed the button was pushed.

I then went into the device and the rule machine 5.1 rule that was to do the toggle and they both showed the light was off, but it was on. I tried to turn the light off from both places but that didn't work. I also tried to turn it on (run the rule in RM 5.1 and push the On button from the device) and then off actions, but those didn't work either. I can turn the light on and off from the physical switch.

I then upgraded to .125 but the didn't help either and I'm finding I have to try several times to get to the desired pages. Here is a screen shot of the devices page not loading:

BTW, I have Chrome, but I don't go into apps as the apps page almost always shows the apps but none of the rules I created there! That has been going on for months and months. But just for the heck of it I tried to get there and got the could not load error there too.

Here is the RM 5.1 rule. Not only was the light on, but pushing the Run Actions button repeatedly did nothing, If it thought it was off, then pushing it should have turned it on.

Here are some log screen shots of the Switch, the Binding Entry and the Fibaro KeyFob 1 pushed.




4 posts were merged into an existing topic: Release 2.3.3 Fibaro switches not working

The error message would seem to imply that the IP address is incorrect, but then I see the screen shot from the logs, etc...

@Stu_The_K , if hub randomly disconnects, try a different network cable. We've seen some failures there.

I swapped out my lan cable for a brand new one. When I tried to use my book marks I wasn't having any luck until I tried to go to the apps page. Once I was there I could navigate from the Hubitat left side panel.

I have no idea what that means.

While I understand that looking at the apps and devices in a web browser won't show the current state if I lost the internet connection, and, of course, I couldn't control the devices that way, that doesn't explain why my light switch or Fibaro Key Fob isn't working, as those are independent of the internet connection.

It looks like your bookmarks have the hub at a specific IP address and it is no longer at that IP address, as it looks like your router is dynamically assigning it. You should edit your bookmarks to say "hubitat.local" rather than the IP address.

Or set a fixed IP for the hub on his router. (I know you can set a fixed IP on HE, but I don't like fixing IPs on individual devices, want it centralized on the router.)

4 Likes

I did change my bookmarks and that seemed to solve my navigation issue. It seems very strange that it suddenly started to dynamically start reassigning my address.

Should I try to lock it into a specific address as it had been in the past?

But that doesn't explain the switch and key fob not working. I tried a graceful shutdown (and pulled the plug from the wall, not the hub). That didn't work. I then rolled back to 2.2.2.141. That didn't work. I then did an air gap on the Fan+Light switch. After I did that the switch did turn on the light, albeit after about 10-15 seconds, but then it wouldn't turn off.

I was able to go into the RM rule (with 2.2.2.141) and get it to work. I then was able to get it work with the Fibaro Key Fob. However, while the switch (the hall one with just the line, neutral and ground) was turning it on, it wasn't turning it off. I then tried to air gap the switch and that FINALLY worked. This one switch has been the most problematic one for me. Here is what the Z-Wave log for it looks like:

So it seems like it should be fine.

I'm going to go back to the future and try 2.3.3.125 again and see what happens.

I think you have some still unexplained issue with your Z-wave mesh that you noticed after the post-upgrade reboot, and that got confused with your router giving out a new IP address and your bookmarks not working. The IP address and the misbehaving Z-wave devices are two completely unrelated things. But while trying to resolve the issue, you've rebooted a whole bunch more times.

I would suggest you stop doing that (rebooting, upgrading, downgrading) for now and let your Z-wave mesh settle down. Since all the devices you are having issues with are Z-wave, I'd tackle this as an issue with the Z-wave mesh and start troubleshooting that.

3 Likes

Agreed...would be good to let things sit for a moment (there's nothing in 2.3.3.125 that is directly related to your issues AFAIK) - like a couple days and see what problems persist (or come to light).

Do you have a reservation set in your router?

Also post your entire z-wave details page so we can see if there is something up there.

I had locked in my ip address. Not sure how it became dynamic. It's been so long that I did it that I'll have to look up how to lock it to an ip again. Also, how do I find out what the current ip is so I know what to set it to or can I pick an address? I'm using a TP Link 3 piece mesh hub system and my hub is connected to one of satellites. (Which allowed me to move the hub to a much better location than the room where my modem is.)

As to reboots, I thought that like my phone or computer, it was a good thing to reboot it periodically when things started doing south. I always keep a backup and gracefully shut down. When I pull the plug it is always from the wall side, never at the hub.

As to upgrades, I waited a bit to help see if 2.3.3 was OK. I went back to 2.3.3.125 as I was under them impression that with the inevitable bug fixes it was best to get the latest version, especially since I thought there were a bunch of issues in 2.2.2.141 that 2.3,3 was going to fix as well as the major revamp of the rules.

Here is my Z-Wave table:




Here is my Z-Wave Topology, but I have no idea how to read that or know what it is telling me (but I understand you guys do).


@Stu_The_K You have several switches that are really struggling (9.6k) and several things are routing through those including your fob. That alone is going to slow your mesh down a lot and probably have drops.,,. You really need to get some beaming repeaters in placed (as always I recommend the Ring V2 Extenders) That may solve your problem. Someone else may chime in...

Download the Hubitat app