This just started happening on 4/12/23

This just started happening yesterday and only on 1 light. A Sengled Smart Led Zigbee.
I have lots of Sengleds in the the house and this is the only one that is not turning on from a EcoLink motion detector. Has worked for at least a couple of years with no issues. Now it doesn't turn on from the motion. And I tried a new Sengled and it also does not turn on. Very strange as all other light turn on and off properly. It does turn on manually from dashboard but not from Motion detector. Any help would be greatly appreciated. The code below is the from the logs and listed as error. Is the motion detector the issue?

org.codehaus.groovy.runtime.metaclass.MethodSelectionException: Could not find which method setLevel() to invoke from this list:
public java.util.List elementClassic#setLevel(java.lang.Object)

2023-04-13 16:34:46.330errororg.codehaus.groovy.runtime.metaclass.MethodSelectionException: Could not find which method setLevel() to invoke from this list:
public java.util.List elementClassic#setLevel(java.lang.Object)
public java.util.List elementClassic#setLevel(java.lang.Object, java.lang.Object) on line 1116 (method setLevel)

That error is coming from the device driver for the bulb (or at least likely is--that part was not included in your copy/paste), not the motion sensor. Some more information that would help troubleshoot:

  • What driver is the bulb using? This is listed under "Type" on the device detail page.
  • What app are you using to turn on this device (e.g., Basic Rule, Room Lighting, etc.), and how is it configured? (A screenshot may be helpful.)

Here's a screenshot. Thanks.

Most relevant information is missing from that screenshot, though it does show the app you must be using:

  • The driver ("Type", which you should see if you scroll up a bit)
  • The actual configuration of that app (click/tap the blue link to take you to that Simple Automation Rule app, and share a screenshot of how it is configured)

While you're in that Simple Automation Rule instance, try just hitting "Done" to see if that helps. Or maybe before that: total guess, but it looks like you might have it set to turn on to a level without having specified that level, so re-checking your configuration may also be helpful.

I fixed the problem by going back to Platform version

Something in the latest 235 seemed to have created a glitch of some type for certain Sengled blubs. All is working as expected now. Thanks for replying.

Probably not a great long-term solution should you wish to take advantage of improvements, new features, bug fixes, etc., that will come in newer FW releases.

It didn't seem (just based on what I see in this topic) like you really did any significant troubleshooting of the problem. Unless you're OK w/never being able to update the FW on your hub again, you might want to roll forward to and gather a little of the info suggested by @bertabcd1234 to see if there is a simple update/change that will resolve your problem. But up to you of course. :slight_smile:


I’m sure at some point in the next week the bug will be discovered by many others. I don’t have hours to troubleshoot Hubitat’s software update issues. I have better things to do with my time. I spent over 6 hours trying different things to make a single lightbulb tuen on. I think that’s enough time on spent on a problem that was created by a update.