Thermostat tiles broken 2.2.8.138

Hi Folks,

Anyone having issue with the thermostat tile? It appears the thermostat tile for my heating devices are changing 0.1 of a deg. for every button push, and no longer control my devices. I get the error like this....

I wish we could change this, as none of my heating devices like the decimal, every button push before was 0.5 deg and that gave me a little trouble, but two quick pushes solved it. It would be nice if it was a whole degree in my case.

@bcopeland

Yes I have the same situation with a Honeywell T6 Pro and the built in Generic Z-Wave Plus thermostat driver.

I have to admit the issue is my fault. Just today I posted how well my system was running and the lack of issues. As I wrote the post the thought at it precipitate an issue crossed my mind but I went ahead with the post anyway. Next time I'll remember :slight_smile:

Hmmm interesting. Is your tile now in 0.1 increments like mine? That has changed recently. I am using the built in Remotec ZXT-600 driver. I also have issue with an external driver for my StelPro Ki Heaters.

We are working on this issue right now. We made a change to 0.1° for °C, but that needs to revert back to prior increment of 0.5°.

1 Like

That's good news, thanks! A question though, is it possible to be able to choose the increments you need? Even 0.5 deg C messes with my heat pumps, as they only take 1 deg increments. Pretty sure my StelPro Ki heaters are the same. Possible to have two tile choices for increments? Never hurts to ask!

Yeah, we're looking at configurable step as the solution for this.

5 Likes

You folks are fantastic! Hubitat was a very good choice for me.

Does your thermostat on board menu allow you to define the setTemperature steps?

We are adding this ability soon.

3 Likes

Using the Average Temp app setting a Virtual Thermostat device in Fahrenheit. Getting the following error when attempting to set the thermostat tile temperature up or down with 2.2.8.138 on a C-4 Hub. Worked fine in 2.2.7 and older.

image

Fix for this coming in next release.

Ok does next release mean 2.2.9 or 2.2.8.1xx?

Hotfix coming soon...

2 Likes

Ok sounds good, will wait for hotfix. Thank you.

Damn. Saw the recent update and doesn't seem to have solved the thermostat tiles for me. Does that mean this is still outstanding?

Fix may require to clean cache to take effect, if not is there any error on the logs for that?

This is through android app dashboard. I have tried through browser,, same problem after clearing cache.

Only cool mode changes temperature from the tile. Only cool mode increments in 1 degree c as I set. Heat mode still increments 0.1 and temp value didn't change on device pages nor change the ac unit from the tile.

I see a device in my logs and an app.

Device shows an error. The app doesnt show any logs for any of the heat mode temp changes, only the cool mode changes.

Log of device.

errorjava.lang.ClassCastException: null (method setHeatingSetpoint)

Key point for me is cool mode works as expected from a tile. Heat mode doesn't. Device pages work fine.

Hi Bruce,

With this configuration setting, will it be per thermostat device, and will it be open to updates by custom drivers, e.g. as an attribute in the capability definition? I am keen to read the value for this in from the thermostat API I am developing with, rather than requiring user intervention. Not wanting to press you for the details, just interested to know if this will be possible or not.

Thanks,
Simon

Yep, still the same issue for me as well. Also note I am in heat mode too.

Bug confirmed, fix on the next build.

3 Likes

Download the Hubitat app