Thermostat Scheduler in 2.3.3

Finally got an opportunity to try replacing my legacy thermostat schedulers with the new 2.3.3 scheduler with my Honeywell T6 pro Zwave Thermostats.

I really like the new look and feel of the App....I'm going to like this a lot...but I'm running into a show-stopper for me at the moment. I'm not seeing a configuration option for "circulate" showing up in 2.3.3 scheduler's Fan Mode. I imagine this is related to the stock Honeywell T6 Pro driver's" supportedThermostatFanModes not providing for "circulate". (The driver does provide the ability to set "circulate" mode from the devices GUI which I have been using via rule 5.1)

Anyone know a way to add "circulate" to the supported fan modes for this driver from the GUI??

Also, I did have a minor problem when first configuring my 2.3.3 scheduler. I had an error when I first created the schedule and tried to rename a time period without first having a valid time entered for that time period. Here's the error I got in the logs

2022-09-27 11:29:59.688 amerrorjava.lang.RuntimeException: invalid time value on line 766 (method mainPage)

No biggie...I deleted and recreated the schedule again and this time entered the time period first...then changed the name of the time period. Just thought I'd mention it in case anyone else runs into this.

This is a driver shortcoming. Post a screenshot of the Current States from the device page.

If the device supports it, you can use the Generic Z-Wave Plus Thermostat driver. Just hit configure after switching.

I'm using a T6 Pro w/the generic Z-Wave Thermostat driver, and it includes Circulate as a Fan Mode.

Just tried the Generic Z-wave thermostat driver.. Worked like a charm and added the circulate fan mode!

Thanks guys!

1 Like

Sorry bravenel but I cleared the states and installed generic zwave thermostat driver before I saw your message. But I can confirm that the "supportedThermostatFanModes" setting did not include the "circulate" mode, even though I was able to set the fan mode to "circulate" by using the GUI or from a 5.1 rule. I would agree with you that "circulate" probably is missing from the initial "supportedThermostatFanModes" provisioning of the stock Honeywell T6 driver.

BTW since correcting the driver issue I now have the new thermostat controller and scheduler running on one of my three T6 thermostats....so far everything running very smooth. I'll convert the other two over in a day or two once I've verified everything continues to work smoothly.

1 Like

Download the Hubitat app