Thermostat Scheduler Always Sending Heat and Cool Points


#1

Thermostat scheduler is acting very strangely. I have the Thermostat set to Heat (no auto) but when Thermostat Scheduler is sends the setpoints it send both, the one for heating and the one for cooling. Well, this is really screwing up my thermostat. I thought it would only send the setpoint for the heating mode (heat or cool) that the thermostat is in. I am using a Z-wave GoControl Thermostat. Because it has a minimuim difference between the two setpoints, what ends up happening is the heating setpoint is always being set too low. Because having the same setting is comfortable if the thermostat is in Heat or in Cool. That's why I manually control which mode it is in and don't use the auto setting. This makes using Thermostat Scheduler much more difficult than I originally anticipated.


#2

Do you have different heat or cool set points? For example, heat daytime = 70, night time =65; Cool set point daytime = 70 night time = 75? I'm trying to figure out what you are trying to do. It sounds like you should be doing the configuring in the device settings and not be using the Thermostat Scheduler app. There you can set the mode to heat or cool. The scheduler looks like it forces the thermostat to auto. Delete the Thermostat Scheduler app and you will probably be able to accomplish what you want to do.


#3

That doesn't really matter, the problem is when the setpoints are the same. So, if I have Day mode at 70 for hear and 70 for AC, the thermostat has a self-imposed "delta" between the two setpoints. So, what ends up happening is the heat setpoint ends up dropping to 67. But the thermostat isn't in Auto mode. But Thermostat scheduler is sending the cooling setpoint 2nd which in turn drives the stat to conclude that it needs to change the Heating setpoint.

If I set all the cooling setpoints to 90, the problem disappears.


#4

In other words, it is not a problem with the thermostat scheduler. It is a hardware/firmware issue with the thermostat itself. It looks like you have a way to work around it.


#5

No, it is a problem with thermostat scheduler. Why is it setting the cooling setpoint when the thermostat is in hearing mode?
Maybe you don't think it's a problem but I do. So, thank you for your opinion.


#6

My guess is that the thermostat scheduler is (rightly IMO) completely independent of the current thermostat mode.

If it doesn't send both heating and cooling setpoints at every update point what happens if the thermostat mode changes from heat to cool (say) during a thermostat schedule period? If the cooling setpoint has not been sent for that period it will be wrong. I don't think it is reasonable to expect the thermostat scheduler to be constantly checking the mode of the thermostat and re-sending the setpoints according to mode.

I agree with @StephenH that it seems like a hardware specific issue.


#7

Then why does thermostat scheduler know the heating mode selected. It can't change from heating to cooling because it is not set to Auto mode.

I suggest you read the whole thing before commenting.


#8

I know the time in New York, but it doesn't mean I have to wake up based on it.

I did read the whole thing, and expressed my opinion on how and why scheduler works the way it does. But I am happy to leave you to argue with someone else about it.


#9

Everyone's entitled to their own opinion, so I'm not jumping into the argument part of this thread, but I 100% agree with @Ryan780 that this is a problem.

If you're in cooling mode it shouldn't send a heating set point, and if you're in heat mode it should not send the cooling set point - for the exact reason Ryan described... Minimum differentials on the thermostat side could cause unexpected behavior.

And that is not specific to his thermostat, almost every thermostat works that way.

I was just looking at this issue the other day. I've worked around it by adjusting my set points for the summer (lowered the heating set points past the differential delta), but the long-term answer is that thermostat scheduler needs to be changed, or someone needs to write a better behaved app.

I have no plans on writing a sharable app for this. If I do write one it will be a quick app that meets only my needs, not one that's publicly released. That's just way too much effort for me right now.


#11

I don't know if the Rule Machine would be able to do what you are asking. We all know the Thermostat Scheduler isn't doing what you want because the thermostat itself won't allow the same set points for both cooling and heating. Delete the Thermostat Scheduler and try the Rule Machine instead. If it works, great! If not, you are no worse off.


#12

It can definitely be done in a combination of RM rules. Or a custom app.

I'll submit an enhancement request to support to integrate that ability into Thermostat Scheduler, though, anyway.


#13

Is your thermostat reporting it's in heating mode?


#14

Yes, and it displays as much in Thermostat Scheduler.

That is what I am currently doing. I am setting the set by modes setpoints based on the Thermostat's operational mode (heat vs. cool). So, when in heating mode, all of the Cool setpoints are 90 and when in cool, all the heating setpoints are 50.

But since this doesn't seem to be getting any attention at all, tagging @patrick @bravenel @mike.maxwell. Would someone from the HE please comment? I would think that anything in the Support category should get some type of reply from staff even if it is to say that you're looking into tit. Some acknowledgement would be appreciated.


#15

So how is it supposed to know whether or not to send a setpoint? If you change the cooling setpoint while it is in heat mode, it shouldn't send it? I don't buy the argument that it should not send a cooling setpoint when it is in heating mode. Then, when you change to cooling mode or to auto, what should happen? If it sends the cooling setpoint then, and it's the same as the heating setpoint, the thermostat is going to react badly.


#16

We don't read and respond to every post made in Support category, as there are too many to do that. That is not an expectation you should have.


#17

Thermostat scheduler knows what mode the thermostat is in. Whether it's Heat:
image

Or auto:
image

or cool. So, I would think that it would only change the heat setpoints if in heating mode, only the cool setpoings in cool mode and both in auto mode. Wouldn't that make sense?


#18

No, that doesn't make sense. How then could you change the cool setpoint when it is in heat mode? You want to change it in advance so that when you flip to cool mode it has the desired temperature.


#19

This seems to be a special case. Obviously, thermostats don't support what you're wanting to do, and would require manual intervention to get the result you want.

Most thermostats use 2° required offset, some 3°. There would have to be an option in Thermostat Scheduler that would cause what you want to happen -- only when the two setpoints would fall within the required offset, thus avoiding the thermostat from changing the setting you put in.

Logic would be this: If setpoints close, and in heat (cool) mode, only send heat (cool) setpoint. Perhaps the option is as simple as just specifying the required offset, in effect defining what "close" means.

Update: Have added this feature to Thermostat Scheduler. Next release...


#20

Thank you.


#21

No... I don't. A perfectly valid use case is a set point of 70 degrees when it's in heat, and a set point of 70 degrees when it's in cool. You cannot do that today with thermostat scheduler.

Why should I have to artificially lower my heating set point to move it out of the way, when my thermostat is going to be in cooling mode for the next seven months?

Anyway you answered the question. I'll just make my own app that works the way I need it to.

If I flip the mode from heat to cool to auto, I will just proactively send the correct set point. That covers your use case about needing to preload the set point. I won't preload it, I will watch for a mode change and then send it proactively.