Thermostat Mode & Alexa

I have a 2Gig ct100 plus zwave thermostat.
I am using the builtin zwave thermostat driver and it generally works.

I am also using the builtin Thermostat Controller app.
So the virtual thermostat is called "Heater" and zwave thermostat is called "Heater Physical"

I now have a weird issue with "Heater" control from Alexa:
if I set the mode to "auto" for heater , and I try to increase setpoint using Alexa, response is negative:
I say : "Alexa, increase heater temperature"
Alexa: "Heater is not responding"
I say : "Alexa, set heater temperature 25"
Alexa: "it's set to auto"

if I set the mode to "heat" , it works:
I say : "Alexa, increase heater temperature"
Alexa: "OK" (temp. is increased by 0.5C)
I say : "Alexa, set heater temperature 25"
Alexa: "OK" (temp. is set to 25C)

why can't I control the thermostat when it is in "auto" mode ?

Additionally;
When I change the temperature of "Heater" (virtual device) , it triggers the real thermostat and if the condition is met , it starts heating.
However, I do not see the change on "Heater Physical" (zwave device) on dashboard or device page UNTIL I manually run "refresh" command on it.
note that "Heater Physical" is set to "auto" mode.

how can I make it refresh state automatically on dashboard and device page ?

I don't use Thermostat Controller and I don't use Alexa with my thermostats, but I have a couple of guesses about what might be happening. In auto mode, there are two setpoints to keep track of, the heating setpoint and the cooling setpoint. Maybe the thermostat doesn't know which to change when you tell it to change the temperature. I have found that ct100 thermostats don't reliably and promptly report the operating state (heat call, cooling call, idle, fan only) to hubitat except following a refresh call. Operating state is what determines the color of the icon on the dashboard. Maybe you need a rule that calls refresh on "Heater Physical" a minute after an operating state change on "Heater". I suggest the minute delay because the thermostat itself may not change operating state instantly.

1 Like

IIRC it has different keywords .. Like upper and lower temperature in auto mode..

1 Like

I tried this just now. This is not working...

These 2 suggestions may be true. But I have recently migrated from Smartthings hub to HE, and on Smartthings I didn't have this situation.

Btw, as I'm only using the thermostat for heating, as a workaround I set its mode to "heat" , and this way it works , I can control it using Alexa.
Is there any downside of using it in "heat" mode ?

And nobody else noticed this issue with "auto" mode ?

I just pulled the documentation from Alexa Smart Home Skill API.. The "Utterances" are lower setpoint and upper setpoint..

1 Like

ok. just tried this now:
"alexa, set heater lower setpoint to 25"
response: "it's set to auto"

:thinking: Ok.. it's been quite a while since I have tested this.. I'll set this up

1 Like

In your situation, where the thermostat never controls cooling, there is no downside.