Thermostat Device Temps are WILDLY wrong

These correlate to C so I think it's a conversion issue, but don't know if it actually matters? This is my first time setting it up:

I'm entering 72 for heat and 68 for cool.

what heating and cooling setpoints are shown in the Kumo cloud thermostat's driver details?

So it doesn't know which to use...

Should I convert everything to C?

there's an issue with this driver, it's reporting these whacky setpoint values.
it seems to me that the thermostat internally is reporting in F, but the driver thinks the device is reporting in C, and then converting this to F

Awesome, I'll let @sburke781 know, thank you!


I put the conversion in before I properly understood how it worked and never got around to removing it. I'll take it out and send out the updated drivers. Thanks for following this up @michaelahess and for your help @mike.maxwell.


My revised theory on this is still a work in progress, but I suspect I was a little heavy handed, both in the original code trying to convert everything from C to the HE hub scale, and again when I tried to fix this earlier this morning by removing all the "convert-if-needed" statements from C to the hub scale.

I suspect I need to distinguish between temperatures coming back from the Kumo cloud service, which I believe are in Celsius and need to be converted, verses those values entered by a HE user or rule / app etc, which would be in fahrenheit, for those in the US. This might be a little tricky...

1 Like