Thermostat Controller 2.2.5.128

Since the new update last night which had "bug fixes to Thermostat Controller" in the change log, I have errors in my logs and thermostats not working.
I am using the Zen thermostat to control my A/C unit.
The Thermostat Controller controls the Zen.

User symptom: A/C units did not kick in this afternoon (its summer here).
Apps>Thermostat Controller doesn't show the usual page, only shows:

Unexpected Error

An unexpected error has occurred trying to load the app. Check Logs for more information.

Error: Cannot invoke method minus() on null object

In the logs for the Thermostat Controller, at 'random' intervals:

app:7372021-02-04 20:53:53.617 errorjava.lang.NullPointerException: Cannot invoke method contains() on null object on line 554 (thermHandler)

any ideas @bravenel?

EDIT: and i should perhaps mention that i have 6 thermostats (2 different types), and i now get errors on all of them.

I just installed 2.2.5.131, now the app will not open "Unexpected Error"

An unexpected error has occurred trying to load the app. Check Logs for more information.

Error: Cannot invoke method capitalize() on null object

So I removed it and reinstalled incase that had to be done with the new update, still the same.

I am using the Remotec ZXT-600 built in driver. The app reinstalled normally but when I selected my thermostat I could not get back to the App. I have read in another thread here it may have to do with a line in the driver not configured properly and the App can't get the information it needs. I can't add the necessary line because it is a built in driver...

Can you post a screen shot of the device current states section of the driver details?

Sure can!! This is the controller

Controller Current States

And this is the Controlled. This thermostat is not currently being controlleld as I can't get into the app to set it up again.

ControllED Current States

I also have another untouched controller that controls a separate ZXT-600, Unable to access that app as well.

See the PM I sent you

Thermostat controller with same issue:
Error: Cannot invoke method capitalize() on null object
and Unexpected error opening the app. (version 2.2.5.131). I got the same error on 3 different Thermostat (Thermostat has built in driver).

Any suggestion?

HI sberardocco, Mine is still broken as well. What thermostat driver are you using?

Hi, mine is still broken: thermostat Fibaro Heath controller thermostat head

+1

Please post a screenshot of the logs showing the error.

Hubitat Elevation®
Platform Version: 2.2.5.131
Hardware Version: Rev C-7

Please show the setup page of Thermostat Controller.

Hi @bravenel, i had to remove the Thermostat Controller instances from my hub. The null errors in the logs referred to by others in this thread contributed to this decision, and more significantly for me for some reason the Thermostat Controller app was sending 'null' commands to my A/C units instead of sending 'off', which of course left them running when they should be off, and generated more errors in the logs. so to keep sanity in the household they had to be removed for now. if you like i can re-add an instance for some specific testing, but in the absence of active troubleshooting i had to stop the complaints from the missus...

OK, but I really need more details. The error on line 163 reported above was specific to that driver, which I believe has been fixed (it wasn't reporting thermostatOperatingState). The error in the original post on line 554 has been fixed, and is due for release in 2.2.6.

So, what thermostat are you using, and what error were you seeing. I hope you realize that we can only push out releases with bug fixes on a schedule with many moving parts. 2.2.6 is due out shortly and these problems are most likely fixed.

1 Like

Hi @bravenel,

I just updated o the new version: 2.2.6.140

And I receive the following error when I try to open a Thermostat Scheduler for the Fibaro thermostat from Apps menu:

Is it a new problem or still the same?

This topic was about Thermostat Controller.

For this Thermostat Scheduler error, I think you will need to remove it and recreate it. See if that resolves your problem.

Hi all,

I just added a Thermostat Controller and got this error.

Unexpected Error

An unexpected error has occurred trying to load the app. Check Logs for more information.

Error: Cannot invoke method capitalize() on null object

Log entry:
app:1222021-10-01 09:40:43.640 errorjava.lang.NullPointerException: Cannot invoke method capitalize() on null object on line 177 (method mainPage)

I can't configure the Thermostat Controller, help !

v2.2.8.156, Rev C-7

I was able to bypass this by adding a second Thermostat (a Virtual Thermostat).

Now the app runs, looks like it errors out when using only one Thermostat.

1 Like

Download the Hubitat app