"There was a problem loading the dashboard data" after update to

After updating to the latest platform version, I'm unable to load the webCoRE dashboard, getting an error "There was a problem loading the dashboard data. The data shown below may be outdated; please log out if this problem persists."
Background info:
I'm getting the error on 2 different PC's.
I logged out of webCoRE as the error suggested and registered new webCoRE instances on both PC's, but the error remains.
Rebooted the hub - still no luck.
Ran "Clean up and rebuild IDE data cache" successfully, but still no luck.
I have four instances of webCoRE (two on Smartthings Hubs and another two on HE hubs.) The pistons of the other 3 are accessible - I only get the error with the instance relating to the HE hub which I had updated immediately before the issue appeared.
Any suggestions or help assistance would be appreciated.

May be a database issue. Maybe try making/downloading a backup and try a soft reset with a restore from the backup?

Thank you. I made a backup before the update - should I rather use that backup, or is it better to make a new backup? I'm afraid of anything that concerns the word "reset". :frowning:

I would open a piston in the webcore IDE, then go back to the webcore main screen and see if anything changes.

If no change, you can try the logout of webcore IDE and reconnect.

Thanks for your reply.
On the PC's I had logged out, no pistons are showing after registering new instances of webCoRE.

On my laptop I have not yet logged out of the dashboard and tried as you suggested (opening a piston.) That produced this error:

Is there any messages or errors in the HE consoles HE console -> Logs ?

have you tried a polite reboot of the hub? (HE console -> Settings -> reboot) and let it settle?

You have seen:

The only webCore related messages in the log, are a few of these:
app:1092022-09-24 14:19:11.095errorOpenWeatherMap http Response Status: 408 error Message: api.openweathermap.org: Temporary failure in name resolution.

Other apps report similar errors:
app:972022-09-24 14:31:57.561errorError sending event to SharpTools.io: events.sharptools.io: Temporary failure in name resolution

dev:2012022-09-24 14:31:49.097warnWasher: distResp: [status:ERROR, httpCode:408, errorMsg:api.smartthings.com: Temporary failure in name resolution]

Could the problem relate to this issue? I'm going to reboot my router.

Thank you, did not think of looking at the logs. There must have been some sort of DNS error - after rebooting the fiber modem, I'm able to access the pistons.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.