The best wireless keypad?


#21

I think your initial problem was that you installed it upside down :stuck_out_tongue_winking_eye:


#22

I posted this elsewhere but I'm liking this iris keypad with HSM but for anyone else using one of these, is it expected operation that I have to enter any of my "codes" on the keypad, once to set them as Armed Home or Armed Away but I have to enter the "codes" twice to Disarm HSM. Or at least to have the Iris logo on the keypad go GREEN. It goes RED when armed.
FYI: The logs show no "errrors".


#23

Entering the codes to arm HSM is optional. I only have to enter the code once to disarm. Make sure your keypad is communicating with the hub, I had a ZigBee mesh issue with mine at one point. Also I've noticed that sometimes the light doesn't go green right away; the keypad will go back to sleep with the red light on and when I wake it back up the light is green.


#24

I just purchased a Ring Keypad but so far no luck is getting it added to the Hubitat. I think it needs to use secure inclusion and Ring provides a little slip of paper that has a "Device Specific Key" that you're supposed to enter somewhere on the Z-wave hub for the inclusion to work.

Does anyone have any idea what that means or if there's any way to do Z-Wave inclusion with this device on the Hubitat?

Thanks,
-Jeremy


#25

I believe you received the answer from Ring already. I bet Ring doesn't want their keypad installed somewhere else.


#26

Is that the PIN or QR code on the back of the device? If so, the manual suggest that is something you need if pairing with Z-Wave S2 security. Hubitat doesn't support S2, but I think S2 devices should fall back to S0 (which Hubitat does support) if S2 fails. In this case, you shouldn't need the key. (Not sure if that is behavior that is required by the standard or if there are exceptions for certain classes of devices.) Does it not work if you just try to pair it? It should at least show up as a "Device," though I doubt any stock driver would work with it.


#27

Yes it's on the back of the device and included on a separate slip of paper inside.

It does not seem to be falling back to S0. I spent a solid hour trying to get the Ring device to get "Discovered" in Hubitat and it never found anything at all (not even an unrecognized device, literally nothing would show up in the discovery list)

I was hoping it would at least show up as a device and then I could try to find a device handler from ST or something that might work with it, but no luck.

I ended up buying an Iris keypad instead: It works wonderfully. Apparently the Iris is actually manufactured by CentraLite because the Z-Wave manufacturer ID that comes through is CentraLite's Z-wave ID. Hubitat still doesn't automatically identify it as a CentraLite keypad but if you simply edit the device and choose the built in driver labeled "CentraLite Keypad" it works perfectly out of the box. (Except for the minor siren issue I had with HSM described in another thread.)

So to answer the title of the thread: The best keypad I've found so far is the Iris Keypad.


#28

The iris keypad uses zigbee, not z-wave.

And it should pair with the hub and assign the correct driver automatically. It did for me.


#29

If there's another keypad type that works with the keypad driver please provide the complete fingerprint, and I'll add it to the driver. Unfortunatly the only time this is available is by clicking the more button during device discovery.


#30

The newest version of the iris keypad, 3405-L2, must have a different fingerprint.


#31

The one I've just bought is a 3405-L and it works great with the Hubitat - Centralite Driver.
I just can't recall if I had to manual select the driver from the inbuilt ones or now. I don't think I did. :slight_smile:


#32

It's a good thing I was planning on buying another one. So I just went through the discover process again. The box labels it as: 3405-L1 (So it's not an "L2" as suggested)

The driver that Hubitat auto-selected was "Device". I had to manually select the "CentraLite" driver. Here's the signature data displayed when I clicked "More" during discovery:

Manufacturer: CentraLite Product Name: Device Model Number: 3405-L deviceTypeId: 15

manufacturer:CentraLite
address64bit:000D6F000E268F67
address16bit:3262
model:3405-L
basicAttributesInitialized:true
application:null
endpoints.01.manufacturer:CentraLite
endpoints.01.idAsInt:1
endpoints.01.inClusters:0000,0001,0003,0020,0402,0500,0501,0B05,FC04,FC05
endpoints.01.endpointId:01
endpoints.01.profileId:0104
endpoints.01.application:null
endpoints.01.outClusters:0019,0501
endpoints.01.initialized:true
endpoints.01.model:3405-L
endpoints.01.stage:4


#33

and when you switch to the build in driver, then hit configure, does the device work?
EDIT, apparently it does, I get lost with my posts.
Thanks for the FP, I'll add it to the existing driver...


#34

This Iris keypad followed me home from Lowes today. Looks different than I was remembering Iris keypads looking. Is this maybe a new model?. It is powered by 4 AA batteries. Was detected as Device. Changed driver to Centralite keypad.

Paired fine, and disarms HSM fine. Codes saved to it from Lock code manager fine. All 4 digit length. Haven't figured out how to get it to arm. Every time I click "On" or " Partial" , both with or without the code, it looks like it is going to work, then after a few seconds switches back to off. If I arm HSM using the dashboard, entering the code and pressing off key on the keypad does disarm.


#35

Yeah that’s new. I wonder if it’s any thinner than the old one; the old ones stick out from the wall a little more than I’d like.


#36

@marktheknife here’s the dimensions from Lowe’s website.
Height (Inches)
0.98

Width (Inches)
3.17

Depth (Inches)
4.94

Weight (lbs.)
0.32


#37

Still pretty thick. At least it takes better batteries.


#38

If these work like the older models, the code is only needed for disarming, both the partial and on buttons should arm home, arm away respectivly.
It looks like we don't have a fingerprint for this model, so I'll fetch on of these next time I get to lowes and make sure it works properly.


#39

It seems to almost work with the Centralite keypad driver, but not quite fully.
What it does correctly
If I arm HSM from my hubitat dashboard (away) - The keypad does accept / reflect the HSM state and the ""ON" button lights up.

If I arm HSM from my hubitat dashboard (home) - The keypad does accept / reflect the HSM state and the "Partial" button lights up.
If the alarm is armed in either state, If I enter any of the codes + "off" that were set through lock manager, HSM does disarm.

What doesn't work
The Centralite driver has a toggle for Require pin to arm. I have tried this with the toggle in both positions.
Entering the code + On or + partial, does not arm the system.
Just pressing the On or Partial do not arm the system, and produce this error. All code lengths are 4 characters

Panic button doesn't seem to have any effect when held in Hubitat. The Iris light does start flashing when panic is held.


#40

I picked up the new Iris L2 keypad. It paired as 'Device' but that's as far as I could get.
Hubitat shows it as:
Manufacturer: iMagic by GreatStar
Model: 1112-S