Tasmota ir bridge no child

I started today to try to integrate a YTF IR bridge into Hubitat. It is my first experience with tasmota and I spent a very happy few hours playing with soldering irons and jumpers. To my surprise it all worked so I have the device running 8.3.1(ir-he). I used the template specified for the YTF. I can receive ir commands and send them through the console. Perfect I thought. I then installed tasmota device manager and the only ir device I could find is the nedis but actually I am pretty sure this is what I actually have. I had to install it manually and it appears to be properly connected. It has not however created a child device, only the parent. Finally, having set all this up how do I actually send it commands from hubitat?

Sorry for being a muppet!

David

OK.

Now have a child, the issue was the 'reset5'. I will say that it is not obvious that you execute the 'reset 5' command in the terminal window of the tasmota device as I spent ages looking everwhere else for it! So.... moving on I now the child device is using a switch device. I think I can change that in the child device settings but I have no idea what to?

Did you make any progress? I just bought one of these on Prime Day.

This is working perfectly for me. The issue was not undersanding how to use the custom command in rule machine which was basically that it is only revealed when you use 'presence' as the device type. I point the IR sender at the device, press the button, look at the string in the device events and then copy and paste it into rule machine. I have them running my bedroom fan and an aircon unit

Nice, Thanks! I'll get mine on Saturday. Did you get to use Tuya Convert to get Tasmota on it? I've got a great jig to snap onto the chip, so I can do either.

No took it apart and used a soldering iron :slight_smile:

Thanks. Crazy thing is I just got everything working this am via CEC over HDMI with the Roku Stick+, Sony TV, and Onkyo AV receiver. The Roku remote is now turning all on/off, and turning the volume up/down for the AV receiver only - exactly what I have been trying to do.
The single Roku remote does it all! Happy Wife, happy Life!

OK, I got tasmota-ir 8.3 HE version on it, I told it to be the YTF Bridge. I added it via Tasmota Device Manager, and it also did not see a child created. I did a reset 5 again, started over, and after that a child showed up.

I also figured out the IRSend syntax from command line. That took me a while!

Edit again! I finally figured it out. I saw the other thread that showed how to use presence, I was putting it all in one string. Once I made it two strings, it worked.