T4HE by markus-li - need help

I have used the Tasmota for HUbitat Elevation from Markus and it created the device. here is what is happening:
when I turn off/on the device from the hubitat the device works fine and the status on tasmota web UI updates correctly.
when i turn off/on the device using tasmota web UI the device works fine but it never updates the status on Hubitat unless i press refresh button in the device page.
when i turn off/on the device on the device itself, it updates on tasmota but it never updates the status on hubitat unless i press refresh button in the device page.
the Mqtt is disable on the tasmota device. HUE emulation is enabled, HTTP API is enabled. the device is falshed with tasmota version 11.0

here is a snapshot of the parent device debug log

also I am always getting a timeout message on the Tasmota device manger as shown below

it is very critical for me to fix this issue since the sonoff mini can be hard wire on S! and S2 to the switch to turn of/on the device. then if the device is not being able to send the status to hubitat then the dashboard will not display the actual status of the lights. :frowning:

please help

thank you everyone


Am also using T4HE for the last 1 1/2 years with about 20 Tasmotized devices (light switches, power monitoring outlets etc). Everything seems to coordinate states between physical switch, Tasmota app, and Hubitat. Not sure if this is the issue but since I am using Markus’ T4HE, I have not updated Tasmota on my devices as it was my understanding that 8.5.1 was the latest confirmed working version. I understand that some others have commented that there is another HE Tasmota app available that allows you to use more recent versions of Tasmota but I not bothered to update as I am still successfully using Markus’ app with my older 8.5.1 flashed Tasmota devices.

As much as I like Tasmota, my main concern with using it with Hubitat is the fear that some future change in the HE software may suddenly make the no longer supported T4HE inoperable. Luckily, so far this has not happened but . . . . .

Thank you Moh for your reply.

I notices that T4HE mentioned tasmota ver 7.x and 8.x. I tried the version 7.2.1 but I got the same issue. I still need to press the refresh button on the device page in hubitat to update the status. Then i tried 8.5.1 and i got the same problem.

I will keep digging around until someone can help me with that. I followed Markus steps and I really liked this software.
If I do get the update automatically from the tasmota devices then I am in a dead end and the automation for my house is useless.

are you using any sonoff devices in your system? I doubt it is the device. it is in hubitat driver only. why I have to refresh the device to get the update?

Thanks again.

from the logs it seems the device is restarting for no reason? or are you restarting it? If not it looks like it's crashing which could be a bad flash or maybe it's overheating or overloaded?
EDIT- found this. possibly caused by interference or large loads within house wiring...maybe

Markus had modified his Tasmota driver to send updates to the hub. In that firmware version, this is where the IP of the Hubitat Hub is added, under “Configuration” then “Configure Hubitat / SmartThings”:

Otherwise, you will need to poll the device.


@Sebastien , that seems a likely solution for @user3. I just assumed that @user3 had T4HE configured properly but if the HTTP Hook was not properly set with the hub’s IP as Host, then the devices would indeed need to be polled to keep the device status in sync (and the problem with that would be the polling interval). Good catch as usual. I am curious if this solves the problem for @user3, especially given his use of Tasmota 11.0 (as I mentioned, I am not comfortable reflashing my devices to upgrade to v11.0 as everything currently works and I do not really need any upgraded capabilities of v11.0, although I might give it a try if I decide to flash any new devices). IIRC, a while back someone had written a mod to Markus’ app to accommodate using Tasmota v9 devices or something like that. Hopefully @user3 will let us know how it goes.

1 Like


Make sure you flash Markus' tasmota 8.51 version. Then follow @Sebastien post about putting the ip of your hub in the tasmota config page.

It works as I had used his tasmota integration for a period of time.

You can't use stock tasmota version 11

I was concerned about this also and have switched to stock tasmota and node-red. I use tasmota for my diy devices.

1 Like

Thank You Sebastien, I need to flash all my sonoff devices with this tasmota version that is highlighted in the picture where i can put the put address of my hub. can you please send me the link for this version. I am still on a learning curve.
Also, i am using ohlabs to create my tasmota devices in my hub

The challenge I am facing is that when i use this app to create a device for tasmota sonoff pow R2 that has power data like volts, amps, power coomsumption etc like in the below picture

i do not get these data anywhere even in the parent device or child device (BTW I downgrade it to tasmota 8.1.0 but it is not working still)
see below:

this is for the child device

kindly asking for your advice

Thank you Kuzenkohome

As I have mentioned to sebastien, I am still on a learning curve. can you please share with me the link for markus tasmota 8.5.1.

i appreciate it if you also give me your feedback on how to read the power values from a tasmotized sonoff device like PowR2.
am I using the right app to create the device and read all these values?


@user3 ,
I have a number of Tasmotized Sonoff S31 with power monitoring enabled (no experience with, and am not familiar with the PowR2) that I flashed with tasmota 8.5.1 so not sure if my info is applicable to your situation but . . .

Again, not sure if this is part of the problem (other than v11.0 not being compatible with T4HE) but I seem to recall (its been about 1 1/2 years since I did this) that after setting up my Tasmota Device Manager settings that I had to remember to save my preferences and also had to click on “Configure” to get the settings saved to the device prior to saving the device in order to update the Current States data of the device (in my case, a Sonoff S31 and several light switches).

1 Like

Here is the link to Markus' github page with complete instructions. The link to his tasmota versions is on the right side of the page under "Tasmota Topics" What @moh linked to is the stock 8.51 version which does not have the integration with Markus' HE driver. You need to use Markus' specific version of Tasmota with his HE drivers. Everything is described in the wiki below.

I don't remember if this setting was present in 8.51 but in the Tasmota "Configuration" --> "Configure Other", make sure you check the box labeled "Activate" in the "Template" section. This tripped me up a couple of times as this actually activates the template.


@user3 ,
@kuzenkohome is correct and I stand corrected (as I stated, it has been quite some time since I had loaded Markus’ stuff and reflashed my Tasmota devices. The most updated drivers that Markus loaded was 8.5.1 which is on the right side menu of the wiki page that @kuzenkohome referenced. I now recall that Markus would reference the link that I posted (incorrectly, sorry) as the source material for his slightly modified driver. Unfortunately, when Markus was “disappeared” from this community, all his posts that I used to set up my hub also disappeared. Anyway, a quick link directly to his device drivers modded for Hubitat is:

Again, it has been a while since I played with this stuff since Markus was “disappeared” from Hubitat and this community, out of my fear/concern that the compatibility of T4HE would also be “disappeared” as well by the HE staff. Because of this, I have not incorporated any more Markus modded Tasmota devices into my home automation and along with the loss of all of Markus’ helpful posts (and old man memory) I recalled the wrong link. Luckily, so far everything continues to work with this older modded driver and with his now non-supported T4HE, but who knows what will come with any future hub firmware updates. Until then, I will just keep using my Tasmotized devices and am slowly transitioning some of them to Zigbee or Z-wave Plus devices (am also looking forward to some Z-wave LR devices coming to market for longer range and less power usage).

Anyway, sorry for any confusion my previous link may have caused. My bad.


I have done some searching on the web and I found tasmota v10 with http hook. i tasmotized my sonoff mini with it and i configure it correctly as per your feedback and it worked like a charm. i also tried the version 8.5.1 by hannah but i found out that the switch will not work even if i select GPIO4 as a switch.
The only challenge I faced with that procedure was that the tasmota v10 with http hook comes as a file with bin.gz format which tasmotizer program does not recognized. So I have to do two steps to tasmotize the sonoff mini from 8.5.1 then to version 10 with http hook.

Since it is sorted out now, i still would like to see if someone had the chance to pull out the power data from any sonoff device like PowR2 or PowR3 that provides power data.

BTW thank you for sharing the link. i will try it on the sonoff powr2 see if it gives both the switch status and the power data.

I have tried the below driver and it works fine as pulling all power data from the device but it has the same problem that the switch status is not updated. the power data is also slow to update in this code

this was my only alternative to T4HE from markus. But i still need the both functionality.

I am not a programmer but I wish if someone can modify the code from mark to read the update from of the switch using hhtp hook and verify which tasmota version will work with it.

To display the data I am using

it is a wonderful piece of software. this is the sample of my dashboard for sonoff tasmotized powR3 but the switch is not updating. i will do some flashing with older versions to see if it will work with the switch.

Again thank you all for your feedback and I am looking forward for your replies.