Switch, dimmer & receptacle status LED (Jasco) assistance


I tried searching for information about setting the status LED on these devices. As I'm sure everyone knows, the indicator can be set to disabled, OFF - when receptacle ON or OFF - when receptacle OFF. There doesn't seem to be an option (at least for the dimmers) in device settings. I know in SmartThings this could be configured through the app.

I plan to learn groovy coding, but in the interim in case I'm just missing something, can anyone confirm whether I need to write something to do this or if it's just somewhere I haven't located it?


Do you have the model number(s) (or the manual)? In Hubitat you can do this fairly easily if you know the z-wave parameter & value for that setting.

Here's how to do it.

Temporarily change the driver to Basic Z-Wave Tool. This is a Hubitat driver that is available from their GitHub (https://raw.githubusercontent.com/hubitat/HubitatPublic/master/examples/drivers/basicZWaveTool.groovy).

Make the change you want, then revert back to the original driver. Be sure to hit "Configure" on the device page after changing the driver back to the original.

1 Like

For the current-model Jasco/GE Z Wave Plus receptacle, LED control is built into the stock driver and works fine. I have 4 of these installed and use both the on-when-on and on-when-off modes.


Most importantly, are you using the new ZIGBEE receptacles, or the Zwave+ receptacles? The Jasco/GE 43102 Zigbee receptacle does NOT offer LED control through the Generic Zigbee Outlet driver.


1 Like

Hey Guys,

Thanks for all the replies! I was sure that the motion dimmers also had a status indicator since they can also be activated manually. However, they don't appear to (except for some functions such as a factory reset). The receptacles and switches do have the option to configure, as mentioned. My apologies for jumping the gun. When I posted, I had not yet got to the receptacles. All is great now. As always, I appreciate the support of the community!

1 Like